Subject: [lisp] One comment to draft-ietf-lisp-type-iana-05.txt

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Feb 2017 10:26:13 -0800

Mohamed, the statement “This document updates RFC6830.” is too broad and easily open to misinterpretation. See my suggestion below.

I suggest this wording (and possibly not in the abstract):

This document introduces a new LISP message type so extenstions to the protocol may be experimented with. The code point is defined in RFC6833bis in which this document references as well as describes how the sub-types for the code point are used.

Dino

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 2 Feb 2017 13:44:22 -0500

I had not realized we intended to defer creation of the registry until 
we publish 6833bis.

Yours,
Joel

On 2/2/17 1:26 PM, Dino Farinacci wrote:
> Mohamed, the statement “This document updates RFC6830.” is too broad and
> easily open to misinterpretation. See my suggestion below.
>
>
> This document introduces a new LISP message type so extenstions to the
> protocol may be experimented with. The code point is defined in
> RFC6833bis in which this document references as well as describes how
> the sub-types for the code point are used.
>
> Dino
>
>
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Feb 2017 10:58:27 -0800

Did we? Why can’t it all be independent? 

Dino

> On Feb 2, 2017, at 10:44 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> I had not realized we intended to defer creation of the registry until we publish 6833bis.
> 
> Yours,
> Joel
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 2 Feb 2017 14:06:59 -0500

Ithink we need to take care with the wording so that we do not introuce 
a normative dependence on 6833bis.  The wording I saw in your email 
looked like it would produce such a dependence.

Yours,
Joel

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Feb 2017 11:10:20 -0800

I guess it did. But should it have a normative reference to RFC6830 where type=15 is not documented?

Dino

> On Feb 2, 2017, at 11:06 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> Ithink we need to take care with the wording so that we do not introuce a normative dependence on 6833bis.  The wording I saw in your email looked like it would produce such a dependence.
> 
> Yours,
> Joel
>