Subject: [lisp] I-D Action: draft-ietf-lisp-type-iana-05.txt

From: [email-masked]
Date: Wed, 01 Feb 2017 23:27:55 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Locator/ID Separation Protocol of the IETF.

        Title           : LISP Shared Extension Message & IANA Registry for LISP Packet Type Allocations
        Authors         : Mohamed Boucadair
                          Christian Jacquenet
	Filename        : draft-ietf-lisp-type-iana-05.txt
	Pages           : 6
	Date            : 2017-02-01

Abstract:
   This document defines a registry for Locator/ID Separation Protocol
   (LISP) Packet Type allocations.  It also specifies a LISP shared
   message type for defining future extensions and conducting
   experiments without consuming a LISP packet type codepoint for each
   extension.

   This document updates RFC6830.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lisp-type-iana/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-lisp-type-iana-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-type-iana-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 2 Feb 2017 10:23:25 -0800

Mohamed, the statement “This document updates RFC6830.” is too broad and easily open to misinterpretation. See my suggestion below.

I suggest this wording (and possibly not in the abstract):

This document introduces a new LISP message type so extenstions to the protocol may be experimented with. The code point is defined in RFC6833bis in which this document references as well as describes how the sub-types for the code point are used.

Dino

> On Feb 1, 2017, at 11:27 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: <[email-masked]>
Date: Fri, 3 Feb 2017 06:25:04 +0000

Hi Dino, all,

I do think the NEW text in -06 is clear about the update:

   This document updates RFC6830 by defining a registry for LISP Packet

   Types assignments.

RFC6833bis will need to point to the registry to define new control messages. No need to add a reference to RFC6833bis, IMHO.

Cheers,
Med

De : lisp [mailto:[email-masked]] De la part de Dino Farinacci
Envoyé : jeudi 2 février 2017 19:23
À : [email-masked]
Cc : [email-masked]; [email-masked]
Objet : Re: [lisp] I-D Action: draft-ietf-lisp-type-iana-05.txt

Dino

On Feb 1, 2017, at 11:27 PM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

_______________________________________________
lisp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 3 Feb 2017 10:37:24 -0800

Okay, thanks.

Dino

> On Feb 2, 2017, at 10:25 PM, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Dino, all,
>