Subject: Re: [lisp] Alvaro Retana's Discuss on draft-ietf-lisp-type-iana-04: (with DISCUSS and COMMENT)

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 1 Feb 2017 09:47:05 +0000

Thanks Med!

Alvaro.

On 1/31/17, 9:54 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

About the text you proposed below…  The LISP Packet Type Registry (4.1, not 5.1) has only 15 possible values, 7 of which are assigned/reserved by this document, rfc6833bis assigns 3 more values, and this document mentions 5 potential extensions (“new message types are proposed in [I-D.ietf-lisp-ddt], [I-D.zhao-lisp-mn-extension], [I-D.boucadair-lisp-bulk], [I-D.ermagan-lisp-nat-traversal], or [I-D.boucadair-lisp-subscribe]” [*])…bringing the total up to 15.  Even if not all these new drafts make it, the LISP Packet Type Registry will soon have no more values to assign.  The result will be that the Sub-Types (in the LISP Shared Extension Message Type) will be used for production [1].

[Med] Agree.

IOW, I don’t think you need a transition mechanism.  Instead, I think you need to recognize that the Sub-Types will be used for production deployments.  Suggestion:  consider changing the registration policy from FCFS to something where part of the space requires Standards Action, or maybe RFC Required or even Expert Review.  The result of FCFS is that anyone can request a value and get it: “There is no substantive review of the request, other than to ensure that it is well-formed and doesn't duplicate an existing assignment.” [rfc5226]

[Med] The motivation for using FCFS is to avoid imposing heavy constraints on designers to register their extensions. Also, given that we have 4096 sub-type values, the full range cannot be consumed completely even with a FCFS policy. That’s said, I agree with you it might be more safe to secure a range for assignments via Standards Action (e.g., 0-1023) and leave the 1024-4095 for FCFS. I can make such change.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 1 Feb 2017 09:48:49 +0000

Cleared!

On 1/31/17, 5:31 PM, "BRUNGARD, DEBORAH A" <[email-masked]<mailto:[email-masked]>> wrote:

As you noted, the document’s status was changed from PS to Experimental based on the RTG Directorate Review. I’ve changed it on datatracker (missed it). Agree, no need to rerun Last Call for this.