Subject: [Jsonpath] Fwd: I-D Action: draft-bormann-jsonpath-iregexp-02.txt

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Jan 2022 02:13:31 +0100

In preparation for tomorrow’s interim meeting, I submitted a version of iregexp that is further streamlined (by removing multi-character escapes, i.e., \s, \d, \w and their uppercase equivalents, which caused more complexity than one would think).

This should now be really easy to implement on most platforms that do have a somewhat modern (Unicode-capable) regexp flavor.  One can lament the loss of multi-character escapes, but these were a cause of interoperability surprises with regexps before.

I hope we can pick this up for solving jsonpath issue #70.

See you all in < 9 hours!

Grüße, Carsten

> Begin forwarded message:
> 
> […]
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : I-Regexp: An Interoperable Regexp Format
>        Author          : Carsten Bormann
> 	Filename        : draft-bormann-jsonpath-iregexp-02.txt
> 	Pages           : 11
> 	Date            : 2022-01-17
> 
> Abstract:
>   "Regular expressions" (regexps) are a set of related, widely
>   implemented pattern languages used in data modeling formats and query
>   languages that is available in many dialects.  This specification
>   defines an interoperable flavor of regexps, I-Regexp.
> 
>   The present version -02 of this document is a more streamlined update
>   of the original trial balloon, meant to determine whether this
>   approach is useful for the JSONPath WG.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-bormann-jsonpath-iregexp/
> 
> There is also an HTML version available at:
> https://www.ietf.org/archive/id/draft-bormann-jsonpath-iregexp-02.html
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-bormann-jsonpath-iregexp-02

---

From: Greg Dennis <[email-masked]>
Date: Tue, 18 Jan 2022 04:59:00 +0000 (UTC)

Carsten, you have closed a number (lot) of issues recently, but it seems that many of them were open discussions still.
It would be helpful if a summary of the decision or change were included in the closure.
ThanksGreg

  On Tue, 18 Jan 2022 at 2:13 pm, Carsten Bormann<[email-masked]> wrote:   In preparation for tomorrow’s interim meeting, I submitted a version of iregexp that is further streamlined (by removing multi-character escapes, i.e., \s, \d, \w and their uppercase equivalents, which caused more complexity than one would think).

Grüße, Carsten

-- 
JSONpath mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Jan 2022 07:25:01 +0100

Hi Greg,

On 2022-01-18, at 05:59, Greg Dennis <gregsdennis=[email-masked]> wrote:
> 
> Carsten, you have closed a number (lot) of issues recently,

25, I think.

> but it seems that many of them were open discussions still.

If by that you mean “wide open, meandering, aimless discussion”, I can probably agree :-)
Actually, many discussions were useful at their time, but are no longer providing actionable content with the direction the document has taken.

> It would be helpful if a summary of the decision or change were included in the closure.

I think I added a comment why I closed them to each of them.
7 of them also got a “revisit-after-base-done” tag, so we remember to look at them once the base document is done:

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues?q=is%3Aissue+label%3Arevisit-after-base-done

If you don’t agree with closing one of the 25 issues, please:
- do one of:
  — reopen the issue,
  - add a revisit-after-base-done tag, or 
  - add a new issue that focuses the question we actually need to decide
— also, please bring it up in the interim today.

Thank you!

Grüße, Carsten