Subject: [Jsonpath] I-D Action: draft-ietf-jsonpath-base-03.txt

From: [email-masked]
Date: Sun, 16 Jan 2022 14:01:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the JSON Path WG of the IETF.

        Title           : JSONPath: Query expressions for JSON
        Authors         : Stefan Gössner
                          Glyn Normington
                          Carsten Bormann
	Filename        : draft-ietf-jsonpath-base-03.txt
	Pages           : 31
	Date            : 2022-01-16

Abstract:
   JSONPath defines a string syntax for selecting and extracting values
   within a JavaScript Object Notation (JSON, RFC 8259) value.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-jsonpath-base/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-jsonpath-base-03.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-jsonpath-base-03

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 16 Jan 2022 23:04:55 +0100

-03 consolidates all the changes we have had since -02, which was about 2.5 months ago, so it has been overdue for a while.  -03 is intended as the document to look at for and at the 2022-01-18 JSONPath interim.

Grüße, Carsten

> On 2022-01-16, at 23:01, [email-masked] wrote:
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 17 Jan 2022 14:10:13 +0100

... I did some work on ABNF texts. Especially I tried to get equality 
comparisons of structured values right.
--
sg

Am 16.01.2022 um 23:04 schrieb Carsten Bormann:
>> On 2022-01-16, at 23:01,[email-masked]  wrote:
>>
>>
>> Internet-Draft directories:http://www.ietf.org/shadow.html
>> orftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 17 Jan 2022 14:10:54 +0100

pull request is here ...

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/compare/main...goessner:main

Am 17.01.2022 um 14:10 schrieb Stefan Gössner:
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
> 	Virenfrei. www.avg.com 
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>
>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 17 Jan 2022 14:14:23 +0100

hmm ... here

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/145