Subject: [Jsonpath] Broken reference

From: Glyn Normington <[email-masked]>
Date: Tue, 6 Jul 2021 10:38:28 +0100

PR 142 produced a broken reference for no apparent reason. I re-ran
the github "Update Editor's Copy " job and the error persisted. The
referenced datatracker item seems ok. Does anyone know what the
problem might be and how to fix it?

Here's where the broken reference is visible:

https://tools.ietf.org/rfcdiff?url1=https://ietf-wg-jsonpath.github.io/draft-ietf-jsonpath-base/draft-ietf-jsonpath-base.txt&url2=https://ietf-wg-jsonpath.github.io/draft-ietf-jsonpath-base/authorship/draft-ietf-jsonpath-base.txt

Regards,
Glyn

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Jul 2021 12:26:17 +0200

On 6. Jul 2021, at 11:38, Glyn Normington <[email-masked]> wrote:
> the github "Update Editor's Copy " job and the error persisted.

I can’t find the error in

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/runs/2997375664?check_suite_focus=true

But I’m not sure I’m looking at the right place.

The previous build was in

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/runs/2997326523?check_suite_focus=true

And that indeed shows one of the temporary failures we have seen for the DNS server for rfc-editor.org:

/root/.cache/xml2rfc/reference.RFC.6901.xml: fetching from https://www.rfc-editor.org/refs/bibxml/reference.RFC.6901.xml
15
*** Can't get with persistent HTTP: Failed to open TCP connection to www.rfc-editor.org:443 (getaddrinfo: Try again)

16
*** Failed to open TCP connection to www.rfc-editor.org:443 (getaddrinfo: Try again) while fetching https://www.rfc-editor.org/refs/bibxml/reference.RFC.6901.xml
17
*** No such file or directory @ rb_sysopen - /root/.cache/xml2rfc/reference.RFC.6901.xml for /root/.cache/xml2rfc/reference.RFC.6901.xml

18
** Can't manipulate reference XML: undefined method `attributes' for nil:NilClass

19
*** KRAMDOWN_OFFLINE: Inserting broken reference for reference.RFC.6901.xml

The next build you started got this right, but did not update the GitHub pages.  I don’t know why it didn’t.
The artefact https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/suites/3167323681/artifacts/72923752 looks right.
But the stage “Update Github Pages” is simply struck out in https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/runs/2997375664?check_suite_focus=true

Rerunning…

Update still crossed out.
Interesting.

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Tue, 6 Jul 2021 16:22:11 +0100

After making a text change, the broken reference has healed itself up.
The update step is still crossed out. Oh well...