Subject: [Jsonpath] June interim meeting

From: Tim Bray <[email-masked]>
Date: Sun, 13 Jun 2021 21:07:58 -0700

I don't know who's coming but I just spent a certain amount of time looking
at our PR list and, while I have opinions about the details, I think it's
difficult to follow the rapid evolution of these discussions over the last
week or so.

This is to ask Greg/Glyn/Carsten/Stefan for their help in walking us
through which of these selector--definition and terminology issues are
considered "open" and worthy of WG time at the meeting.

Should someone want to post a summary/overview note before the meeting that
would also be useful.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 07:32:15 +0200

On 14. Jun 2021, at 06:07, Tim Bray <[email-masked]> wrote:
> 
> I don't know who's coming but I just spent a certain amount of time looking at our PR list and, while I have opinions about the details, I think it's difficult to follow the rapid evolution of these discussions over the last week or so.  

I would prefer if we could merge the ready-to-merge PRs (#94, #101) and get the other ones rebased on those.
With enough time before tomorrow’s meeting that we can still prepare slides.

Can the document authors please get the merging done quickly, so the submitters can rebase their PRs?
This is not the time to be shy — I know there are authors on the document that are invisible, but this will have to be done by the ones who have been doing the work.

(I apologise for forking #99 off #98; I hope I have explained why the tooling made this necessary.
I don’t know how “alive” #75 is; the actual PR would need rebasing after the selector work has progressed.)

So there really only is

— #97, which after rebasing is a single remaining change.  That needs discussion, because it is indicative of a fundamental problem we haven’t addressed yet.
— #99 (with most of the discussion in the thread on #98), which desperately needs to be split up into smaller PRs building on top of each other.

> This is to ask Greg/Glyn/Carsten/Stefan for their help in walking us through which of these selector--definition and terminology issues are considered "open" and worthy of WG time at the meeting.

I can certainly make a slide or two on the remaining significant terminology issue.
(That doesn’t mean terminology is otherwise done, it’s just good enough that work can continue on technical content.)

> Should someone want to post a summary/overview note before the meeting that would also be useful.

Given the short time remaining, I’d prefer to do that in the form of slideware.

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 14 Jun 2021 10:38:00 +0200

I collected some topics worth discussing from my point of view ...

/* ==========

## Topics - June interims meeting

### Terminology

* *primitive/atomic/simple* value types vs. 
*complex/structured/container* value types. Two common terms seem to be 
needed here.

### Selectors

* Fundamental point is the alternate wording in text ... :
     * ... selects a value.
     * ... selects a node.

Both is possible with Jsonpath, but we should stick with one throughout 
the text.

* Is a dot-member name allowed to start with a DIGIT?
* Are unions allowed to contain wild cards, descendant-selectors and 
filter-selectors ?
* Do we need to specify the order of evaluation of the 
`descendant-selector`?
* Discuss the proposed lean backward compatible syntax `[?<expr>]` in 
contrast to original `[?(<expr>)]`.
* Discuss proposal of `in-op` operator.
* Should comparison with structured values be allowed?
* What's the opinion about supporting functions? Related to this is: How 
to access a specific member in `{...,"key":5,...}` via filter expression 
`[?@...]` ?

==========*/

--
sg

Am 14.06.2021 um 06:07 schrieb Tim Bray:
> I don't know who's coming but I just spent a certain amount of time 
> looking at our PR list and, while I have opinions about the details, I 
> think it's difficult to follow the rapid evolution of these 
> discussions over the last week or so.
>
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
> 	Virenfrei. www.avg.com 
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>
>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 10:39:39 +0200

I’m using these now for making my slides…

Plan to have them ready to look at before 0930Z.

Grüße, Carsten

> On 2021-06-14, at 10:38, Stefan Gössner <[email-masked]> wrote:
> 
> * *primitive/atomic/simple* value types vs. *complex/structured/container* value types. Two common terms seem to be needed here.
>  
> 
> ### Selectors
> 
> Both is possible with Jsonpath, but we should stick with one throughout the text.
> 
> * Are unions allowed to contain wild cards, descendant-selectors and filter-selectors ?
> * Do we need to specify the order of evaluation of the `descendant-selector`?
> * Discuss the proposed lean backward compatible syntax `[?<expr>]` in contrast to original `[?(<expr>)]`.
> * What's the opinion about supporting functions? Related to this is: How to access a specific member in `{...,"key":5,...}` via filter expression `[?@...]` ?
> 
> ==========*/
> 
> --
> sg
> 
> 
> 
> 
> 
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 14 Jun 2021 10:53:51 +0200

I forgot

### Selectors

* What's the opinion about support of arithmetic operators in filter 
expressions?

--
sg

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 11:01:20 +0200

> Plan to have them ready to look at before 0930Z.

I put them up at

https://github.com/ietf-wg-jsonpath/slides-wip/blob/main/2021-06-15-jsonpath-cabo.pdf

(I could have put them into meeting materials, but I’d rather keep any issues, comments, outside of that repo.)

I also put the markdown source there,

https://github.com/ietf-wg-jsonpath/slides-wip/blob/main/2021-06-15-jsonpath-cabo.md

Please be bold and edit...

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 11:04:52 +0200

On 2021-06-14, at 10:53, Stefan Gössner <[email-masked]> wrote:
> 
> * What's the opinion about support of arithmetic operators in filter expressions?

Indeed.
I already had that on slide 9, so I didn’t add a slide (but I of course could).

Obviously, slide 13 to 19 are still placeholders; I plan to fill in some of the discussion in #98 if there is any.

I think the underlying problem (and solution) is that we need to clearly separate the expression language from the way it is used in the selectors; that will clean up both and be simpler to work with.

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Mon, 14 Jun 2021 11:12:14 +0200

separating expression language from its usage in selectors is a good idea.
--
sg

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 11:16:43 +0200

On 2021-06-14, at 11:01, Carsten Bormann <[email-masked]> wrote:
> Please be bold and edit…

Or if you just want to comment, github makes that convenient on

https://github.com/ietf-wg-jsonpath/slides-wip/commit/8ef149a

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Mon, 14 Jun 2021 10:52:48 +0100

> With enough time before tomorrow’s meeting that we can still prepare slides.

I have merged PRs 94 & 101 and asked the raisers of the two other
non-draft PRs to rebase.

---

From: Greg Dennis <[email-masked]>
Date: Mon, 14 Jun 2021 12:39:56 +0000 (UTC)

#97 has been rebased.
Carsten, would you explain your understanding of the difference between string in JSON and strings in JSONPath, please?  Isn't JSONPath built on JSON?  Wouldn't that necessitate the same definition?  You've been rather aggressive with comments on strings, but you haven't offered any alternatives or reasons for your objections.  You've simply stated that what Stefan and I have written is wrong.  (I've tried to follow from your "slides," but they seem more like fragmented notes: reminders of talking points for you.  There's not really much reasoning to follow in there.)
My primary objection to the use of "literals" (and why I used "values" instead) is that we discussed and agreed using "values" in the previous meeting.  We never discussed the word "literal."  If this is the direction you'd like us to go, that's fine, but we need to discuss it first.  Instead, you've both proposed it and urgently pushed for it on both of the major change sets.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 15:01:06 +0200

> #97 has been rebased.

Thank you.  Please see my recent comment.

> Carsten, would you explain your understanding of the difference between string in JSON and strings in JSONPath, please?  

This is best explained in my draft slides, https://github.com/ietf-wg-jsonpath/slides-wip/blob/main/2021-06-15-jsonpath-cabo.pdf

> Isn't JSONPath built on JSON?  Wouldn't that necessitate the same definition?  

That is getting to the core of the issue.
The definitions in RFC 8259 (actually, there is no formal definitions section there) cannot be used without additional salting, as they do not distinguish between the data and the notation.
JSONPath does not operate on JSON notation (“JSON text” in RFC 8259), but on JSON data.
So we have to do the work RFC 8259 didn’t.

> You've been rather aggressive

s/aggressive/terse/

> with comments on strings, but you haven't offered any alternatives or reasons for your objections.  You've simply stated that what Stefan and I have written is wrong.  (I've tried to follow from your "slides," but they seem more like fragmented notes: reminders of talking points for you.  There's not really much reasoning to follow in there.)

OK, so maybe we do need to discuss this online tomorrow.

> My primary objection to the use of "literals" (and why I used "values" instead) is that we discussed and agreed using "values" in the previous meeting.  

Of course, because we do need the values (I wanted to be more explicit here, but we arrived at using the RFC 8259 terms here).
We also need the notation for the values, and a common word for that has been “literal” (see ECMA-262 for many examples).

> We never discussed the word "literal."  If this is the direction you'd like us to go, that's fine, but we need to discuss it first.  Instead, you've both proposed it and urgently pushed for it on both of the major change sets.

I think we have a different perception of how common this term is, so that may explain our different perception of how necessary a discussion of this term is.
It sure was good enough for ECMA-262.

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Tue, 15 Jun 2021 07:51:19 +0200

... can't find the webex meeting link ... ?
--
sg

---

From: Glyn Normington <[email-masked]>
Date: Tue, 15 Jun 2021 07:06:06 +0100

I can't find the coordinates for today's meeting either.

On Tue, 15 Jun 2021 at 06:51, Stefan Gössner <[email-masked]> wrote:

> think it's difficult to follow the rapid evolution of these discussions
> over the last week or so.
>
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> Virenfrei.
> www.avg.com
> <#m_774821232799864043_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>
>
> --
> Jsonpath mailing list
> [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Jun 2021 09:55:20 +0200

> https://github.com/ietf-wg-jsonpath/slides-wip/commit/8ef149a

I didn’t get a lot of comments, but useful stuff was still accreting at the three superseding pull requests #98, #99, #102.

So I updated the slides from there and submitted them.
Of course, there is still time for adding/fixing things:

> https://github.com/ietf-wg-jsonpath/slides-wip

Talk to you all in an hour.

Grüße, Carsten

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 15 Jun 2021 08:52:19 +0000

https://meetings.conf.meetecho.com/interim/?short=84108259-728f-49d3-8f8a-b068eeae44bd

(starting in 8 minutes)

Francesca
From: Jsonpath <[email-masked]> on behalf of Glyn Normington <[email-masked]>
Date: Tuesday, 15 June 2021 at 08:06
To: Stefan Gössner <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Tim Bray <[email-masked]>
Subject: Re: [Jsonpath] June interim meeting

On Tue, 15 Jun 2021 at 06:51, Stefan Gössner <[email-masked]<mailto:[email-masked]>> wrote:
... can't find the webex meeting link ... ?
--
sg

[Image removed by sender.]<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>
Virenfrei. www.avg.com<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

--
Jsonpath mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Greg Dennis <[email-masked]>
Date: Tue, 15 Jun 2021 08:54:50 +0000 (UTC)

DataTracker doesn't seem to be recognizing my login.  I tried a reset, but it says it can't find my account.
    On Tuesday, June 15, 2021, 08:52:34 PM GMT+12, Francesca Palombini <francesca.palombini=[email-masked]> wrote:  

 
(starting in 8 minutes)

Francesca
 
From:Jsonpath <[email-masked]> on behalf of Glyn Normington <[email-masked]>

 

 

 

 
| 

  | 
Virenfrei.www.avg.com 
  |

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Jun 2021 10:56:04 +0200

Still time to get a new one…

Grüße, Carsten

> On 2021-06-15, at 10:54, Greg Dennis <gregsdennis=[email-masked]> wrote:
>

---

From: Greg Dennis <[email-masked]>
Date: Tue, 15 Jun 2021 08:57:46 +0000 (UTC)

Tried that.  Says I don't have permission to create.
    On Tuesday, June 15, 2021, 08:56:15 PM GMT+12, Carsten Bormann <[email-masked]> wrote:  

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Jun 2021 18:49:00 +0200

> I have merged PRs 94 & 101 and asked the raisers of the two other

So here we are with #102, including some of the results of the interim where they could be put in right away.  I have sent out the review requests; I hope we can merge this in the next 24 hours or so...

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Wed, 16 Jun 2021 09:28:42 +0200

With #102 we made a big step forward.

Thanks to all
--
sg

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 Jun 2021 11:46:59 +0200

On 2021-06-15, at 18:49, Carsten Bormann <[email-masked]> wrote:
> 
> So here we are with #102, including some of the results of the interim where they could be put in right away.  I have sent out the review requests; I hope we can merge this in the next 24 hours or so…

I think I have finished addressing the PR comments, so I would appreciate if one of the non-vacationing editors would press the merge button.

Grüße, Carsten

---

From: Greg Dennis <[email-masked]>
Date: Wed, 16 Jun 2021 10:43:23 +0000 (UTC)

#102 has been merged. Can we close #98 and #99 now?

Grüße, Carsten