Subject: [Jsonpath] Markdown Editing with VSCode ...

From: Stefan Gössner <[email-masked]>
Date: Tue, 8 Jun 2021 18:14:32 +0200

I cloned the Gihub repository and started editing 
draft-ietf-jsonpath-base.md.

I was wondering why the VSCode Markdown preview was not functioning and 
simply black. Later found out, that a terminating line

`---`

was missing at the end of the /Frontmatter/ metadata section.

Now it works like a charme. I also repaired the JSONPath / XPath 
comparison table.

cheers
--
sg

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 8 Jun 2021 18:19:55 +0200

On 2021-06-08, at 18:14, Stefan Gössner <[email-masked]> wrote:
> 
> Later found out, that a terminating line
> 
> `---`
> 
> was missing at the end of the Frontmatter metadata section.
> 
> Now it works like a charme.

Kramdown-rfc currently does not support this terminating line (a standard end for YAML would be `...`, which *is* supported.)

Of course, I could change this, but for now this means that you can’t build.
Does `...` work in MS-vscode?

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 8 Jun 2021 19:01:20 +0200

> Does `...` work in MS-vscode?

Now documented in

https://github.com/cabo/kramdown-rfc2629/wiki/Pitfalls#vscode

Grüße, Carsten