Subject: Re: [Jsonpath] May interim meeting minutes

From: Tim Bray <[email-masked]>
Date: Thu, 10 Jun 2021 10:43:49 -0700

I reproduce the notes from our meeting last month.  I see quite a few
action items there … if our meeting next week is going to be useful, it
would be nice to see some of the PRs submitted.  Thanks to Stefan for
getting this started - I think he needs help getting his PR untangled?

On Fri, May 14, 2021 at 2:33 PM James <[email-masked]> wrote:

> Thank you to all who attended our first interim meeting - the minutes
> are available on Datatracker[1] however at time of writing this email
> the recording is not yet on Youtube.
>
> The consensus and action points as I gathered:
>
> # Terminology - #84
> Consensus: Sticking with the term "node" implying the location and the
> value
>
> Action: Greg to PR the terminology
>
>
> # Relative Path Support - #59
> Consensus: Queries should not begin with @, but this is a natural
> extension point.
>
> Action: Chairs to update the Github issue and allow for non-attendees to
> reply
> Action: Write an extensibility model
>
>
> # Regular Expressions in Filters - #70
> Consensus: Regular expressions can be included once we have a specific
> proposal
> Consensus: Only permit literals in regular expressions
>
> Action: Carsten to attempt a PR
> Action: Cover DoS in the security considerations of the document
>
>
> # Duplicates in Selector output - #23
> Consensus: Duplicate removal won't be part of the document
>
> Action: Marko to write the descendants PR
>
>
> # Filter Expressions - #64
> Action: Stefan to write PR
>
> If there are any questions or corrections please let me know.
>
> A poll for the June interim will be sent out soon.
>
> James & Tim
> JSONPath Chairs
>
>
> 1:
>
> https://datatracker.ietf.org/doc/minutes-interim-2021-jsonpath-01-202105110900/
>
> --
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath
>

---

From: Greg Dennis <[email-masked]>
Date: Fri, 11 Jun 2021 03:37:17 +0000 (UTC)

My PR for #84 has been up for almost a month, and I've had one review of it with no follow-up to my subsequent edits.

84 terminology by gregsdennis · Pull Request #97 · ietf-wg-jsonpath/draft-ietf-jsonpath-base

| 
| 
| 
|  |  |

 |

 |
| 
|  | 
84 terminology by gregsdennis · Pull Request #97 · ietf-wg-jsonpath/draf...

Resolves #84 Alterations Removed Object, and Array since they are defined in 8259. Replaced with extended verb...
 |

 |

 |

    On Friday, June 11, 2021, 05:44:17 AM GMT+12, Tim Bray <[email-masked]> wrote:  
 
 I reproduce the notes from our meeting last month.  I see quite a few action items there … if our meeting next week is going to be useful, it would be nice to see some of the PRs submitted.  Thanks to Stefan for getting this started - I think he needs help getting his PR untangled?
On Fri, May 14, 2021 at 2:33 PM James <[email-masked]> wrote:

# Terminology - #84
Consensus: Sticking with the term "node" implying the location and the value

James & Tim
JSONPath Chairs

1:

---

From: Stefan Gössner <[email-masked]>
Date: Fri, 11 Jun 2021 07:41:55 +0200

... it's still on my task list, didn't forget.

Am 11.06.2021 um 05:37 schrieb Greg Dennis:
> My PR for #84 has been up for almost a month, and I've had one review 
> of it with no follow-up to my subsequent edits.
>
> 84 terminology by gregsdennis · Pull Request #97 · 
> ietf-wg-jsonpath/draft-ietf-jsonpath-base 
> <https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/97>
>
>
> 	
>
> 	
>
>
> Resolves #84 Alterations Removed Object, and Array since they are 
> defined in 8259. Replaced with extended verb...
>
> <https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/97>
>
>
>
> action items there … if our meeting next week is going to be useful, 
> it would be nice to see some of the PRs submitted.  Thanks to Stefan 
> for getting this started - I think he needs help getting his PR untangled?
>
> On Fri, May 14, 2021 at 2:33 PM James <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     <https://datatracker.ietf.org/doc/minutes-interim-2021-jsonpath-01-202105110900/>
>
>     -- 
>     Jsonpath mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/jsonpath>
>
> -- 
> Jsonpath mailing list
> [email-masked] <mailto:[email-masked]>
> <https://www.ietf.org/mailman/listinfo/jsonpath>
>
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
> 	Virenfrei. www.avg.com 
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>
>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>

---

From: Glyn Normington <[email-masked]>
Date: Fri, 11 Jun 2021 06:42:37 +0100

Whoops - sorry about that. Approved.

On Fri, 11 Jun 2021 at 04:37, Greg Dennis <gregsdennis=
[email-masked]> wrote:

> My PR for #84 has been up for almost a month, and I've had one review of
> it with no follow-up to my subsequent edits.
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 11 Jun 2021 10:01:04 +0200

> My PR for #84 has been up for almost a month, and I've had one review of it with no follow-up to my subsequent edits.

You have a followup now.

In its current state, this PR does not improve the document, even after the subsequent edits.
Please do not merge.

Grüße, Carsten

---

From: Greg Dennis <[email-masked]>
Date: Fri, 11 Jun 2021 08:30:09 +0000 (UTC)

That's rude, Carsten.
I put significant effort into this PR. It resolves precisely what it was supposed to in that it updates the terminology as we had discussed in the meeting.
To say that the changes don't improve the document is insulting.

You have a followup now.

Grüße, Carsten

---

From: Tim Bray <[email-masked]>
Date: Fri, 11 Jun 2021 08:24:06 -0700

I invite WG members to visit
https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/97, where
there has been discussion of the changes Greg has proposed, and form their
own opinion about Carsten's aggressive statement.

Since that PR has a bunch of changes, it may be helpful to pull out a few
for independent discussion/decision?

On Fri, Jun 11, 2021 at 1:30 AM Greg Dennis <[email-masked]> wrote:

> That's rude, Carsten.
>
> I put significant effort into this PR. It resolves precisely what it was
> supposed to in that it updates the terminology as we had discussed in the
> meeting.
>
> On Fri, 11 Jun 2021 at 8:01 pm, Carsten Bormann
> <[email-masked]> wrote:

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 11 Jun 2021 22:49:15 +0200

On 11. Jun 2021, at 17:24, Tim Bray <[email-masked]> wrote:
> 
> Since that PR has a bunch of changes, it may be helpful to pull out a few for independent discussion/decision?

Yes, please.
There is lots of good stuff in there, but as a package it is inedible.

We need to get better in generating small PRs that, if they move us forward, then get merged quickly so we can build on top of them.
An I mean quickly, as in within a couple of days, and not as a Herculean effort.
(Case in point: Why isn’t #100 merged yet? It is not even changing the text.  Well, OK, it is 16 h old.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Jun 2021 17:10:46 +0200

> There is lots of good stuff in there, but as a package it is inedible.

Well, I ate that sandwich now.

Given that some of us seem to like #97, I have picked (and slightly fixed up) most of #97 into #101.

I would propose that we merge that quickly and get on to the problematic aspect of #97:
While the terms "object", "array", "number" are used in RFC 8259, it is never clear whether they refer to the concept or its representation in a JSON text.  That problem is irrelevant in RFC 8259 (which, after all, only defines the JSON text), but not here.
The specimen showing this best is a new definition of "String" in #97, which is neither defining the JSON strings JSONPath operates on nor does it make clear that JSONPath has redefined string literals with respect to RFC 8259.
➔ We’ll need to decide whether there also is a different data model for strings in JSONPath or JSONPath just has a different notation.

I would expect that we'll go in and fix the other gaps opened by this PR later; right now I'd rather focus on technical work.

(Oh, and why are we stuck with #94?
Three approvals.)

Grüße, Carsten

---

From: Greg Dennis <[email-masked]>
Date: Sun, 13 Jun 2021 04:20:32 +0000 (UTC)

Regarding #94, who has merging responsibility? It was my understanding that it was the chairs.  I've asked this question before, and the result was for me to leave it for someone else.
Greg

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 13 Jun 2021 07:23:45 +0200

The authors. 

Sent from mobile, sorry for terse

> On 13. Jun 2021, at 06:21, Greg Dennis <[email-masked]> wrote:
> 
> On Sun, 13 Jun 2021 at 3:10 am, Carsten Bormann
> <[email-masked]> wrote:

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 13 Jun 2021 11:22:34 +0200

> The authors. 

And the long version is at <https://mailarchive.ietf.org/arch/msg/jsonpath/uLN_5lk8VSbhzgnK7nNBbsrJ4qI>

Although this pretty much can be derived from reading RFC 2418 with adding some github common sense, maybe it would help if the chairs would confirm that this is indeed the process, or declare their variation of it.

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Mon, 14 Jun 2021 08:33:10 +0100

That link said "Editor merges" which is quite different from the
author merging. I think we should discuss the policy tomorrow for
clarity (especially since the editors listed in the document are not
the same set as the intended editors). Meanwhile, I'll do some merges
today, unless someone gets there first, as I have some spare time.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Jun 2021 10:36:32 +0200

> On 2021-06-14, at 09:33, Glyn Normington <[email-masked]> wrote:
> 
> author merging.

Sorry, I messed up the terminology again.

Author/Editor is the same in RFC 2418.
So when I say “author merges”, I mean “person in the author heading of the I-D merges”, which are also called “editors”, except that my preferred editors are Emacs and the editors at the RFC editor.

I use “submitter of the PR” in contrast to "authors of the I-D".

> I think we should discuss the policy tomorrow for

Again, please do #94 and #101.
Thank you!

Grüße, Carsten