Subject: [Jsonpath] help with build system

From: Greg Dennis <[email-masked]>
Date: Thu, 22 Apr 2021 06:35:27 +0000 (UTC)

I'm trying to get the build to work, and I am running into continuous roadblocks.
I'm running a freshly installed Ubuntu on WSL.  I'm trying to install the prerequisits, but there's not a clear list of things that I need.  xml2rfc needs python and virtualenv and.... it just keeps going.  Is there a guide somewhere for someone unfamiliar with linux?  Perhaps a list of everything I need?  This is really frustrating.
Greg

---

From: Greg Dennis <[email-masked]>
Date: Thu, 22 Apr 2021 06:38:24 +0000 (UTC)

To be clear, I'm following this: https://github.com/martinthomson/i-d-template/blob/master/doc/SETUP.md
I have brew and make installed, but for xml2rfc, apparently I need virtualenv, but I get this when trying to install
Error: The following formula cannot be installed from bottle and must bebuilt from source.  virtualenvInstall Clang or run `brew install gcc`.

    On Thursday, April 22, 2021, 06:35:43 PM GMT+12, Greg Dennis <gregsdennis=[email-masked]> wrote:  
 
 I'm trying to get the build to work, and I am running into continuous roadblocks.
I'm running a freshly installed Ubuntu on WSL.  I'm trying to install the prerequisits, but there's not a clear list of things that I need.  xml2rfc needs python and virtualenv and.... it just keeps going.  Is there a guide somewhere for someone unfamiliar with linux?  Perhaps a list of everything I need?  This is really frustrating.
Greg-- 
Jsonpath mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Greg Dennis <[email-masked]>
Date: Thu, 22 Apr 2021 07:04:28 +0000 (UTC)

Okay I think I have things installed.  I installed to user instead of virtualenv.

When I run make in the repo root dir, I get this
git submodule syncgit submodule update  --initerror: chmod on /mnt/c/projects/draft-ietf-jsonpath-base/.git/config.lock failed: Operation not permittederror: chmod on /mnt/c/projects/draft-ietf-jsonpath-base/.git/config.lock failed: Operation not permittedfatal: Failed to register url for submodule path 'lib'Makefile:2: lib/main.mk: No such file or directorymake: *** [Makefile:7: lib/main.mk] Error 128
Do I need to run this as root/admin?
    On Thursday, April 22, 2021, 06:38:37 PM GMT+12, Greg Dennis <gregsdennis=[email-masked]> wrote:

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Apr 2021 09:39:31 +0200

Hi Greg,

On 22. Apr 2021, at 09:04, Greg Dennis <gregsdennis=[email-masked]> wrote:
> 
> error: chmod on /mnt/c/projects/draft-ietf-jsonpath-base/.git/config.lock failed: Operation not permitted

I have no experience with WSL, but Duckduckgo leads me to

https://askubuntu.com/questions/1115564/wsl-ubuntu-distro-how-to-solve-operation-not-permitted-on-cloning-repository

Grüße, Carsten

---

From: Greg Dennis <[email-masked]>
Date: Fri, 23 Apr 2021 10:19:37 +0000 (UTC)

That seemed to help, but now kramdown is having issues.  Please forgive my lack of knowledge in this area.  Quite a different dev experience than .net.
cat draft-ietf-jsonpath-base.md  | kramdown-rfc2629 --v3 | lib/add-note.py | xml2rfc -q -s 'Setting consensus="true" for IETF STD document' --rfc-base-url https://datatracker.ietf.org/doc/html/ --id-base-url https://datatracker.ietf.org/doc/html/ --cache=/home/gregsdennis/.cache/xml2rfc --v2v3 /dev/stdin -o draft-ietf-jsonpath-base.xmlbash: /mnt/c/Ruby27-x64/bin/kramdown-rfc2629: C:/Ruby27-x64/bin/ruby.exe: bad interpreter: No such file or directoryError: Unable to parse the XML document: /dev/stdinmake: *** [lib/main.mk:68: draft-ietf-jsonpath-base.xml] Error 1
Greg
    On Thursday, April 22, 2021, 07:39:43 PM GMT+12, Carsten Bormann <[email-masked]> wrote:  
 
 Hi Greg,

Grüße, Carsten

-- 
Jsonpath mailing list
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 23 Apr 2021 12:33:21 +0200

On 23. Apr 2021, at 12:19, Greg Dennis <[email-masked]> wrote:
> cat draft-ietf-jsonpath-base.md  | kramdown-rfc2629 --v3 | lib/add-note.py | xml2rfc -q -s 'Setting consensus="true" for IETF STD document' --rfc-base-url https://datatracker.ietf.org/doc/html/ --id-base-url https://datatracker.ietf.org/doc/html/ --cache=/home/gregsdennis/.cache/xml2rfc --v2v3 /dev/stdin -o draft-ietf-jsonpath-base.xml
> bash: /mnt/c/Ruby27-x64/bin/kramdown-rfc2629: C:/Ruby27-x64/bin/ruby.exe: bad interpreter: No such file or directory
> Error: Unable to parse the XML document: /dev/stdin
> make: *** [lib/main.mk:68: draft-ietf-jsonpath-base.xml] Error 1

OK, so obviously kramdown-rfc2629 has not been installed properly.

> C:/Ruby27-x64/bin/ruby.exe: bad interpreter: No such file or directory

Makes me assume that C:/Ruby27-x64/bin/ruby.exe is in the first line of /mnt/c/Ruby27-x64/bin/kramdown-rfc2629, but that is a Windows path, not a UNIX path.

How did you install it?

Grüße, Carsten