Subject: [Jsonpath] JSONPath WG next steps

From: Tim Bray <[email-masked]>
Date: Wed, 23 Dec 2020 10:56:36 -0800

On behalf of James and myself:  Thanks to everyone for the quick consensus
on accepting the Carsten/Glyn combined draft for adoption by the WG, and
special thanks to Glyn and Carsten for getting this pulled together.

The next thing we need to do is get it checked in - James has made a repo
in our project at https://github.com/ietf-wg-jsonpath.  We think the proper
new name is draft-ietf-jsonpath-jsonpath-00 - does anyone disagree?

After reaching out to all four people who edited previous drafts, James and
I have asked Marko Mikulicic and Stefan Goessner to serve as co-editors for
the WG going forward. It would be appreciated if our co-editors could fix
up the name and have a look at the issues on Glyn's repo and migrate at
least some of them over to our official project, applying
editorial judgment about what deserves to be carried forward.

As soon as the draft is in place, we're hoping to see a flurry of issues
and PRs and looking forward to lively discussion of what a JSONPath really
is and what we can most usefully say about it.

---

From: Glyn Normington <[email-masked]>
Date: Thu, 24 Dec 2020 07:14:24 +0000

On Wed, 2020-12-23 at 10:56 -0800, Tim Bray wrote:
> On behalf of James and myself:  Thanks to everyone for the quick
> consensus on accepting the Carsten/Glyn combined draft for adoption
> by the WG, and special thanks to Glyn and Carsten for getting this
> pulled together.
> 
> The next thing we need to do is get it checked in - James has made a
> repo in our project at https://github.com/ietf-wg-jsonpath.  We think
> the proper new name is draft-ietf-jsonpath-jsonpath-00 - does anyone
> disagree?

I presume that's the name of the document. (The repo should not, of
course, have a version in its name.)

Out of interest, why the "stutter" in the name? Wouldn't draft-ietf-
jsonpath-00 be less cumbersome? I don't feel strongly, but it would be
good to know the rationale.

> 
> After reaching out to all four people who edited previous drafts,
> James and I have asked Marko Mikulicic and Stefan Goessner to serve
> as co-editors for the WG going forward. It would be appreciated if
> our co-editors could fix up the name and have a look at the issues on
> Glyn's repo and migrate at least some of them over to our official
> project, applying editorial judgment about what deserves to be
> carried forward.
> 
> As soon as the draft is in place, we're hoping to see a flurry of
> issues and PRs and looking forward to lively discussion of what a
> JSONPath really is and what we can most usefully say about it.

---

From: Tim Bray <[email-masked]>
Date: Wed, 23 Dec 2020 23:25:48 -0800

> good to know the rationale.

The convention is draft-ietf-${WG}-${DRAFT_SUBJECT} - in my previous
IETFing I've never been in a situation where the WG name and draft subject
are the same, but it can't be entirely unknown. I'll bounce it off our AD.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 Dec 2020 08:27:52 +0100

> good to know the rationale.

Internet-draft naming for WG documents is

draft-ietf-wgname-subject-subject-subject-nn

Now if there is only one draft in the WG, we might leave the subject off entirely.
I actually find a few cases where this has been done:

draft-ietf-cnrp-12.txt
draft-ietf-geojson-04.txt
draft-ietf-gsmp-11.txt
draft-ietf-itrace-04.txt
draft-ietf-lisp-24.txt
draft-ietf-otp-01.txt
draft-ietf-sming-02.txt
draft-ietf-upsmib-05.txt

Most of these are older cases (1994 to 2006, with geojson at 2016 being the newest), but it sure could be done again.

(Some of the WGs then did develop further drafts with non-empty subject parts, e.g., lisp.)

Grüße, Carsten

---

From: Tim Bray <[email-masked]>
Date: Wed, 23 Dec 2020 23:51:14 -0800

Hmm, draft-ietf-jsonpath-00 certainly wouldn't offend me, but on the
other hand there's a lot to be said for sticking to conventions.  I'm
imagining someone writing a bot to plow through WG drafts and relying on
the convention. I've added Murray to the "To" line to see if he has an
opinion.  James? Anyone else?

On Wed, Dec 23, 2020 at 11:27 PM Carsten Bormann <[email-masked]> wrote:

> Most of these are older cases (1994 to 2006, with geojson at 2016 being
> the newest), but it sure could be done again.
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 24 Dec 2020 13:31:57 +0100

Am 24.12.2020 um 08:51 schrieb Tim Bray:
> ...

Just lookes at <https://www.ietf.org/standards/ids/guidelines/#7> and
found it to be not that helpful (yes, sent mail reporting the brokenness).

Anyway: I believe sticking with the naming convention is more important
than avoiding "stutter".

Best regards, Julian

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 24 Dec 2020 08:35:31 -0800

I suggest draft-ietf-jsonpath-base-00.

-MSK

---

From: Stefan Hagen <[email-masked]>
Date: Thu, 24 Dec 2020 18:21:59 +0100

> Am 24.12.2020 um 17:35 schrieb Murray S. Kucherawy <[email-masked]>:
> 
> 
>> Hmm, draft-ietf-jsonpath-00 certainly wouldn't offend me, but on the other hand there's a lot to be said for sticking to conventions.  I'm imagining someone writing a bot to plow through WG drafts and relying on the convention. I've added Murray to the "To" line to see if he has an opinion.  James? Anyone else?
>> 
I second draft-ietf-jsonpath-base-00

Grüße, Stefan

> -- 
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath