Subject: [Jsonpath] Merging the drafts

From: Glyn Normington <[email-masked]>
Date: Wed, 18 Nov 2020 11:46:07 +0000

Following on from the Working Group meeting at IETF 109, Carsten and I are working on merging the two existing drafts. The goal is to create a merged document that the Working Group will hopefully decide to adopt as a starting point.

We started by converting [1] to markdown, for simpler editing and PR review. Once IETF 109 is over, we’ll start adding selected material from [2]. We’ll do that using pull requests and try to leave each PR open for at least a day so that everyone has the opportunity to comment, suggest improvements, etc. Of course, the merged result won’t be set in stone, so there will be ample opportunity to improve the text after the merge is complete. 

Regards,
Glyn

[1] https://github.com/jsonpath-standard/internet-draft <https://github.com/jsonpath-standard/internet-draft>
[2] https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00 <https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 26 Nov 2020 20:45:11 +0100

> Following on from the Working Group meeting at IETF 109, Carsten and I are working on merging the two existing drafts. The goal is to create a merged document that the Working Group will hopefully…

My first PR in Glyn’s repo:

https://github.com/jsonpath-standard/internet-draft/pull/42

(How could it be anything but 42.)

I didn’t touch the actual text of the normington draft very much, so I plan to put in another round cleaning up the remaining redundancies and moving things around when we’ve seen some feedback on this round.

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Thu, 26 Nov 2020 20:32:58 +0000

Thanks Carsten! I won’t be able to review the PR until Monday. I hope others will have had a chance to make their comments, preferably in the PR, by then.

> On 26 Nov 2020, at 19:45, Carsten Bormann <[email-masked]> wrote:
>

---

From: Tim Bray <[email-masked]>
Date: Thu, 26 Nov 2020 13:33:09 -0800

On behalf of James and myself and everyone really, thanks in advance to
Carsten and Glyn for getting this pulled together!

On Thu, Nov 26, 2020 at 12:33 PM Glyn Normington <
[email-masked]> wrote:

> Thanks Carsten! I won’t be able to review the PR until Monday. I hope
> others will have had a chance to make their comments, preferably in the PR,
> by then.
>
> >> Following on from the Working Group meeting at IETF 109, Carsten and I
> are working on merging the two existing drafts. The goal is to create a
> merged document that the Working Group will hopefully decide to adopt as a
> starting point.
> >
> > I didn’t touch the actual text of the normington draft very much, so I
> plan to put in another round cleaning up the remaining redundancies and
> moving things around when we’ve seen some feedback on this round.
> >
> > Grüße, Carsten
> >
>
> --
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath
>