Subject: Re: [Jsonpath] git(hub) usage

From: Glyn Normington <[email-masked]>
Date: Mon, 9 Nov 2020 11:08:05 +0000

On 26 Oct 2020, at 16:13, Tim Bray <[email-masked]> wrote:
> 
> Per 8875, I've asked Murray to create a GitHub organization and update the DataTracker, then I'll fill in the basics and we can move forward.

Will the GitHub org be created before the inaugural WG meeting? If not, should we add an agenda item to discuss repurposing jsonpath-standard or jsonpath-wg instead?

> 
> On Mon, Oct 26, 2020 at 7:51 AM <[email-masked] <mailto:[email-masked]>> wrote:
> On Mon, 2020-10-26 at 07:42 -0700, Tim Bray wrote:
> > Yes please. I'll go ahead and set that up unless one of you wants to?
> 
> Go for it, thanks. Then you as the Chair will have the necessary admin
> priveleges.
> 
> > 
> > On Mon, Oct 26, 2020 at 6:03 AM Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
> > > 
> > > > On 2020-10-26, at 11:50, [email-masked] <mailto:[email-masked]> wrote:
> > > > 
> > > > On Sun, 2020-10-25 at 00:24 +0200, Carsten Bormann wrote:
> > > >> I think by the time of the meeting we should have proposals
> > > ready to
> > > >> discuss:
> > > >> ...
> > > >> 
> > > >> * (if we find a lot of time:) git(hub) operations procedures,
> > > e.g.,
> > > >> how do we make use of issues and pull requests, what is the role
> > > of
> > > >> the mailing list, ...
> > > > 
> > > > In terms of git(hub) usage, I'd be happy for the WG to take over
> > > > ownership of the jsonpath-standard github organisation, which I
> > > > currently own, and (if necessary) to repurpose the contents.
> > > 
> > > RFC 8875 suggests the organization name ietf-wg-jsonpath
> > > I’m not a fan of this choice, but it’s the current guideline.
> > > 
> > > Of course, existing organizations (jsonpath-standard, jsonpath-wg)
> > > can be converted to that name.  We just should follow RFC 8874/5
> > > (unless there is a good reason not to follow them).
> > > 
> > > Grüße, Carsten
> > > 
> 
> -- 
> Jsonpath mailing list
> [email-masked]
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=04%7C01%7Cnormingtong%40vmware.com%7C75545e80872e447fcc0708d879ca1dd4%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637393256321527260%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=SB54LdG%2FDt4vGI%2F5B5sKEzCM7HmSWmg7LpEXgipANSs%3D&amp;reserved=0 <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=04%7C01%7Cnormingtong%40vmware.com%7C75545e80872e447fcc0708d879ca1dd4%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637393256321527260%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=SB54LdG%2FDt4vGI%2F5B5sKEzCM7HmSWmg7LpEXgipANSs%3D&amp;reserved=0>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 9 Nov 2020 14:19:57 +0100

> Will the GitHub org be created before the inaugural WG meeting? If not, should we add an agenda item to discuss repurposing jsonpath-standard or jsonpath-wg instead?

I’d make a new organization and push over repos from the other two organizations as we decide.

Actually, I just did that because it is too easy.
(Not sure I invited the right Murray S. Kucherawy.)

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Mon, 9 Nov 2020 14:04:36 +0000

Thanks for creating https://github.com/ietf-wg-jsonpath <https://github.com/ietf-wg-jsonpath>. Does this need to be added to datatracker?

> On 9 Nov 2020, at 13:19, Carsten Bormann <[email-masked]> wrote:
>

---

From: James <[email-masked]>
Date: Mon, 9 Nov 2020 15:38:09 +0100

I've added it to datatracker.

- J

On 09/11/2020 14:04, Glyn Normington wrote:
> Thanks for creating https://github.com/ietf-wg-jsonpath 
> <https://github.com/ietf-wg-jsonpath>. Does this need to be added to 
> datatracker?
>
>> On 9 Nov 2020, at 13:19, Carsten Bormann <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> On 2020-11-09, at 12:08, Glyn Normington <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>>
>>> Will the GitHub org be created before the inaugural WG meeting? If 
>>> not, should we add an agenda item to discuss repurposing 
>>> jsonpath-standard or jsonpath-wg instead?
>>

---

From: Glyn Normington <[email-masked]>
Date: Mon, 9 Nov 2020 17:03:59 +0000

Perfect.

> On 9 Nov 2020, at 14:38, James <[email-masked]> wrote:
> 
>>> On 9 Nov 2020, at 13:19, Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> On 2020-11-09, at 12:08, Glyn Normington <[email-masked] <mailto:[email-masked]>> wrote:
>>>>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 11 Nov 2020 09:16:58 -0800

> (Not sure I invited the right Murray S. Kucherawy.)

There's more than one?!

-MSK

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 11 Nov 2020 21:12:10 +0100

> (Not sure I invited the right Murray S. Kucherawy.)

I don’t know!

Some IETFers make a point of not being findable on github(*).
(I mean, there is this guy with the email address “superuser@...“, why wouldn’t he do the same on github.)
Also, someone evil could create a "Murray S. Kucherawy” account on github at any time.
These two together make it necessary to ask.

(But my sleuthing seems to have worked.)

Grüße, Carsten

(*) Privacy and all, but generally not a good move for engineers that try to change the world.

---

From: Marko Mikulicic <[email-masked]>
Date: Wed, 11 Nov 2020 21:31:32 +0100

FWIW Keybase (https://keybase.io/) is a nice solution to the problem of
stitching up an identity based of various unrelated identity providers (and
thus unrelated namespaces)

On Wed, Nov 11, 2020, 21:12 Carsten Bormann <[email-masked]> wrote:

> https://www.ietf.org/mailman/listinfo/jsonpath
>