Subject: [Jsonpath] Welcome, and our IETF 109 session

From: Tim Bray <[email-masked]>
Date: Sat, 24 Oct 2020 10:29:13 -0700

Hey everyone, welcome to the now-official IETF jsonpath WG:
https://mailarchive.ietf.org/arch/msg/ietf-announce/gETCDPfifXG6y4iq3CrgD-sH3-c/

Looks like I'm your unfortunate chair. I'll try to have useful things to
say but I need to touch base with Murray first.

Here's the IETF 109 agenda: https://datatracker.ietf.org/meeting/agenda/
It's taking place in ICT, where "I" stands for Indochina.  Note: The
meeting iis all-virtual.

The JSONpath meeting is 16:00 Monday November 16th.  I'm in Pacific time
and that's Monday 1AM for me - work it out for wherever you are.

Purpose of this note: Who on this list is coming to the meeting?

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 25 Oct 2020 00:24:42 +0200

Hi Tim,

congratulations for your new blue dot :-)

> Purpose of this note: Who on this list is coming to the meeting? 

I certainly will.

I think by the time of the meeting we should have proposals ready to discuss:

* some more guidelines for the development of this specification: What are going to be the guide rails within which we will be taking decisions.  The charter already provides some; maybe we can flesh them out a bit.  (Preferably not in a vacuum, but by looking at examples of decisions we’ll need to take.)

* a proposal for a working draft (probably by merging/coming up with a plan to merge the two I-Ds we already have).  Clearly, the authors are in a position to take the initiative here, but we shouldn’t really do something the WG doesn’t like.

* (if we find a lot of time:) git(hub) operations procedures, e.g., how do we make use of issues and pull requests, what is the role of the mailing list, ...

Grüße, Carsten

---

From: Tim Bray <[email-masked]>
Date: Sat, 24 Oct 2020 16:38:51 -0700

Nothing to disagree with there, but what we can realistically do at the
meeting, and thus an input to the agenda, is partially a function of who's
going to show up.

On Sat, Oct 24, 2020 at 3:24 PM Carsten Bormann <[email-masked]> wrote:

> * some more guidelines for the development of this specification: What are
> going to be the guide rails within which we will be taking decisions.  The
> charter already provides some; maybe we can flesh them out a bit.
> (Preferably not in a vacuum, but by looking at examples of decisions we’ll
> need to take.)
>
> * a proposal for a working draft (probably by merging/coming up with a
> plan to merge the two I-Ds we already have).  Clearly, the authors are in a
> position to take the initiative here, but we shouldn’t really do something
> the WG doesn’t like.
>
> * (if we find a lot of time:) git(hub) operations procedures, e.g., how do
> we make use of issues and pull requests, what is the role of the mailing
> list, ...
>
> Grüße, Carsten
>
>

---

From: Norm Tovey-Walsh <[email-masked]>
Date: Sun, 25 Oct 2020 12:59:44 +0000

> Purpose of this note: Who on this list is coming to the meeting?

I’m planning to attend.

                                        Be seeing you,
                                          norm

--
Norman Tovey-Walsh <[email-masked]>
https://nwalsh.com/

> Research is the process of going up alleys to see if they are
> blind.--Marston Bates

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 26 Oct 2020 11:22:00 +1100

> Purpose of this note: Who on this list is coming to the meeting? 

I'm planning to be there, though I'm mostly a tourist.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Mario Loffredo <[email-masked]>
Date: Mon, 26 Oct 2020 08:38:23 +0100

Il 24/10/2020 19:29, Tim Bray ha scritto:
> Looks like I'm your unfortunate chair. I'll try to have useful things 
> to say but I need to touch base with Murray first.
>
> The JSONpath meeting is 16:00 Monday November 16th.  I'm in Pacific 
> time and that's Monday 1AM for me - work it out for wherever you are.
>

I'm planning to join the meeting.

Best,

Mario

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Rick Taylor <[email-masked]>
Date: Mon, 26 Oct 2020 09:59:50 +0000

On Mon, 2020-10-26 at 08:38 +0100, Mario Loffredo wrote:
> > Looks like I'm your unfortunate chair. I'll try to have useful
> > things to say but I need to touch base with Murray first.
> > 
> > Here's the IETF 109 agenda: 
> > https://datatracker.ietf.org/meeting/agenda/
> > It's taking place in ICT, where "I" stands for Indochina.  Note:
> > The meeting iis all-virtual.
> > 

I'm planning to join as well.

As some background, at Airbus we have been successfully using our own
internal C-11 implementation of JSONPath for 6 years now, based on the
syntax at  https://github.com/dfilatov/jspath.

I am really pleased to hear that there is a standardisation process in
progress, and will attempt to add useful input.

Cheers,

Rick Taylor
Principal Engineer - Airbus
(Using my personal address for IETF mailing lists)

---

From: [email-masked]
Date: Mon, 26 Oct 2020 10:29:28 +0000

> Purpose of this note: Who on this list is coming to the meeting?

I'll be there.

I suggest we use separate threads for input to the meeting.

Regards,
Glyn
PS. I'll be using my personal address too from now on.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 27 Oct 2020 23:34:23 -0700

> say but I need to touch base with Murray first.

I'm still on the hunt for a co-chair to back Tim up.  If anyone is keen or
has someone to suggest, please ping me privately.

-MSK