Subject: Re: [Json] draft-ietf-jsonbis-rfc7159bis-03: recommendation to use UTF-8

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Jul 2017 08:52:55 +0200

On 2017-07-17 18:33, Alexey Melnikov wrote:
> Hi,
> 
> The JSONBIS WG decided to update recommendation on Unicode encoding to
> be UTF-8. (For details see the RFC Editor's notes in the approval
> message that will be sent out shortly.) This took a bit of time to
> debate in the WG, so the document approval took a bit longer than
> originally expected.
> 
> Best Regards,
> Alexey, as the responsible AD

The last WG mail related to this topic is over 2 months old, and I don't 
see any declaration of consensus.

It would be good if the chair would send a summary about what's going on 
to the WG mailing list before anything gets finalized.

(I note that 
<https://datatracker.ietf.org/doc/draft-ietf-jsonbis-rfc7159bis/> has 
been saying "Revised ID Needed" for 48 days, and I was under the 
assumption that there'd be indeed a revised ID).

Best regards, Julian

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 18 Jul 2017 10:05:26 +0200

Hi Julian,

> On 18 Jul 2017, at 08:52, Julian Reschke <[email-masked]> wrote:
> 
> The last WG mail related to this topic is over 2 months old, and I don't see any declaration of consensus.
> 
> It would be good if the chair would send a summary about what's going on to the WG mailing list before anything gets finalized.
> 
> (I note that <https://datatracker.ietf.org/doc/draft-ietf-jsonbis-rfc7159bis/> has been saying "Revised ID Needed" for 48 days, and I was under the assumption that there'd be indeed a revised ID).

I just posted a message on this: this is approved with updated RFC Editor notes. See the approval message once it is sent.

Best Regards,
Alexey

---

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Jul 2017 10:19:04 +0200

On 2017-07-18 10:05, Alexey Melnikov wrote:
> ...

This is not how it's supposed to work. Please have a new I-D posted and 
get people to review the changes in context. This is a *very* important 
piece of standards work - we need to make sure it meets quality standards.

 From a quick glance at 
<https://datatracker.ietf.org/doc/draft-ietf-jsonbis-rfc7159bis/writeup/>, 
I already note that the appendix "Changes from RFC 7159" is now incomplete.

Best regards, Julian

---

From: Barry Leiba <[email-masked]>
Date: Tue, 18 Jul 2017 13:04:32 +0200

I have to agree with Julian here: this is not a change that's
appropriate to do in an RFC Editor note.  The change is probably fine,
but draft revisions are cheap and it's easy enough to post a revised
I-D to make sure we can all see the final version in context.

Thanks,
Barry

On Tue, Jul 18, 2017 at 10:19 AM, Julian Reschke <[email-masked]> wrote:
>>> <https://datatracker.ietf.org/doc/draft-ietf-jsonbis-rfc7159bis/> has been
>>> saying "Revised ID Needed" for 48 days, and I was under the assumption that
>>> there'd be indeed a revised ID).
>>
>>
>> I just posted a message on this: this is approved with updated RFC Editor
>> notes. See the approval message once it is sent.
>> ...
>
>
> This is not how it's supposed to work. Please have a new I-D posted and get
> people to review the changes in context. This is a *very* important piece of
> standards work - we need to make sure it meets quality standards.
>
> From a quick glance at
> <https://datatracker.ietf.org/doc/draft-ietf-jsonbis-rfc7159bis/writeup/>, I
> already note that the appendix "Changes from RFC 7159" is now incomplete.
>
> Best regards, Julian
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

---

From: Pete Resnick <[email-masked]>
Date: Tue, 18 Jul 2017 13:18:15 +0200

Alexey,

I believe Julian and Barry's notes constitute an appeal of the Protocol 
Action, and I think they're probably right. Please rescind it, publish 
the new draft, and give people a bit to review. No need for another 
formal LC, but doing this in a note to the RFC Editor isn't kosher.

pr

On 18 Jul 2017, at 13:04, Barry Leiba wrote:

>> I

---

From: Barry Leiba <[email-masked]>
Date: Tue, 18 Jul 2017 13:27:52 +0200

I hadn't thought of it as an appeal, but I do think the current
document state should be "Approved, Announcement to be Sent" with a
substate of "Revised I-D Needed".  If an appeal is what's needed to
change that, then... yeah, sure.

Barry

On Tue, Jul 18, 2017 at 1:18 PM, Pete Resnick <[email-masked]> wrote:
> Action, and I think they're probably right. Please rescind it, publish the
> new draft, and give people a bit to review. No need for another formal LC,
> but doing this in a note to the RFC Editor isn't kosher.
>
> pr
>
>
>>>>> been
>>> get