Subject: [Json] Status of 7159bis

From: Julian Reschke <[email-masked]>
Date: Sat, 7 Jan 2017 16:35:24 +0100

Hi there,

I just noticed that the document went to state "Publication Requested" 
early December, with no notification of the working group, and (IMHO) 
some of the few feedback that the document received during WG LC being 
ignored (such as 
<https://www.ietf.org/mail-archive/web/json/current/msg03945.html> and 
<https://www.ietf.org/mail-archive/web/json/current/msg03978.html>).

What's going on here?

Best regards, Julian

---

From: "Paul Hoffman" <[email-masked]>
Date: Sat, 07 Jan 2017 08:50:47 -0800

On 7 Jan 2017, at 7:35, Julian Reschke wrote:

> early December, with no notification of the working group

Julian is correct here, and that's a bit disturbing.

> , and (IMHO) some of the few feedback that the document received 
> during WG LC being ignored (such as 

I cannot tell. I'm one of the mailing list moderators, and I didn't see 
any message to the list or in the moderator queue. This seems like a 
problem with the IETF tooling.

--Paul Hoffman

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 8 Jan 2017 08:44:37 +0000

Hi Julian,

> On 7 Jan 2017, at 15:35, Julian Reschke <[email-masked]> wrote:
> 
> Hi there,
> 
> I just noticed that the document went to state "Publication Requested" early December, with no notification of the working group, and (IMHO) some of the few feedback that the document received during WG LC being ignored (such as <https://www.ietf.org/mail-archive/web/json/current/msg03945.html> and <https://www.ietf.org/mail-archive/web/json/current/msg03978.html>).
> 
> What's going on here?

I moved it to the Publication Requested state in datatracker in order to get the document done and get the WG closed. Negotiations with the WG chair and document editor are ongoing. WGLC comments will be handled (or at least replied to).

Best Regards,
Alexey

---

From: "Peter F. Patel-Schneider" <[email-masked]>
Date: Sun, 8 Jan 2017 11:48:05 -0800

> I moved it to the Publication Requested state in datatracker in order to get the document done and get the WG closed. Negotiations with the WG chair and document editor are ongoing. WGLC comments w…

Progress on this document was waiting for progress on ECMA 404.  I don't see
that anything has happened with ECMA 404, so this document can't progress.

peter

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 9 Jan 2017 09:59:33 +0000

> On 8 Jan 2017, at 19:48, Peter F. Patel-Schneider <[email-masked]> wrote:
> 

It is quite the opposite: If the document doesn't progress, ECMA is not going to do anything.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 9 Jan 2017 11:03:43 +0100

On 2017-01-09 10:59, Alexey Melnikov wrote:
> ...

Is there a way for the WG to track what's going on? Any public 
communication?

Best regards, Julian

---

From: Anders Rundgren <[email-masked]>
Date: Mon, 9 Jan 2017 11:06:16 +0100

> It is quite the opposite: If the document doesn't progress, ECMA is not going to do anything.

Which highlights the impossibility having two normative standards for the same thing.
Dropping the references to ECMA is the only sensible way forward.

Anders

>
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: Stefan Hagen <[email-masked]>
Date: Mon, 9 Jan 2017 12:03:07 +0100

On 09/01/17 11:06, Anders Rundgren wrote:
>>>>> I just noticed that the document went to state "Publication
>>>>> Requested" early December, with no notification of the working
>>>>> group, and (IMHO) some of the few feedback that the document
>>>>> received during WG LC being ignored (such as
>>>> I moved it to the Publication Requested state in datatracker in
>>>> order to get the document done and get the WG closed. Negotiations
>>>> with the WG chair and document editor are ongoing. WGLC comments
>>>> will be handled (or at least replied to).
>>>>
>>>> Best Regards,
>>>> Alexey
>>>

respecting substantial back and forth to create the best possible 
specification is one thing, accepting merely formal shall I stay, or 
shall I go, I really don't know kind of discussions is another.
So I am +0 with Anders here to avoid further erosion of human forces in 
the field - if I may bluntly put it that way in a language foreign to me.

"Stefan"

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 9 Jan 2017 06:46:41 -0500

​ECMA 404 not found? Well there's your problem.​

On Mon, Jan 9, 2017 at 5:06 AM, Anders Rundgren <
[email-masked]> wrote:

>>>>> early December, with no notification of the working group, and (IMHO) some
>>>>> of the few feedback that the document received during WG LC being ignored
>>>>> (such as <https://www.ietf.org/mail-archive/web/json/current/msg03945
>>>>> .html> and <https://www.ietf.org/mail-arc
>>>>> hive/web/json/current/msg03978.html>).
>>>>>
>>>>> What's going on here?
>>>>>
>>>>
>>>> I moved it to the Publication Requested state in datatracker in order
>>>> to get the document done and get the WG closed. Negotiations with the WG
>>>> chair and document editor are ongoing. WGLC comments will be handled (or at
>>>> least replied to).
>>>>
>>>> Best Regards,
>>>> Alexey
>>>>
>>>

---

From: John Cowan <[email-masked]>
Date: Mon, 9 Jan 2017 08:28:02 -0500

Which highlights the impossibility having two normative standards for the
> same thing.

ISO 10646 and Unicode are two standards for the same thing, and are
developed by completely separate standards bodies using quite distinct
processes (though to be sure some of the people involved are the same).
Yet they have stayed perfectly in sync in substance (not in verbal form:
the language of each standard is quite different) for 24 years of very
active development.

Getting two JSON standards into mutual conformity, given that JSON is quite
static, should be trivial by comparison.  Nothing is lacking except
systematic liaison and the firm will not to disagree.

-- 
John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
A rose by any other name may smell as sweet, but if you called it
an onion you'd get cooks very confused.          --RMS

---

From: "Peter F. Patel-Schneider" <[email-masked]>
Date: Mon, 9 Jan 2017 06:38:41 -0800

On 01/09/2017 02:06 AM, Anders Rundgren wrote:
>>>> I moved it to the Publication Requested state in datatracker in order to
>>>> get the document done and get the WG closed. Negotiations with the WG
>>>> chair and document editor are ongoing. WGLC comments will be handled (or
>>>> at least replied to).
>>>>
>>>> Best Regards,
>>>> Alexey
>>>

If there is no reciprocal normative reference from some version of ECMA 404
with status at least equivalent to last call then I strongly agree.  Drop the
reference and go forward with the other fixes.

The whole idea of having the normative reference to ECMA 404 was to emphasize
that there is agreement from both sides that the two documents will always
agree on what is JSON.  The current version of 7159bis states the IETF side of
that agreement but there is nothing at all from the ECMA side.

peter

---

From: Tim Bray <[email-masked]>
Date: Tue, 10 Jan 2017 00:04:19 -0800

I’m assuming that in the near future there will be a note from the IESG to
ietf@ mailing list advising us that they will be taking this matter up?

On Mon, Jan 9, 2017 at 6:38 AM, Peter F. Patel-Schneider <
[email-masked]> wrote:

> >>> On 8 Jan 2017, at 19:48, Peter F. Patel-Schneider <
> [email-masked]>
> >>> wrote:
> >>>
> Requested"
> to
> > Which highlights the impossibility having two normative standards for
> the same
> > thing.

-- 
- Tim Bray (If you’d like to send me a private message, see
https://keybase.io/timbray)

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 10 Jan 2017 09:30:15 +0000

Tim,

On Tue, Jan 10, 2017, at 08:04 AM, Tim Bray wrote:

> I’m assuming that in the near future there will be a note from the
> IESG to ietf@ mailing list advising us that they will be taking this
> matter up?
My understanding is that the action will be taken around RFC publication
time. So either the ECMA document going to have a similar note to what
is in 7159bis, or the RFC will be published without the current note.

So can we please get the document over this finish line?

Thank you,

Alexey

> On Mon, Jan 9, 2017 at 6:38 AM, Peter F. Patel-Schneider
> <[email-masked]> wrote:
>> 

>>  >>> On 8 Jan 2017, at 19:48, Peter F. Patel-Schneider
>>  >>> <[email-masked]>
>>  >>> wrote:

>>  >>>> order to

>>  >> It is quite the opposite: If the document doesn't progress, ECMA
>>  >> is not
>>  >> going to do anything.

>>  > Which highlights the impossibility having two normative standards
>>  > for the same
>>  > thing.

---

From: "Paul Hoffman" <[email-masked]>
Date: Tue, 10 Jan 2017 08:23:06 -0800

> So can we please get the document over this finish line?

Can you as AD please tell us the steps that are needed to do that?

--Paul Hoffman

---

From: Julian Reschke <[email-masked]>
Date: Tue, 10 Jan 2017 17:24:48 +0100

> Can you as AD please tell us the steps that are needed to do that?

As a first step, address feedback and produce a new draft?

Best regards, Julian

---

From: "Peter F. Patel-Schneider" <[email-masked]>
Date: Tue, 10 Jan 2017 08:27:05 -0800

> As a first step, address feedback and produce a new draft?

And get at least a draft version of what ECMA is going to say?

peter

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 10 Jan 2017 21:24:23 +0000

> On 10 Jan 2017, at 16:24, Julian Reschke <[email-masked]> wrote:
> 

Indeed.

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 10 Jan 2017 21:30:04 +0000

Sent from my iPhone

> On 10 Jan 2017, at 16:27, Peter F. Patel-Schneider <[email-masked]> wrote:
> 

I can investigate this, but I don't think this should be blocking as long as the WG is happy to also publish the RFC without the note.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 11 Jan 2017 10:39:08 +0000

> And get at least a draft version of what ECMA is going to say?

Based on earlier discussions with ECMA they need to know the RFC number to reference. After that they say that they can move quite fast on adding the note.

---

From: "Peter F. Patel-Schneider" <[email-masked]>
Date: Wed, 11 Jan 2017 08:03:05 -0800

> Based on earlier discussions with ECMA they need to know the RFC number to reference. After that they say that they can move quite fast on adding the note.

Isn't the number 7159bis?  Why can't ECMA go ahead using this number?

peter

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 12 Jan 2017 12:33:01 +0900

> Isn't the number 7159bis?  Why can't ECMA go ahead using this number?

No. Stuff like 7159bis is only used in the drafting process. There are 
no actual RFCs with 'bis' suffixes in their numbers. To check, please 
see https://www.rfc-editor.org/rfc-index2.html, which is a full list of 
RFCs.

The number will be allocated shortly before publication, it may be 8059 
or 8159 or anything else to the RFC Editor's fancy.

Regards,   Martin.