Subject: Re: [Json] Early AD review of draft-ietf-jsonbis-rfc7159bis-02

From: Tim Bray <[email-masked]>
Date: Mon, 30 Jan 2017 19:38:39 -0800

Just put finishing touches on the draft, and I surveyed back through the WG
and found Barry’s note:

​​
O
​​
n Tue, Sep 20, 2016 at 1:29 AM, Barry Leiba <[email-masked]> wrote:
​​

> ​​
> > "Byte order mark" in Section 8.1 needs a definition, for example by
> ​​
>
> > including the Unicode codepoint value.
>
​​
​Correct - a bit more work than you might think, since there's not a really
good canonical reference. So I just updated the text to read
“Implementations MUST NOT add a byte order mark (either U+FEFF or U+FFE) to
the beginning of​…”

Anyone have a better idea?
​​

> ​​
> > In Section 11: I think you meant to update references to point to this
> ​​
> > document, not an earlier RFC.
>

OK
​​

> >
> > Appendix A needs to be checked that it is correct. I think at least a
> couple
> > of things are out of date.
>

​Yep. Now it's just deltas since 7159.​

​> First mention of UTF-8, UTF-16 need normative references.

OK.  One reference (Unicode Section 3) will do for all three.

---

From: "Manger, James" <[email-masked]>
Date: Tue, 31 Jan 2017 04:00:05 +0000

> "Byte order mark" in Section 8.1 needs a definition, for example by
​​> including the Unicode codepoint value.
​​
> ​Correct - a bit more work than you might think, since there's not a really good canonical reference. So I just updated the text to read “Implementations MUST NOT add a byte order mark (either U+FEFF or U+FFE) to the beginning of​…”

Don’t mention U+FFEF (particularly if misspelled U+FFE). Just say “byte order mark (U+FEFF)”.