Subject: Re: iFCP - FCIP merge proposal

From: "Ken Hirata" <[email-masked]>
Date: Thu, 28 Dec 2000 18:46:21 -0800

I have to agree with what Joshua said in the "iFCP fabric attachments"
thread; it doesn't make sense to merge iFCP and FCIP.

FCIP is used to solve the problem of connecting 2 Fibre Channel SANs
via IP; it's a tunneling protocol.  As such, it is very simple; the amount
of
processing on any Fibre Channel frame is minimal.  It doesn't read or modify

any of the FC-2 header, add augmentation information or manipulate any
Extended Link Service frames, and allows all FC-2 functionality.

iFCP is a gateway protocol.  It cracks the FC-2 header, handles some Fibre
Channel Extended Link Service frames in a special manner, and there is a
possibility that it won't support all FC-2 functionality.

Merging the FCIP and iFCP documents would make a single document in name
only.  FCIP doesn't need to use any of the functionality described in the
current
iFCP document.

                                                        Ken

Joshua Tseng wrote:

> Venkat,
>
> <stuff deleted...>
> >
> > But as far as I can tell, iFCP requires you to remove devices
> > that support
> > E_Port, B_Port and FC-AL functionality and replace them with iFCP plus
> > OSPF/BGP/RIP implementaions, which is quite a drastic step
> > for a deployed
> > SAN to take on. Merging the two would appear to provide both
> > capabilities.
> >
> iFCP does not require you to remove anything.  There are implementation
> techniques to connect E_PORTS, Loop ports, and whatever ports you have
> in FC to the iFCP transport.  Merging the two will provide you nothing
> but a very complicated, confusing document describing two dissimilar
> techniques.
>
> Regards,
>
> Josh
>
> > Regards,
> >
> > Venkat Rangan
> > Rhapsody Networks Inc.
> > http://www.rhapsodynetworks.com
> >
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Julian Satran
> > Sent: Wednesday, December 13, 2000 4:36 PM
> > To: [email-masked]
> > Subject: iFCP - FCIP merge proposal
> >
> >
> > Dear colleagues,
> >
> > At yesterdays IPS WG meeting and had no chance to clarify my proposal
> > regarding a merger of FCIP and iFCP into a single effort.
> >
> > iFCP attempt to provide an IP interconnect for FCP devices.
> > It has also the
> > capabilty to interconnect FC islands.
> >
> > FCIP has the narrower scope of connecting only FC islands -
> > admittedly even
> > FC devices other then FCP.
> >
> > Given that FCP devices where the main concern of this WG and that iFCP
> > serves a wider purpose than FCIP and will enable not only
> > tunneling but also
> > migration of FCP devices to IP infrastructure my intention
> > was to suggest
> > that iFCP should attempt to incorporate those FCIP functions
> > it does not
> > care about today and those two groups should work towards one
> > common draft
> > that should cover not only tunneling but also device migration to IP
> > networks.
> >
> > Julo
> > ______________________________________________________________
> > ______________
> > _________
> > Get more from the Web.  FREE MSN Explorer download :
> http://explorer.msn.com

--
Kenneth Hirata
Vixel Corporation
Irvine, CA 92618
Phone: (949) 450-6100
Email: [email-masked]

---

From: Charles Monia <[email-masked]>
Date: Fri, 29 Dec 2000 16:59:43 -0800

Hi:

>........................FCIP doesn't need to use any of the functionality 
> described in the
> current
> iFCP document.
> 

Considering the the limited purpose for which it was designed, the tunneling
protocol  is certainly adequate as it stands. Fundamentally, these
specifications have widely different goals and constituencies and need to
evolve as seperate documents.

Charles

> From: Ken Hirata [mailto:[email-masked]]
> Sent: Thursday, December 28, 2000 6:46 PM
> To: [email-masked]
> Cc: Ken Hirata
> Subject: Re: iFCP - FCIP merge proposal
> 
> 
> > > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > > Julian Satran