Subject: [iola-conversion-tool] Bug report - Document listed twice on IESG Agenda

From: Amy Vezza <[email-masked]>
Date: Wed, 7 Mar 2012 17:49:48 -0500

Logged in as a Secretariat user I changed the IESG Telechat agenda (https://datatracker.ietf.org/iesg/agenda/) section a document was in by changing the Document State from Publication Requested to IESG Evaluation.

The document is draft-tsou-softwire-gwinit-6rd and it was in section 3.2.3 For Action (it had two other things wrong with it due to user unfamiliarity, and I fixed those as well - unchecked the "returning item" box as it is not a returning item, and checked the "IRTF/RFC Editor" submission box, as this is an ISE stream document).  When I changed the state it moved to section 3.3.1 New Items as it should have, but now it is listed twice.  

I may have inadvertently caused this doubling, but I am not sure how.

Regards,

Amy

---

From: Ole Laursen <[email-masked]>
Date: Thu, 8 Mar 2012 15:34:45 +0100

2012/3/7 Amy Vezza <[email-masked]>:
> The document is draft-tsou-softwire-gwinit-6rd and it was in section 3.2.3
> For Action (it had two other things wrong with it due to user unfamiliarity,
> and I fixed those as well - unchecked the "returning item" box as it is not
> a returning item, and checked the "IRTF/RFC Editor" submission box, as this
> is an ISE stream document).  When I changed the state it moved to section
> 3.3.1 New Items as it should have, but now it is listed twice.

I had a look draft-tsou-softwire-gwinit-6rd and found a problem with
the code that pulls the documents out of the database so a document
may end up being listed twice in the agenda (the data itself is fine
as far as I can see).

We had a similar problem not long ago so I've now looked through the
whole agenda code and believe I've fixed all of them. So the extra
listing will go away when Henrik deploys my changes. He's out of
office until March 12th so it may take a couple of days.

Ole

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 13 Mar 2012 16:56:29 +0100

Hi Amy, Ole,

The fix has now been deployed.

Best regards,

	Henrik