Subject: Re: [iola-conversion-tool] Small Datatracker Bug

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 01 Mar 2012 12:36:51 +0100

Hi Amy,

I've entered this into the issue tracker as #782:
  http://trac.tools.ietf.org/tools/ietfdb/ticket/782

for Ole to deal with.

Best regards,

	Henrik

On 2012-02-29 15:45 Amy Vezza said:
> Logged in as Secretariat user, I created the Telechat "Moderator's Package" by going to this url:
> 
> https://datatracker.ietf.org/iesg/agenda/moderator_package.html
> 
> It looks like it created mostly well, except for a weirdness when it pulled the ballots for each of the documents.  Each ballot has the full ballot with all ADs listed on the top, and underneath that has a second listing of all ADs that have entered a position like this:
> 
>                       Yes  No-Objection  Discuss  Abstain
> Jari Arkko           [   ]     [   ]     [   ]     [   ]
> Ronald Bonica        [   ]     [   ]     [   ]     [   ]
> Stewart Bryant       [ X ]     [   ]     [   ]     [   ]
> Gonzalo Camarillo    [   ]     [   ]     [   ]     [   ]
> Ralph Droms          [   ]     [   ]     [   ]     [   ]
> Wesley Eddy          [   ]     [ X ]     [   ]     [   ]
> Adrian Farrel        [ X ]     [   ]     [   ]     [   ]
> Stephen Farrell      [   ]     [ X ]     [   ]     [   ]
> David Harrington     [   ]     [   ]     [   ]     [   ]
> Russ Housley         [   ]     [   ]     [   ]     [   ]
> Pete Resnick         [   ]     [ X ]     [   ]     [   ]
> Dan Romascanu        [   ]     [ X ]     [   ]     [   ]
> Peter Saint-Andre    [   ]     [ X ]     [   ]     [   ]
> Robert Sparks        [   ]     [ X ]     [   ]     [   ]
> Sean Turner          [   ]     [   ]     [   ]     [   ]
> 
> Stewart Bryant       [ X ]     [   ]     [   ]     [   ]
> Wesley Eddy          [   ]     [ X ]     [   ]     [   ]
> Adrian Farrel        [ X ]     [   ]     [   ]     [   ]
> Stephen Farrell      [   ]     [ X ]     [   ]     [   ]
> Pete Resnick         [   ]     [ X ]     [   ]     [   ]
> Dan Romascanu        [   ]     [ X ]     [   ]     [   ]
> Peter Saint-Andre    [   ]     [ X ]     [   ]     [   ]
> Robert Sparks        [   ]     [ X ]     [   ]     [   ]
> 
> Can we have that second listing removed?  The only time a ballot should have a second grouping of ADs like this is for former Area Directors that entered a position on the document before they stepped down, not current Area  Directors (in other words, for historical purposes).  
> 
> Thank you!
> 
> Amy

---

From: Ole Laursen <[email-masked]>
Date: Thu, 1 Mar 2012 20:19:02 +0100

> It looks like it created mostly well, except for a weirdness when it pulled the ballots for each of the documents.  Each ballot has the full ballot with all ADs listed on the top, and underneath th…

Yes. I was looking through the code, and there was a hole in the
translation layer we're using to bridge the gap between the old
database structure and the new one so it weren't detecting that the
second set was of ADs was actually active ADs.

Thanks for the report!

Ole