Subject: [iola-conversion-tool] Fwd: [www.ietf.org/rt #45823] Missing messages from the submitter

From: Alexa Morris <[email-masked]>
Date: Sun, 4 Mar 2012 08:45:33 -0800

Sorry, the original complaint did not forward when I responded to Jim. Can someone see if the missing confirmation message has something to do with the database conversion? This is the 4th such report.

Regards,
Alexa

Begin forwarded message:

> From: "Jim Schaad via RT" <[email-masked]>
> Date: March 3, 2012 2:45:53 PM PST
> To: "AdminCc of www.ietf.org/rt Ticket #45823":;
> Subject: [www.ietf.org/rt #45823] Missing messages from the submitter 
> Reply-To: [email-masked]
> 
> 
> Sat Mar 03 14:45:52 2012: Request 45823 was acted upon.
> Transaction: Ticket created by [email-masked]
>       Queue: IETF-Action
>     Subject: Missing messages from the submitter
>       Owner: Nobody
>  Requestors: [email-masked]
>      Status: new
> Ticket <URL: https://www.ietf.org/rt/Ticket/Display.html?id=45823 >
> 
> 
> I did not appear to get any confirmation messages from the submission server
> for 
> 
> Draft-schaad-plasma-cms-00.txt and
> Draft-schaad-pkix-rfc2875-bis-00.txt
> 
> Is there a way for me to force a resend of the submitter authentication
> message?
> 
> Jim
> 
> 
> 

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Ole Laursen <[email-masked]>
Date: Mon, 5 Mar 2012 14:40:43 +0100

Hi!

Jim, you can go to the submit tool, click the "Status" link at the
blue bar at the top, enter "draft-schaad-plasma-cms" and at the bottom
of the page (an orange box) request an email with the URL.

Alexa: I've tried going through a submission on my local development
server and sure I didn't get the confirmation email, but as far as I
can tell from the code, the submitter doesn't get a confirmation email
on submission of 00 revisions of drafts?

The process does look a bit odd (you get redirected to the secret URL,
then fill in submitter info and get redirected to a non-secret one
without knowing you should have saved the previous URL), but I don't
think this has anything to do with the database conversion. A clean up
of the layout/info on those pages would probably help, it's silly if
the same mistakes keep popping up just because the system is a bit
confusing.

Ole

2012/3/4 Alexa Morris <[email-masked]>:
> --
> _______________________________________________
> iola-conversion-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iola-conversion-tool

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Mar 2012 09:44:03 -0500

> on submission of 00 revisions of drafts?

They should.

> the same mistakes keep popping up just because the system is a bit

It is a two stage system.  The author uploads the draft and it is placed in a staging area, then the system send email to all of the authors, then one of the authors clicks the link in the email, the draft is posted from the staging area, and finally all of the authors get email that the draft was posted.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 15:50:35 +0100

Hi Alexa,

On 2012-03-04 17:45 Alexa Morris said:
> Sorry, the original complaint did not forward when I responded to
> Jim. Can someone see if the missing confirmation message has
> something to do with the database conversion? This is the 4th such
> report.

Do you have the draft names associated with the other 3 reports?  That
would be useful information.

Best regards,

	Henrik

---

From: Ole Laursen <[email-masked]>
Date: Mon, 5 Mar 2012 16:08:41 +0100

>> on submission of 00 revisions of drafts?

Ah, wait a second, there's a difference between WG drafts and
individual drafts. I do get the confirmation in the latter case.
Sorry.

My first idea would be checking the mail logs and see if it got lost
there. I have a dump of the database, and it looks like it went down
the right branch of the code, saved the submitter email as
[email-masked] and then went into the email sending code.
Henrik, can you check that?

Ole

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 16:21:38 +0100

>> on submission of 00 revisions of drafts?

I checked on one case of allegedly missing confirmation email for Cindy
Friday, and found that the email server on www.ietf.org reported the email
as delivered to the submitter's email server.

I hope to get all the names where trouble has been reported from Alexa,
so I can check them all, to see whether mail has gone out from the server
or not.

Best regards,

	Henrik

> It is a two stage system.  The author uploads the draft and it is
> placed in a staging area, then the system send email to all of the
> authors, then one of the authors clicks the link in the email, the
> draft is posted from the staging area, and finally all of the authors
> get email that the draft was posted.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 16:57:23 +0100

Hi Alexa,

> Sorry, the original complaint did not forward when I responded to Jim. Can someone see if the missing confirmation message has something to do with the database conversion? This is the 4th such rep…

The two drafts mentioned show up in the staging area as follows:

-rw-r--r-- 1 wwwrun www 64007 Mar  2 14:17 /home/henrik/staging/draft-schaad-pkix-rfc2875-bis-00.txt
-rw-r--r-- 1 wwwrun www 69515 Mar  2 14:17 /home/henrik/staging/draft-schaad-pkix-rfc2875-bis-00.xml
-rw-r--r-- 1 wwwrun www 59939 Mar  2 14:16 /home/henrik/staging/draft-schaad-plasma-cms-00.txt
-rw-r--r-- 1 wwwrun www 63495 Mar  2 14:16 /home/henrik/staging/draft-schaad-plasma-cms-00.xml

I.e., the posting time was 14:16 and 14:17 PST on March 2nd.

Checking the email address in the drafts in the staging area, I find that
Jim uses the email address [email-masked].

In the email server log, I find the following entries, which I believe
indicates that the email (from [email-masked]) has been handed
successfully over to the relay 'winery.augustcellars.com'.  (Someone who's
expert in postfix logging can probably tell for sure :-)  :

Kicked off 14:16:

  Mar  2 14:16:48 ietfa amavis[25291]: (25291-20) ESMTP::10024 /a/amavis/tmp/amavis-20120302T135553-25291: <[email-masked]> -> <[email-masked]> SIZE=941 Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <[email-masked]>; Fri,  2 Mar 2012 14:16:48 -0800 (PST)
  Mar  2 14:16:48 ietfa amavis[25291]: (25291-20) Checking: N2TzYBtdcPuk [127.0.0.1] <[email-masked]> -> <[email-masked]>
  Mar  2 14:16:49 ietfa amavis[25291]: (25291-20) FWD via SMTP: <[email-masked]> -> <[email-masked]>,BODY=7BIT 250 2.0.0 Ok, id=25291-20, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3F10E21F858E
  Mar  2 14:16:49 ietfa amavis[25291]: (25291-20) Passed CLEAN, [127.0.0.1] [127.0.0.1] <[email-masked]> -> <[email-masked]>, Message-ID: <[email-masked]>, mail_id: N2TzYBtdcPuk, Hits: -102.573, size: 941, queued_as: 3F10E21F858E, 470 ms
  Mar  2 14:16:49 ietfa postfix/smtp[32481]: C43A121F8596: to=<[email-masked]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.52, delays=0.04/0/0/0.47, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=25291-20, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3F10E21F858E)
  Mar  2 14:17:20 ietfa postfix/smtp[32486]: 3F10E21F858E: to=<[email-masked]>, relay=winery.augustcellars.com[206.212.239.129]:25, delay=31, delays=0.04/0/30/0.46, dsn=2.6.0, status=sent (250 2.6.0 <[email-masked]> [InternalId=238] Queued mail for delivery)

Kicked off 14:17:

 Mar  2 14:17:32 ietfa amavis[32430]: (32430-02) ESMTP::10024 /a/amavis/tmp/amavis-20120302T141502-32430: <[email-masked]> -> <[email-masked]> SIZE=953 Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <[email-masked]>; Fri,  2 Mar 2012 14:17:32 -0800 (PST)
 Mar  2 14:17:32 ietfa amavis[32430]: (32430-02) Checking: 2hyU8fneXOX3 [127.0.0.1] <[email-masked]> -> <[email-masked]>
 Mar  2 14:17:33 ietfa amavis[32430]: (32430-02) FWD via SMTP: <[email-masked]> -> <[email-masked]>,BODY=7BIT 250 2.0.0 Ok, id=32430-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4FE2A21F859A
 Mar  2 14:17:33 ietfa amavis[32430]: (32430-02) Passed CLEAN, [127.0.0.1] [127.0.0.1] <[email-masked]> -> <[email-masked]>, Message-ID: <[email-masked]>, mail_id: 2hyU8fneXOX3, Hits: -102.573, size: 953, queued_as: 4FE2A21F859A, 597 ms
 Mar  2 14:17:33 ietfa postfix/smtp[522]: B1E7221F8596: to=<[email-masked]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.61, delays=0.01/0/0/0.6, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32430-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4FE2A21F859A)
 Mar  2 14:18:03 ietfa postfix/smtp[505]: 4FE2A21F859A: to=<[email-masked]>, relay=winery.augustcellars.com[206.212.239.129]:25, delay=31, delays=0/0.01/30/0.39, dsn=2.6.0, status=sent (250 2.6.0 <[email-masked]> [InternalId=241] Queued mail for delivery)

Regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 16:58:48 +0100

Hi Ole,

> Henrik, can you check that?

Just did that, and the result is that they definitely were handed over
to the mail server, and as far as I can tell also went out to the
submitters' mail server for delivery.

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Mar 2012 11:52:12 -0500

> Henrik, can you check that?

The process I explained above in the individual draft.

The WG draft process has an additional check.  The WG chair needs to approve the posting of the -00 document.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 00:15:25 +0100

Hi Jim,

On 2012-03-05 23:35 Jim Schaad said the following:
> Henrik,
> 
> Is there any possibility that an issue could be present because I had
> multiple MX records and the primary server was down during that period?

It shouldn't matter, if you've collected messages from the secondary
server meanwhile.  Otherwise, it definitely could matter.  The mail
server log showed these lines for the final delivery of the outgoing
messages:

and

If 'winery.augustcellars.com' is your secondary mail server, then my bet is that
that's where you'll find the messages :-)

Best regards,

	Henrik

> Jim
> 
> 
>> -----Original Message-----
>> From: Henrik Levkowetz [mailto:[email-masked]]
>> Sent: Monday, March 05, 2012 7:59 AM
>> To: Ole Laursen
>> Cc: Russ Housley; Alexa Morris; [email-masked];
>> [email-masked]
>> Subject: Re: [iola-conversion-tool] Fwd: [www.ietf.org/rt #45823] Missing
>> messages from the submitter
>> 
>> Hi Ole,
>> 
>> >>> can tell from the code, the submitter doesn't get a confirmation
>> >>> email on submission of 00 revisions of drafts?
>> >>
>> >> They should.
>> >
>> Just did that, and the result is that they definitely were handed over to
> the
>> mail server, and as far as I can tell also went out to the submitters'
> mail server
>> for delivery.
>> 
>> 
>> Best regards,
>> 
>> 	Henrik
> 
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 00:37:01 +0100

Hi Jim,

On 2012-03-06 00:20 Jim Schaad said the following:
> Winery.augustcellars.com is my secondary server, I am collecting messages
> from that server - so it must be deciding that you are bad juju for some
> reason.  I guess that will be part of my trip to the winery later this week
> to figure out what spam filter these messages are going to that is not
> catching the rest of my IETF mail.

Ah.  It would most likely be very interesting to hear what you find, in case
it could help us fix any issues with the outgoing messages that make them
likely to be misclassified as spam.

Best regards,

	Henrik

>> Sent: Monday, March 05, 2012 3:15 PM
>> To: Jim Schaad
>> Cc: 'Ole Laursen'; 'Russ Housley'; 'Alexa Morris';
> server
>> meanwhile.  Otherwise, it definitely could matter.  The mail server log
>> showed these lines for the final delivery of the outgoing
>> messages:
>> 
>>    Mar  2 14:17:20 ietfa postfix/smtp[32486]: 3F10E21F858E:
>> to=<[email-masked]>,
>> relay=winery.augustcellars.com[206.212.239.129]:25, delay=31,
>> delays=0.04/0/30/0.46, dsn=2.6.0, status=sent (250 2.6.0
>> <[email-masked]> [InternalId=238]
>> Queued mail for delivery)
>> 
>> and
>> 
>>   Mar  2 14:18:03 ietfa postfix/smtp[505]: 4FE2A21F859A:
>> to=<[email-masked]>,
>> relay=winery.augustcellars.com[206.212.239.129]:25, delay=31,
>> delays=0/0.01/30/0.39, dsn=2.6.0, status=sent (250 2.6.0
>> <[email-masked]> [InternalId=241]
>> Queued mail for delivery)
>> 
>> If 'winery.augustcellars.com' is your secondary mail server, then my bet
> is
>> that that's where you'll find the messages :-)
>> 
>> 
>> Best regards,
>> 
>> 	Henrik
>> 
>> 
>> 
>> > Jim
>> >
>> >
>> >> Subject: Re: [iola-conversion-tool] Fwd: [www.ietf.org/rt #45823]
>> >> Missing messages from the submitter
>> >>
>> >> Hi Ole,
>> >>
>> >> >>> Alexa: I've tried going through a submission on my local
>> >> >>> development server and sure I didn't get the confirmation email,
>> >> >>> but as far as I can tell from the code, the submitter doesn't get
>> >> >>> a confirmation email on submission of 00 revisions of drafts?
>> >> >>
>> >> >> They should.
>> >> >
>> >> > My first idea would be checking the mail logs and see if it got
>> >> > lost there. I have a dump of the database, and it looks like it
>> >> > went down the right branch of the code, saved the submitter email
>> >> > as [email-masked] and then went into the email sending code.

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 5 Mar 2012 14:35:21 -0800

Henrik,

Jim

the
mail server

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 5 Mar 2012 15:20:52 -0800

Jim

server
is