Subject: [iola-conversion-tool] Bug in Datatracker Agenda Code?

From: Alexa Morris <[email-masked]>
Date: Fri, 2 Mar 2012 11:17:06 -0800

There seems to be a small bug affecting Datatracker agenda code, because both the technical and the admin plenary agendas are being written to the same location.  I uploaded the admin agenda yesterday and then uploaded the technical plenary agenda, only to find that the technical plenary agenda went into the admin plenary slot. See here: https://datatracker.ietf.org/meeting/83/agenda.txt

Let me know if you need additional information to research this. 

Thanks,
Alexa

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 16:30:53 +0100

Hi Alexa,

On 2012-03-02 20:17 Alexa Morris said:
> There seems to be a small bug affecting Datatracker agenda code,
> because both the technical and the admin plenary agendas are being
> written to the same location.  I uploaded the admin agenda yesterday
> and then uploaded the technical plenary agenda, only to find that the
> technical plenary agenda went into the admin plenary slot. See here:
> https://datatracker.ietf.org/meeting/83/agenda.txt

I think this has been corrected now?  The materials upload tool is under
Ryan's control, but I think the problem was that the different slots had
been assigned to the same group ('ietf'), while the technical plenary
now has been changed to belong to 'iab'.

(This should, by the way, permit the IETF chair and the IAB chair to upload
agenda materials for these two sessions directly, without having to go
through the secretariat).

> Let me know if you need additional information to research this.

It would be good if you could confirm that with the current session
assignment, upload works for both and only appears in the appropriate
slot?

Best regards,

	Henrik

---

From: Alexa Morris <[email-masked]>
Date: Mon, 5 Mar 2012 08:21:36 -0800

Hi Henrik

> assignment, upload works for both and only appears in the appropriate

Unfortunately, it's not working yet on my end yet. I just uploaded the Admin Plenary Agenda but the Technical Plenary Agenda is still holding the Wednesday evening slot and it says that no technical plenary agenda has been uploaded. 

Thanks,
Alexa

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Mar 2012 11:43:04 -0500

Do you have a work around so that the agenda can go to the printer on schedule today?

Russ

On Mar 5, 2012, at 11:21 AM, Alexa Morris wrote:

> -- 
> _______________________________________________
> iola-conversion-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iola-conversion-tool

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 17:46:42 +0100

Hi Alexa,

On 2012-03-05 17:21 Alexa Morris said:
> Unfortunately, it's not working yet on my end yet. I just uploaded
> the Admin Plenary Agenda but the Technical Plenary Agenda is still
> holding the Wednesday evening slot and it says that no technical
> plenary agenda has been uploaded.

Mmm, what I see here is "The plenary has not been scheduled", which
is a different matter.  I think this may be a failure in the scheduling
tool; it is possible that it hasn't connected the session with the meeting
slot (maybe because at the time the two plenaries were associated with the
same group?).  I'll try to dig a bit in the data to see what's up.

Best regards,

	Henrik

---

From: Alexa Morris <[email-masked]>
Date: Mon, 5 Mar 2012 09:16:59 -0800

Yes, we are fine here. Thanks for asking.

Alexa

----------

---

From: Ryan Cross <[email-masked]>
Date: Mon, 5 Mar 2012 09:20:33 -0800

Hi Henrik,

I show two plenary Timeslots for meeting 83, both with a Session associated.  And both sessions with agenda material attached.  So the data looks good unless I'm missing some detail of scheduling plenaries.

In [38]: q=TimeSlot.objects.filter(meeting=83,type='plenary')

In [39]: q
Out[39]: [<TimeSlot: 83: 03-28 16:30-19:30 IETF Operations and Administration Plenary, Amphitheatre Bleu>, <TimeSlot: 83: 03-26 16:30-19:30 Technical Plenary, Amphitheatre Bleu>]

In [40]: q[0].session  
Out[40]: <Session: IETF-83: iesg 1630>

In [41]: q[1].session
Out[41]: <Session: IETF-83: iab 1630>

Thanks,
Ryan

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 Mar 2012 19:06:55 +0100

Hi Ryan, Alexa, all,

I think I've now got this working.  Both administrative and technical
plenary shows up as they should.

There were some assumptions which didn't hold, which lead to some code
changes, and there was an encoding problem with the agenda file on disk,
as follows:

  1. The code assumed that the uploaded document would have a title which
     indicated which plenary agenda it was for -- no title was set.  I've
     now changed the code to look at the document name instead.

  2. There were actually 4 different agendas which matched the plenaries,
     and the code didn't check for state active, so I added this.

  3. Even after I fixed the things above, I went 'round and 'round a couple
     of times, as I only saw a blank space where the agenda should have
     been.  This seems to have been caused by the uploaded document having
     a mac character set encoding and mac line-endings -- Ryan, you maybe
     should investigate that further, and see if you should do character
     set and line-ending conversion.  I think what's on disk should either
     be ascii or unicode -- for drafts we check that it's pure ascii, but
     the agendas are different, and we should maybe enforce unicode?

Best regards,

	Henrik

---

From: Ryan Cross <[email-masked]>
Date: Wed, 21 Mar 2012 07:17:29 -0700

Hi Henrik,

>     the agendas are different, and we should maybe enforce unicode?
Does this mean the code is parsing the agenda file?  Does it need to do this?  I'm happy to add character set validation, but this would affect everyone submitting agenda's so I want to be sure that is the official requirement.

Thanks,
Ryan

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 21 Mar 2012 15:51:20 +0100

Hi Ryan,

On 2012-03-21 15:17 Ryan Cross said:
>> 3. Even after I fixed the things above, I went 'round and 'round a
>> couple of times, as I only saw a blank space where the agenda
>> should have been.  This seems to have been caused by the uploaded
>> document having a mac character set encoding and mac line-endings
>> -- Ryan, you maybe should investigate that further, and see if you
>> should do character set and line-ending conversion.  I think what's
>> on disk should either be ascii or unicode -- for drafts we check
>> that it's pure ascii, but the agendas are different, and we should
>> maybe enforce unicode?

> Does this mean the code is parsing the agenda file?  Does it need to
> do this?  I'm happy to add character set validation, but this would
> affect everyone submitting agenda's so I want to be sure that is the
> official requirement.

No, the code isn't parsing the agenda file, but the file is being
displayed through web browsers, and if you tell the browsers it's
latin-1 when it's utf-8, or vice versa, things don't look good.
And for mac line-endings things can get so bad that the browser
doesn't show anything at all in some circumstances -- that seemed to
be what happened above.

Best regards,

	Henrik