Subject: [iola-conversion-tool] Fwd: [www.ietf.org/rt #46122] RFC 6349 PDF error

From: Alexa Morris <[email-masked]>
Date: Tue, 13 Mar 2012 15:28:13 -0700

Please see below, we think this maybe related to the database conversion but please let me know if that is not the case.

Thanks,
Alexa

Begin forwarded message:

> From: Sandy Ginoza <[email-masked]>
> Date: March 13, 2012 3:09:12 PM PDT
> To: Alice Hagens <[email-masked]>
> Cc: Steve Young <[email-masked]>, [email-masked], Alexa Morris <[email-masked]>
> Subject: Re: [www.ietf.org/rt #46122] RFC 6349 PDF error 
> 
> Hi Alice,
> 
> This suggestion is correct to me if the goal is to link to the .pdf files created from the text files (all RFCs have them) -- as opposed to linking to the enhanced .pdf files (of which there are few).
> 
>> link of the form:
>> http://www.rfc-editor.org/rfc/rfcXXXX.pdf
>> should be:
>> http://www.rfc-editor.org/pdfrfc/rfcXXXX.txt.pdf
> 
> Thanks,
> Sandy
> 
> On Mar 13, 2012, at 3:04 PM, Alice Hagens wrote:
> 
>> Hi Sandy,
>> 
>> Looks like this is an error on all datatracker pages for RFCs where there is the PDF link.
>> 
>> link of the form:
>> http://www.rfc-editor.org/rfc/rfcXXXX.pdf
>> should be:
>> http://www.rfc-editor.org/pdfrfc/rfcXXXX.txt.pdf
>> 
>> Example: http://datatracker.ietf.org/doc/rfc6349/
>> link to:
>> http://www.rfc-editor.org/rfc/rfc6349.pdf
>> should be:
>> http://www.rfc-editor.org/pdfrfc/rfc6349.txt.pdf
>> 
>> Do you agree?
>> 
>> Other examples:
>> https://datatracker.ietf.org/doc/rfc5234/
>> https://datatracker.ietf.org/doc/rfc2119/
>> 
>> Alternatively: PDF link could point to the tools.ietf.org PDF
>> e.g. http://tools.ietf.org/pdf/rfc6349
>> But I'm guessing rfc-editor.org is the Right Choice.
>> 
>> Thanks,
>> Alice
>> 
>> On Mar 13, 2012, at 5:48 PM, Steve Young wrote:
>> 
>>> Hi all,
>>> 
>>> I'm sending this to a wide range of people because I'm not sure what the
>>> answer is here...
>>> 
>>> Is the error below simply because rfc6349 doesn't exist any more on
>>> rfc-editor because it's not a viable rfc and therefore shouldn't be listed
>>> in datatracker, or should it exist on rfc-editor but doesn't for some
>>> reason, or or or...
>>> 
>>> Any insight from anyone so we can determine what needs to be done to fix
>>> this would be welcome.
>>> 
>>> Thanks,
>>> Steve
>>> 
>>> On 3/13/12 1:42 PM, "Marshall Eubanks via RT" <[email-masked]> wrote:
>>> 
>>>> 
>>>> Tue Mar 13 13:42:56 2012: Request 46122 was acted upon.
>>>> Transaction: Ticket created by [email-masked]
>>>>    Queue: IETF-Action
>>>>  Subject: RFC 6349 PDF error
>>>>    Owner: Nobody
>>>> Requestors: [email-masked]
>>>>   Status: new
>>>> Ticket <URL: https://www.ietf.org/rt/Ticket/Display.html?id=46122 >
>>>> 
>>>> 
>>>> In
>>>> 
>>>> On the datatracker page for this RFC
>>>> 
>>>> http://datatracker.ietf.org/doc/rfc6349/
>>>> 
>>>> if you click on "pdf" you get
>>>> 
>>>> http://www.rfc-editor.org/rfc/rfc6349.pdf
>>>> 
>>>> which returns
>>>> 
>>>> -----
>>>> Object not found!
>>>> 
>>>> The requested URL was not found on this server. The link on the
>>>> referring page seems to be wrong or outdated. Please inform the author
>>>> of that page about the error.
>>>> 
>>>> If you think this is a server error, please contact the webmaster.
>>>> 
>>>> Error 404
>>>> 
>>>> www.rfc-editor.org
>>>> Tue Mar 13 13:39:25 2012
>>>> Apache/2.2.10 (Linux/SUSE) mod_ssl/2.2.10 OpenSSL/0.9.8h PHP/5.2.13
>>>> with Suhosin-Patch mod_python/3.3.1 Python/2.6 mod_perl/2.0.4
>>>> Perl/v5.10.0
>>>> -----
>>>> 
>>>> I have not tested this for other RFCs.
>>>> 
>>>> Regards
>>>> Marshall
>>>> 
>>>> 
>>> 
>>> 
>> 
> 

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Ole Laursen <[email-masked]>
Date: Wed, 14 Mar 2012 13:37:03 +0100

> Please see below, we think this maybe related to the database conversion but please let me know if that is not the case.

Yes, it's definitely related. There's an issue open about it now:

http://trac.tools.ietf.org/tools/ietfdb/ticket/807

Ole