Subject: [iola-conversion-tool] Bug when attempting to view announcement text for doc with no intended status

From: Cindy Morgan <[email-masked]>
Date: Thu, 23 Feb 2012 14:25:10 -0800

Hi,

When attempting to view the approval announcement text for draft-moonesamy-rfc2369bis before an Intended RFC Status had been entered for the document, I got the error below.  (Once an Intended RFC Status was entered, the message did show up as it should.)

AttributeError at /doc/draft-moonesamy-rfc2369bis/edit/approvaltext/ 

Environment:

Request Method: GET
Request URL: https://trackerbeta.ietf.org/doc/draft-moonesamy-rfc2369bis/edit/approvaltext/
Django Version: 1.2.7 SVN-3951
Python Version: 2.6.0
Installed Applications:
['django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.sites',
 'django.contrib.sitemaps',
 'django.contrib.admin',
 'django.contrib.admindocs',
 'django.contrib.humanize',
 'south',
 'workflows',
 'permissions',
 'ietf.person',
 'ietf.name',
 'ietf.group',
 'ietf.doc',
 'ietf.message',
 'ietf.announcements',
 'ietf.idindex',
 'ietf.idtracker',
 'ietf.ietfauth',
 'ietf.iesg',
 'ietf.ipr',
 'ietf.liaisons',
 'ietf.mailinglists',
 'ietf.meeting',
 'ietf.proceedings',
 'ietf.redirects',
 'ietf.idrfc',
 'ietf.wginfo',
 'ietf.submit',
 'ietf.ietfworkflows',
 'ietf.wgchairs',
 'ietf.wgcharter']
Installed Middleware:
('django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.contrib.auth.middleware.RemoteUserMiddleware',
 'django.middleware.doc.XViewMiddleware',
 'ietf.middleware.SQLLogMiddleware',
 'ietf.middleware.SMTPExceptionMiddleware',
 'ietf.middleware.RedirectTrailingPeriod',
 'django.middleware.transaction.TransactionMiddleware',
 'ietf.middleware.UnicodeNfkcNormalization')

Traceback:
File "/a/www/ietf-trackerbeta/web/django/core/handlers/base.py" in get_response
  100.                     response = callback(request, *callback_args, **callback_kwargs)
File "/a/home/henrik/tracker/4.00rc1/ietf/ietfauth/decorators.py" in inner
  51.                 return view_func(request, *args, **kwargs)
File "/a/www/ietf-trackerbeta/web/ietf/idrfc/views_ballot.py" in ballot_approvaltextREDESIGN
  1074.         existing = generate_approval_mail(request, doc)
File "/www/ietf-trackerbeta/web/ietf/idrfc/mails.py" in generate_approval_mailREDESIGN
  285.         mail = generate_approval_mail_approved(request, doc)
File "/www/ietf-trackerbeta/web/ietf/idrfc/mails.py" in generate_approval_mail_approved
  298.     doc.full_status = full_intended_status(doc.intended_std_level.name)

Exception Type: AttributeError at /doc/draft-moonesamy-rfc2369bis/edit/approvaltext/
Exception Value: 'NoneType' object has no attribute 'name'

Thanks,
Cindy

Cindy Morgan / Project Manager / IETF
48377 Fremont Blvd., Suite 117 / Fremont CA 94358
T: +1.510.492.4085 / F: +1.510.492.4001 / http://www.ietf.org
----------
Managed by Association Management Solutions (AMS);
Forum Management, Meeting and Event Planning
Website: http://www.amsl.com

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 23 Feb 2012 23:35:22 +0100

Hi Cindy,

On 2012-02-23 23:25 Cindy Morgan said the following:
> When attempting to view the approval announcement text for
> draft-moonesamy-rfc2369bis before an Intended RFC Status had been
> entered for the document, I got the error below.

Right.  A fix to handle the case where the Intended RFC Status hasn't
been set was committed by Ole 11:22 PST and deployed by me 13:31 PST.

It would however be good to know which path you took to get to the view
that blew up without setting the Intended RFC Status?

Thanks for the testing, and best regards,

	Henrik

---

From: Cindy Morgan <[email-masked]>
Date: Thu, 23 Feb 2012 14:44:03 -0800

> been set was committed by Ole 11:22 PST and deployed by me 13:31 PST.

Ah, that's what I get for going to lunch in between testing and writing up the bug report. :-)

> that blew up without setting the Intended RFC Status?

From https://trackerbeta.ietf.org/doc/draft-moonesamy-rfc2369bis/, I clicked on the "Announcement Text" link (https://trackerbeta.ietf.org/doc/draft-moonesamy-rfc2369bis/edit/approvaltext/), and that's when I got the error.

Thanks,
Cindy

> -- 
> _______________________________________________
> iola-conversion-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iola-conversion-tool
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 23 Feb 2012 23:56:51 +0100

Hi Cindy,

> writing up the bug report. :-)

Heh :-)

We received an email from the tracker about the problem, with the stack
dump (similar to what you see in the browser in test mode when something
blows up) and Ole jumped on it and put in a fix.

> From https://trackerbeta.ietf.org/doc/draft-moonesamy-rfc2369bis/, I
> clicked on the "Announcement Text" link
> (https://trackerbeta.ietf.org/doc/draft-moonesamy-rfc2369bis/edit/approvaltext/),
> and that's when I got the error.

Ah.  Thanks!

Best regards,

	Henrik