Subject: [iola-conversion-tool] Secretariat user experience

From: Cindy Morgan <[email-masked]>
Date: Tue, 7 Feb 2012 14:53:58 -0800

While logged in to https://tracker.tools.ietf.org/ as a Secretariat user:

Wish list: 

- Add a link to Management Items (currently https://datatracker.ietf.org/admin/iesg/telechatagendaitem/ on the production server) under the Secretariat heading in the sidebar.

Questions:

- On the telechat dates page, I like that we can add a whole slew of dates at once now, instead of being stuck with 4 at a time; and yes, the "suggest latest date + 14" feature works.  But without the "Rollup" function that we currently have, how does the IESG agenda get set up for the next telechat with the right date at the top and the right set of documents?

- Will the Secretariat still need to remove documents from the IESG agenda after the telechat in order to set up for the next one, or is that no longer necessary?

Bugs:

- I moved draft-ietf-dhc-dhcpv4-bulk-leasequery-05 from the 2012-02-16 agenda to the 2012-03-29 agenda using https://tracker.tools.ietf.org/iesg/agenda/documents/, and the document showed up on the 2012-03-29 agenda as a returning item, even though it is not a returning item.  (In all fairness, this has been a persistent issue with the current datatracker as well.  But this did give me the opportunity to test the "clear returning item" checkbox, and it seems to work as it's supposed to.)

- Looking at the announcement text for individual documents (e.g. https://tracker.tools.ietf.org/doc/draft-kucherawy-authres-spf-erratum/edit/approvaltext/), it looks like system plans to try and CC the announcement to [email-masked].  I would guess it's trying that because the WG is set to "none" for individual submissions, but that address is going to bounce.  (In the production version of the datatracker, announcements on individual submissions just go to IETF-Announce with a CC to the RFC Editor.)

- I tried to regenerate the approval announcement text on draft-irtf-hiprg-proxies and got an error.  (Originally, the text that was there was for a regular IETF stream doc, but I hadn't checked the "Via IRTF or RFC Editor" box when adding the doc, even though the stream menu was set to "IRTF.")  After checking the box, I tried to regenerate the announcement to see if the correct text appeared, and got this error:

Environment:

Request Method: POST
Request URL: https://tracker.tools.ietf.org/doc/draft-irtf-hiprg-proxies/edit/approvaltext/
Django Version: 1.2.7 SVN-3906
Python Version: 2.7.2
Installed Applications:
['django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.sites',
 'django.contrib.sitemaps',
 'django.contrib.admin',
 'django.contrib.admindocs',
 'django.contrib.humanize',
 'south',
 'workflows',
 'permissions',
 'ietf.person',
 'ietf.name',
 'ietf.group',
 'ietf.doc',
 'ietf.message',
 'ietf.announcements',
 'ietf.idindex',
 'ietf.idtracker',
 'ietf.ietfauth',
 'ietf.iesg',
 'ietf.ipr',
 'ietf.liaisons',
 'ietf.mailinglists',
 'ietf.meeting',
 'ietf.proceedings',
 'ietf.redirects',
 'ietf.idrfc',
 'ietf.wginfo',
 'ietf.submit',
 'ietf.ietfworkflows',
 'ietf.wgchairs',
 'ietf.wgcharter']
Installed Middleware:
('django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.contrib.auth.middleware.RemoteUserMiddleware',
 'django.middleware.doc.XViewMiddleware',
 'ietf.middleware.SQLLogMiddleware',
 'ietf.middleware.SMTPExceptionMiddleware',
 'ietf.middleware.RedirectTrailingPeriod',
 'django.middleware.transaction.TransactionMiddleware',
 'ietf.middleware.UnicodeNfkcNormalization')

Traceback:
File "/srv/www/ietfdb/django/core/handlers/base.py" in get_response
  100.                     response = callback(request, *callback_args, **callback_kwargs)
File "/srv/www/ietfdb/ietf/ietfauth/decorators.py" in inner
  51.                 return view_func(request, *args, **kwargs)
File "/srv/www/ietfdb/ietf/idrfc/views_ballot.py" in ballot_approvaltextREDESIGN
  1091.             e = generate_approval_mail(request, doc)
File "/srv/www/ietfdb/ietf/idrfc/mails.py" in generate_approval_mailREDESIGN
  282.         mail = generate_approval_mail_rfc_editor(request, doc)
File "/srv/www/ietfdb/ietf/idrfc/mails.py" in generate_approval_mail_rfc_editorREDESIGN
  365.             g = Group.objects.get(type='irtf')

Exception Type: NameError at /doc/draft-irtf-hiprg-proxies/edit/approvaltext/
Exception Value: global name 'Group' is not defined

Thanks,
Cindy

Cindy Morgan / Project Manager / IETF
48377 Fremont Blvd., Suite 117 / Fremont CA 94358
T: +1.510.492.4085 / F: +1.510.492.4001 / http://www.ietf.org
----------
Managed by Association Management Solutions (AMS);
Forum Management, Meeting and Event Planning
Website: http://www.amsl.com

---

From: Ole Laursen <[email-masked]>
Date: Wed, 8 Feb 2012 14:47:13 +0100

> - Add a link to Management Items (currently https://datatracker.ietf.org/admin/iesg/telechatagendaitem/ on the production server) under the Secretariat heading in the sidebar.

Sure, I've done that.

> - On the telechat dates page, I like that we can add a whole slew of dates at once now, instead of being stuck with 4 at a time; and yes, the "suggest latest date + 14" feature works.  But without…

Hm, good point. The current code has a set of telechat dates it
considers active, those that are either today or later. It uses them
in the same way as the old 4 dates. So if today is 2012-02-08 with
these dates

 2012-01-25  - inactive
 2012-02-08  - active
 2012-02-22  - active

then the agenda shown will be for 2012-02-08 because it's the first
active date. And tomorrow it will show the agenda for 2012-02-22. So
it's like an automatic roll-up at the end of the day. Do you think
this is fine?

> - Will the Secretariat still need to remove documents from the IESG agenda after the telechat in order to set up for the next one, or is that no longer necessary?

I'm glad you asked because the way we model this, it shouldn't be
necessary anymore. I just fixed some wrapper code to make it say the
right thing when you go to the page for a draft so I think this should
work.

> - I moved draft-ietf-dhc-dhcpv4-bulk-leasequery-05 from the 2012-02-16 agenda to the 2012-03-29 agenda using https://tracker.tools.ietf.org/iesg/agenda/documents/, and the document showed up on the 2012-03-29 agenda as a returning item, even though it is not a returning item.

Hm, yes, this doesn't make much sense. It's trying to guess whether
the draft has become a returning item or not, and failing. If I remove
all automatic guessing and the "Clear returning item" check box and
instead add a "Returning item" check box like the one in the document
edit page, would that be better? So you'd have a check box that
reflects the current status of the document and if you need to turn it
into a returning item, you can then check it.

> - Looking at the announcement text for individual documents (e.g. https://tracker.tools.ietf.org/doc/draft-kucherawy-authres-spf-erratum/edit/approvaltext/), it looks like system plans to try and CC the announcement to [email-masked].  I would guess it's trying that because the WG is set to "none" for individual submissions, but that address is going to bounce.

Odd, fixed.

> - I tried to regenerate the approval announcement text on draft-irtf-hiprg-proxies and got an error.  (Originally, the text that was there was for a regular IETF stream doc, but I hadn't checked th…

Fixed. This case was missing in the automated tests we have running,
I've added it now.

Great testing!

Ole