Subject: [iola-conversion-tool] Protocol Action vs. Document Action Messages

From: Cindy Morgan <[email-masked]>
Date: Thu, 23 Feb 2012 14:21:42 -0800

Hi,

In the approval announcements for IETF stream documents, it looks like the tracker is treating all of the messages as Protocol Actions, e.g. "Subject: Protocol Action: 'Analysis of Stateful 64 Translation' to Informational RFC (draft-ietf-behave-64-analysis-06.txt)."  However, it is only approval announcements for Standards Track and BCP documents that are Protocol Actions.  Approval announcements for Informational, Experimental and Historic* documents are Document Actions.

(*Acknowledging that Historic docs are funny sometimes and per the IESG statement on Historic, we sometimes have to change them to Document Actions manually.)

Thanks,
Cindy

Cindy Morgan / Project Manager / IETF
48377 Fremont Blvd., Suite 117 / Fremont CA 94358
T: +1.510.492.4085 / F: +1.510.492.4001 / http://www.ietf.org
----------
Managed by Association Management Solutions (AMS);
Forum Management, Meeting and Event Planning
Website: http://www.amsl.com

---

From: Ole Laursen <[email-masked]>
Date: Fri, 24 Feb 2012 17:57:46 +0100

> In the approval announcements for IETF stream documents, it looks like the tracker is treating all of the messages as Protocol Actions, e.g. "Subject: Protocol Action: 'Analysis of Stateful 64 Tran…

I'm not sure what exactly went wrong but the code was looking at the
indefinite article of the intended status which is really odd. Instead
I now just compare it with your list.

Ole

---

From: Cindy Morgan <[email-masked]>
Date: Fri, 24 Feb 2012 09:15:52 -0800

> I now just compare it with your list.

FWIW, whatever is being used to tell the difference between Protocol and Document Actions on the IESG agenda (https://trackerbeta.ietf.org/iesg/agenda/?private) does seem to be working as it should.  But I just checked several docs listed on the agenda as Document Actions*, and their approval announcement text is still being generated as Protocol Actions.

* draft-ietf-v6ops-v6nd-problems
  draft-snell-atompub-tombstones
  draft-ietf-lisp-interworking
  draft-ietf-behave-64-analysis

Thanks,
Cindy

> 
> 
> Ole
> -- 
> _______________________________________________
> iola-conversion-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iola-conversion-tool
>

---

From: Russ Housley <[email-masked]>
Date: Fri, 24 Feb 2012 12:24:11 -0500

Ole:

Items in Section 2 of the Telechat agenda should produce Protocol Action messages.  These are BCPs, Proposed Standards, and Internet Standards.

Items in Sections 3.1 and 3.2 of the Telechat agenda should produce Document Action messages.  These are Informational, Experimental, and Historic RFCs.

Hope this helps,
  Russ

---

From: Ole Laursen <[email-masked]>
Date: Fri, 24 Feb 2012 18:38:08 +0100

2012/2/24 Cindy Morgan <[email-masked]>:
> FWIW, whatever is being used to tell the difference between Protocol and Document Actions on the IESG agenda (https://trackerbeta.ietf.org/iesg/agenda/?private) does seem to be working as it should.

Yes, I had a closer look, and I can see now why it broke (it
accidentally got the intended status without the indefinite article).
Anyway, choosing between Procotol/Document Action based on whether the
intended status should be prefixed with "an" or "a" is brittle. Future
generations of IETF code base maintainers will thank us for getting
rid of that abomination.

> But I just checked several docs listed on the agenda as Document Actions*, and their approval announcement text is still being generated as Protocol Actions.
>

Ah, sorry, we need to wait a second for Henrik to deploy the update. I
did check it on my local server, and I think we're good, but would
appreciate if you would try it too when he's deployed it.

Ole

---

From: Ole Laursen <[email-masked]>
Date: Fri, 24 Feb 2012 18:48:53 +0100

> Items in Sections 3.1 and 3.2 of the Telechat agenda should produce Document Action messages.  These are Informational, Experimental, and Historic RFCs.

Right, I think we're just waiting for Henrik to deploy it now.

Ole

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 24 Feb 2012 19:45:50 +0100

> appreciate if you would try it too when he's deployed it.

Fix deployed!  (I was en-route home, via a number of shops).

Best regards,

	Henrik

---

From: Cindy Morgan <[email-masked]>
Date: Fri, 24 Feb 2012 10:54:09 -0800

> Fix deployed!  (I was en-route home, via a number of shops).

And fix confirmed--all of the docs on the agenda that should be Document Actions are now generating their approval announcements as such. Thank you!

Cindy