Subject: [iola-conversion-tool] State changing bug "Approved announcement sent" to "RFC Editor Queue"

From: Amy Vezza <[email-masked]>
Date: Wed, 22 Feb 2012 11:24:02 -0500

Logged in as a Secretariat user, I tried to change a document state from "Approved Announcement Sent" to "RFC Editor Queue."  On this page:
https://trackerbeta.ietf.org/doc/draft-ietf-dhc-pd-exclude/edit/state/
(also checked this one https://trackerbeta.ietf.org/doc/draft-os-ietf-sshfp-ecdsa-sha2/edit/state/ - same issue)

the "Or jump directly to" button should go to "RFC Editor Queue" as the next state on the publication path, and not "Approved-announcement to be sent" - which is a state backwards on the publication path.  It should have two button links here - "Or jump directly to" which goes forward on the publication path, and "Or revert to previous state" which goes back.  It seems these have been merged.

Using the drop-down list of possible states seems to have worked correctly.

Best regards,

Amy

---

From: Ole Laursen <[email-masked]>
Date: Wed, 22 Feb 2012 19:16:14 +0100

Hi!

> https://trackerbeta.ietf.org/doc/draft-ietf-dhc-pd-exclude/edit/state/

It looks like I managed to swap "Approved-announcement to be sent" and
"Approved Announcement Sent" with regards to what is considered the
next states. I've fixed that now, this should work correctly after the
next import-states.py run (I think that's within 24 hours).

> It should have two button links here - "Or jump directly to" which goes forward on the publication path, and "Or revert to previous state" which goes back.  It seems these have been merged.

"Or revert to previous state" doesn't work right after import at the
moment, it's a long story, but basically it's not easy to get the
necessary information extracted correctly from the old database and
put into the new one, so we currently cut a corner there. So that's
why it doesn't show it.

It will show up again as soon as the new system sees a state change
for the document (since it will then have stored the necessary
information).

Thanks for the report!

Ole