Subject: [iola-conversion-tool] Secretariat access bug?

From: Cindy Morgan <[email-masked]>
Date: Mon, 30 Jan 2012 16:34:45 -0800

While logged in to https://tracker.tools.ietf.org/ as a Secretariat user:

- When I click on the Telechat Dates link under the Secretariat heading in the sidebar, it redirects to https://tracker.tools.ietf.org/admin/iesg/telechatdate/, where all it says is "Permission denied."

- The Working Groups option under the Secretariat heading seems to be missing entirely from the sidebar.  (https://tracker.tools.ietf.org/iesg/wgactions/ does exist, but is not in the sidebar as it currently is on the production server.)

Thanks,
Cindy

Cindy Morgan / Project Manager / IETF
48377 Fremont Blvd., Suite 117 / Fremont CA 94358
T: +1.510.492.4085 / F: +1.510.492.4001 / http://www.ietf.org
----------
Managed by Association Management Solutions (AMS);
Forum Management, Meeting and Event Planning
Website: http://www.amsl.com

---

From: Ole Laursen <[email-masked]>
Date: Tue, 31 Jan 2012 13:03:53 +0100

> - When I click on the Telechat Dates link under the Secretariat heading in the sidebar, it redirects to https://tracker.tools.ietf.org/admin/iesg/telechatdate/, where all it says is "Permission den…

Hm, that is because your user didn't have permission to access to the
admin area. I have changed the importer now to give all Secretariat
users access to that. So this should work when the importer has had a
chance to run again.

Note that the interface for telechat dates looks a bit different - I
don't know if you have talked to Ryan about this, but rather than just
storing 4 dates and rotating them, we store all the dates, but of
course only show those in the future in the various dropdown boxes. So
instead of rotating, you press the "Add telechat date" button in the
upper right corner and save that. If I managed to not botch it
completely, it should suggest latest date + 14 days.

> - The Working Groups option under the Secretariat heading seems to be missing entirely from the sidebar.  (https://tracker.tools.ietf.org/iesg/wgactions/ does exist, but is not in the sidebar as it…

Oops. Fixed. Sorry.

Thanks for testing!

Ole