Subject: [Ietf-and-github] Draft: requirements for third-party tools

From: Mark Nottingham <[email-masked]>
Date: Fri, 3 Mar 2017 12:55:18 +1100

I went and scribbled down what I meant when I said we should start by just documenting hard requirements, rather than advice.

See:
 https://mnot.github.io/I-D/wugh-services/

It's pretty rough and not submitted yet, will do so if there are encouraging noises / feedback.

Thanks,

--
Mark Nottingham   https://www.mnot.net/

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Mar 2017 13:54:32 +0200

I like this a lot!

Definitely worth submitting.

Jari

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 9 Mar 2017 15:10:48 +0000

>  https://mnot.github.io/I-D/wugh-services/

A nice start.

I think a separate section on web-based (which browsers) and command-line based (which operating systems) would be worthwhile.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 10 Mar 2017 08:45:25 +1100

> On 10 Mar 2017, at 2:10 am, Salz, Rich <[email-masked]> wrote:
> 

Thanks. The idea here is just to document our high-level requirements for the third-party services/tools we use, which should be relatively stable.

Tool-specific advice / practices can go in another document (and it's not clear that it would need to be an RFC). Or are you saying that there are requirements specific to the type of tool that aren't captured yet?

Cheers,

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 9 Mar 2017 23:16:43 +0000

> Tool-specific advice / practices can go in another document (and it's not clear
> that it would need to be an RFC). Or are you saying that there are
> requirements specific to the type of tool that aren't captured yet?

I think there are considerations, not necessarily requirements, that aren't considered yet.

For example, a web-based tool that uses JS to fully function is probably okay. A command-line tool that only runs under DOS is probably not okay.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 9 Mar 2017 23:26:03 +0000

> Does that help?

Yes.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 10 Mar 2017 10:25:09 +1100

> On 10 Mar 2017, at 10:16 am, Salz, Rich <[email-masked]> wrote:
> 
> 

I think this goes to accessibility -- if a tool doesn't run on the platform that one of its users prefers, that's a problem. We should take reasonable efforts to have tools that are usable across a spectrum of common platforms -- e.g., Linux, Windows, OSX, Android, iOS.

However, enumerating them is probably not a great place to go; neither is requiring all of them. I could see saying something like:

"""
When choosing a tool, a Working Group MUST consider the breadth of platform(s) it is available upon; tools that are platform-specific SHOULD NOT be chosen unless there is consensus in the Working Group that the benefits of using that tool outweigh this limitation, and no suitable alternative is available. Tools that are specific to individual users (e.g., the Editors) MAY be exempted from this requirement, although the Working Group Chair(s) MUST approve of such choices.
"""

Does that help?

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 10 Mar 2017 16:00:47 +1100

Done.

https://tools.ietf.org/html/draft-nottingham-wugh-services-00

Cheers,

> On 9 Mar 2017, at 10:54 pm, Jari Arkko <[email-masked]> wrote:
> 
> I like this a lot!
>

---

From: Martin Thomson <[email-masked]>
Date: Fri, 10 Mar 2017 16:08:15 +1100

Inspired, I re-read this.  One nit:

  "That said, backups SHOULD be in open formats
   (e.g., XML, JSON)."

Use of XML or JSON is in no way exemplary of open.  These meta-formats
are perhaps more conducive to the creation of formats that are open,
but there are enough counter-examples of XML and JSON abuse for
proprietary ends that I would simply remove this parenthetical.
Well-documented is - I think - what you really mean here.

On 10 March 2017 at 16:00, Mark Nottingham <[email-masked]> wrote:
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 10 Mar 2017 16:16:01 +1100

> On 10 Mar 2017, at 4:08 pm, Martin Thomson <[email-masked]> wrote:
> 

I didn't want to intimate that content had to be in an open / standard format. 

"Well-documented" is better, but the Github issues format isn't particularly well-documented; it's more self-documenting (the closest they seem to come is a few examples in <https://developer.github.com/v3/issues/>). When push comes to shove that will suffice for our purposes.

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 20 Mar 2017 13:36:27 -0400

Couple of thoughts on this doc:

2.2: People can’t be prevented from covering the fees for everyone to use a tool if they want to do that, but it seems like there is some danger there of a WG becoming too reliant on paid-for features and having the person who paid change jobs or roles or otherwise decide to stop paying before the work is done. Might just be something to note as folks consider this.

2.7: I’d like to see the possibility of secretariat access included here for commonly-used tools.

Thanks,
Alissa

> On Mar 10, 2017, at 12:00 AM, Mark Nottingham <[email-masked]> wrote:
> 
> Done.
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 21 Mar 2017 09:53:53 +1100

> On 21 Mar 2017, at 4:36 am, Alissa Cooper <[email-masked]> wrote:
> 

Agreed; I think it makes sense to add a cautionary note here.

> 2.7: I’d like to see the possibility of secretariat access included here for commonly-used tools.

So, what would the purpose of that be? I'd be concerned if they started changing repo settings, doing checkins or adding people to the organisation.

Cheers,

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 21 Mar 2017 17:02:42 -0400

> On Mar 20, 2017, at 6:53 PM, Mark Nottingham <[email-masked]> wrote:
> 
> 

It would be for the same reason that they have administrative access to the datatracker. If adding/removing responsible people becomes a routine part of the transition process when we have changes in personnel, it takes the load off of ADs and chairs if they just have to click one button in the datatracker and all of the associated permissions/roles get changed correctly by the secretariat.

Alissa

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 22 Mar 2017 12:09:17 +1100

> On 22 Mar 2017, at 8:02 am, Alissa Cooper <[email-masked]> wrote:
> 
> 

How about something like: "When third party tools become so commonly used that the IETF defines best practices for their use, those guidelines SHOULD define what the Secretariat's role is in their use."

?

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 23 Mar 2017 15:34:55 -0400

> On Mar 21, 2017, at 9:09 PM, Mark Nottingham <[email-masked]> wrote:
> 
> How about something like: "When third party tools become so commonly used that the IETF defines best practices for their use, those guidelines SHOULD define what the Secretariat's role is in their use.”

I’m not a big fan of these sort of process documents putting normative requirements on each other. If folks don’t think this is appropriate to include in this doc, the details could just be included in Martin’s doc.

Alissa