Subject: [Ietf-and-github] Draft/proposed BCP on GitHub usage

From: Martin Thomson <[email-masked]>
Date: Sat, 18 Feb 2017 09:52:23 +1100

Alia and I were discussing the proposed "BOF" for Chicago.  It was
apparent that lack of something concrete to talk about was the main
reason we were having second thoughts about having the meeting.

We decided to remove that uncertainty, which made the decision about
whether to have the meeting much easier.  Thus, it appears as though
we will have a short meeting AND we now have something to argue about.
Obviously, this is very drafty right now, but better to get the
feedback cycle started early.

See: https://tools.ietf.org/html/draft-thomson-github-bcp

Contrary to all expectations, the draft is also on GitHub:
  https://github.com/unicorn-wg/github-bcp

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 21 Feb 2017 22:32:51 +0000

>   https://github.com/unicorn-wg/github-bcp

Not bad.  I liked section 9.

I would like to see more text about GitLab, too.  I know at least openpgp uses it.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Feb 2017 16:11:34 +1100

> I would like to see more text about GitLab, too.  I know at least openpgp uses it.

I don't know how you see ACME benefiting from its use of GitHub, but I
have seen the benefits from reaching existing GitHub users.  Though
GitLab is quite good, installing our own copy of anything wouldn't end
up with us gaining access to GitHub users.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 22 Feb 2017 17:15:11 +1100

I feel like this wants to be two documents, and one of them might not even be an I-D.

We need a short, sharp document that very concisely lays out the administrative requirements (in RFC2119) for using Github (and similar things?) at the IETF. 

That document is probably relatively long-lived.

Then, we need to collect advice for people who use such things, based upon experience. That's likely to change a fair amount of time, and doesn't need to be an RFC.

Cheers,

> On 18 Feb 2017, at 9:52 am, Martin Thomson <[email-masked]> wrote:
> 
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 22 Feb 2017 07:56:41 +0000

> I don't know how you see ACME benefiting from its use of GitHub, but I have
> seen the benefits from reaching existing GitHub users.  Though GitLab is
> quite good, installing our own copy of anything wouldn't end up with us
> gaining access to GitHub users.

Either you're confused or I don't understand your response.  Gitlab offers free hosting just like github.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Feb 2017 19:17:22 +1100

> Either you're confused or I don't understand your response.  Gitlab offers free hosting just like github.

Ahh, that's probably because I am confused, or I haven't been clear enough.

There are two things that I had considered: using github and using an
private install of gitlab.  I see no real value in using a hosted
service if it isn't github.

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Feb 2017 19:18:04 +1100

> We need a short, sharp document that very concisely lays out the administrative requirements (in RFC2119) for using Github (and similar things?) at the IETF.

This is where I was headed, though the expository text is perhaps a
little broader than that narrower remit would dictate.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 22 Feb 2017 08:22:58 +0000

>  I see no real value in using a hosted service if it isn't github.

Then please consider this a request to add some rationale for that.

If we are going to put all of these eggs in the GH basket, which is okay with me, then perhaps the IETF should reach out to GH and see about making things more official and seamless.  For example, an IETF organization and naming groups like ietf-wg-xxxxx.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Feb 2017 07:53:06 +1100

On 22 February 2017 at 19:22, Salz, Rich <[email-masked]> wrote:
> perhaps the IETF should reach out to GH and see about making things more official and seamless.  For example, an IETF organization and naming groups like ietf-wg-xxxxx.

FWIW, I'm discussing with the IESG about how that might proceed.  The
IETF already has a github organization.  I don't think that we can
camp on a slice of the namespace, but will have to accept that names
are vulnerable.

We're not that special, and I don't think we need special treatment.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 22 Feb 2017 20:58:30 +0000

> FWIW, I'm discussing with the IESG about how that might proceed.  The IETF
> already has a github organization.  I don't think that we can camp on a slice of
> the namespace, but will have to accept that names are vulnerable.
> 

Don't know what's there until you ask about it. :)

I think the naming scheme in your draft is backwards; ietf-wg-xxxx makes things much easier to find.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Feb 2017 10:50:02 +1100

+1

> On 23 Feb 2017, at 7:53 am, Martin Thomson <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 22 Feb 2017 15:53:10 -0800

Maybe ietf-wg-<wgname>wg. Which I think we can agree will be awesome for
tsvwg.

Seriously, ietf-wg-<wgname> seems fine.

-Ekr

On Wed, Feb 22, 2017 at 3:50 PM, Mark Nottingham <[email-masked]> wrote:

> >> perhaps the IETF should reach out to GH and see about making things
> more official and seamless.  For example, an IETF organization and naming
> groups like ietf-wg-xxxxx.
> >
> >

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Feb 2017 10:57:44 +1100

Having a convention would imply that any name conforming to it is "official." Unless we can get an agreement with Github to their exclusive use, that doesn't seem like a good idea.

I personally don't think it's worth the effort.

> On 23 Feb 2017, at 10:53 am, Eric Rescorla <[email-masked]> wrote:
> 
> Maybe ietf-wg-<wgname>wg. Which I think we can agree will be awesome for tsvwg.
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 22 Feb 2017 19:01:01 -0500

Making it easy to find them seems helpful to me.

Regards,
Alia

On Feb 22, 2017 6:57 PM, "Mark Nottingham" <[email-masked]> wrote:

> Having a convention would imply that any name conforming to it is
> "official." Unless we can get an agreement with Github to their exclusive
> use, that doesn't seem like a good idea.
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Feb 2017 11:03:26 +1100

That's why we have <https://datatracker.ietf.org/wg/>. 

Besides, not all WGs are going to be on Github. 

Yet.

> On 23 Feb 2017, at 11:01 am, Alia Atlas <[email-masked]> wrote:
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 22 Feb 2017 19:11:09 -0500

> That's why we have <https://datatracker.ietf.org/wg/>.

Having a convention that makes it easier for a more casual participant (who
doesn't
know of or use the datatracker) seems useful to me - particularly since the
cost to
do it doesn't feel high to me.   What are you seeing as the downside?

I am, of course, only talking about finding the repository associated with
a WG if the
WG is using Github.

> Yet.

That's a much more nuanced discussion and highly depends on what the
perceived
benefits are for a particular WG.

Regards,
Alia

---

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Feb 2017 11:25:33 +1100

On 23 February 2017 at 11:11, Alia Atlas <[email-masked]> wrote:
> know of or use the datatracker) seems useful to me

A convention is fine.  But you don't need to BCP something to get a
convention.  I think that is where the disconnect lies.

If you look at the working groups that are using GitHub already, the
naming is pretty random.  And frankly, I think that is fine.  We have
a working directory of working groups in the datatracker.

That also addresses the issue of having someone decide to go to
bitbucket or gitlab.  All the datatracker needs to do is link to the
working group hub/organization/repo/whatever.

In addition to this, it would be nice to collect a specific repository
link in draft metadata.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Feb 2017 11:26:09 +1100

> On 23 Feb 2017, at 11:11 am, Alia Atlas <[email-masked]> wrote:
> 
> Having a convention that makes it easier for a more casual participant (who doesn't
> know of or use the datatracker) seems useful to me - particularly since the cost to

We don't control that name space, and if we imply that any github org starting with ietf-* is an IETF WG, that can be abused, unless we have an agreement with the manager of the name space (github). 

If we can get that agreement easily, great, but I suspect it may not be easy (since AFAICT it will set a precedent for them, and they'll need to develop internal policies for it).

If we don't get such an agreement, it will be extremely easy to squat on a WG's name, either unintentionally or intentionally. For example, the QUIC proponents reserved "IETF-QUIC"; we decided not to reuse it because we needed a clean break.

Also, we have a number of WGs that already use Github that don't conform to any convention, so we'll either have inconsistencies, or need to move orgs and wear the potential mess that will create.

To be clear -- I'm not necessarily against having a suggested naming scheme, but  the value seems pretty low if we don't have a way of guaranteeing that a given WG name maps to a given github org. Making it a requirement without such a guarantee would be unworkable, and even if we did have the guarantee, we'd still have a legacy problem. 

Cheers,

P.S. There are already about 20 users/orgs starting with "ietf-" on Github, and many of them are not IETF WGs; quite a few are not official IETF efforts at all.

> 
> I am, of course, only talking about finding the repository associated with a WG if the
> WG is using Github.
> 
> That's a much more nuanced discussion and highly depends on what the perceived

---

From: Alia Atlas <[email-masked]>
Date: Wed, 22 Feb 2017 19:32:09 -0500

I see the value in having a suggested naming scheme for future WGs that
decide to use github.
I certainly hear the concern about mandating it - and that isn't what I put
in the draft.   The draft does say that there SHOULD be a consistent naming
scheme; the specific one (and ietf-wg-<wgname> would be fine!) isn't
particularly important.

If there is no recommendation, then the current state will remain the same
going forward - which makes it harder, IMHO, for the random community
outreach benefits that going to GitHub provides.

Regards,
Alia

On Wed, Feb 22, 2017 at 7:26 PM, Mark Nottingham <[email-masked]> wrote:

> We don't control that name space, and if we imply that any github org
> starting with ietf-* is an IETF WG, that can be abused, unless we have an
> agreement with the manager of the name space (github).
>
> If we can get that agreement easily, great, but I suspect it may not be
> easy (since AFAICT it will set a precedent for them, and they'll need to
> develop internal policies for it).
>
> If we don't get such an agreement, it will be extremely easy to squat on a
> WG's name, either unintentionally or intentionally. For example, the QUIC
> proponents reserved "IETF-QUIC"; we decided not to reuse it because we
> needed a clean break.
>
> Also, we have a number of WGs that already use Github that don't conform
> to any convention, so we'll either have inconsistencies, or need to move
> orgs and wear the potential mess that will create.
>
> To be clear -- I'm not necessarily against having a suggested naming
> scheme, but  the value seems pretty low if we don't have a way of
> guaranteeing that a given WG name maps to a given github org. Making it a
> requirement without such a guarantee would be unworkable, and even if we
> did have the guarantee, we'd still have a legacy problem.
>
> Cheers,
>
> P.S. There are already about 20 users/orgs starting with "ietf-" on
> Github, and many of them are not IETF WGs; quite a few are not official
> IETF efforts at all.
>
>
> >
> > > > >> perhaps the IETF should reach out to GH and see about making
> things more official and seamless.  For example, an IETF organization and
> naming groups like ietf-wg-xxxxx.
> > > > >
> > > > >

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 22 Feb 2017 19:41:26 -0500

Using the WG name in the repository so that Google searching is useful.
But expecting folks to understand what they find there without finding 
the IETF WG information seems to me to be unlikely to be useful.

So I really am not worried about whether the repository name is easily 
guessed / guessable.

Yours,
joel

On 2/22/17 7:11 PM, Alia Atlas wrote:
> On Wed, Feb 22, 2017 at 7:03 PM, Mark Nottingham <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     That's why we have <https://datatracker.ietf.org/wg/
>     <https://datatracker.ietf.org/wg/>>.
>
>
>     > On 23 Feb 2017, at 11:01 am, Alia Atlas <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     > On Feb 22, 2017 6:57 PM, "Mark Nottingham" <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     "official." Unless we can get an agreement with Github to their
>     exclusive use, that doesn't seem like a good idea.
>     >
>     > > On 23 Feb 2017, at 10:53 am, Eric Rescorla <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     > >
>     > > On Wed, Feb 22, 2017 at 3:50 PM, Mark Nottingham <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     > > +1
>     > >
>     > >
>     > > > On 23 Feb 2017, at 7:53 am, Martin Thomson
>     <[email-masked] <mailto:[email-masked]>> wrote:
>     > > >
>     > > > On 22 February 2017 at 19:22, Salz, Rich <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     things more official and seamless.  For example, an IETF
>     organization and naming groups like ietf-wg-xxxxx.
>     > > >
>     > > >
>     > > > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/ietf-and-github>
>     > >
>     > > --
>     > > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/ietf-and-github>
>     > >
>     >
>     > --
>     > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/ietf-and-github>
>
>     --

---

From: Alia Atlas <[email-masked]>
Date: Wed, 22 Feb 2017 19:47:13 -0500

On Wed, Feb 22, 2017 at 7:41 PM, Joel M. Halpern <[email-masked]>
wrote:

> But expecting folks to understand what they find there without finding the
> IETF WG information seems to me to be unlikely to be useful.
>

I'd have to defer to those who have been getting comments and reviews from
those who don't participate in the IETF generally.  Martin may have a
useful perspective.

There'll be the Note Well equiv and probably pointers to the IETF
datatracker.

> So I really am not worried about whether the repository name is easily

I certainly don't see a need to try and "harmonize" or change existing
use.  Having consistency going forward could be helpful - but the minimum
is having the WG name & hopefully IETF so that it works well for searches.

Of course, I'm happy to document whatever the community thinks is best.

Regards,
Alia

Yours,

---

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Feb 2017 11:50:50 +1100

On 23 February 2017 at 11:47, Alia Atlas <[email-masked]> wrote:
> those who don't participate in the IETF generally.  Martin may have a useful
> perspective.

I don't find that searching works for finding these sorts of things,
except as a last resort.  Even for search engines, links matter a lot.

GitHub has recently added a tagging capability that might help us more
than any naming convention:

https://github.com/search?utf8=%E2%9C%93&q=topic%3Aietf&type=Repositories&ref=searchresults

The results are already interesting.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Feb 2017 12:20:00 +1100

On 23 February 2017 at 12:16, Salz, Rich <[email-masked]> wrote:
> So Martin says the name doesn't matter, but apparently it does matter to him, because he doesn't like the common prefix that I suggested which would make it easier for non-IETF folks to find "wow, look at all the stuff that the IETF does."

I never said anything of the sort.  I think that a convention is fine.
A stricture isn't practical and that is what you get when you include
it in a document.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 23 Feb 2017 01:16:30 +0000

> I don't find that searching works for finding these sorts of things, except as a
> last resort.  Even for search engines, links matter a lot.

Mark is bothered that folks may think the name implies something official which I think is bogus.  Martin points out tagging, which is unrestrained; Mark are you worried about that?

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 23 Feb 2017 12:44:29 +1100

> On 23 Feb 2017, at 12:16 pm, Salz, Rich <[email-masked]> wrote:
> 
> Mark is bothered that folks may think the name implies something official which I think is bogus.

OK, nice to know...

>  Martin points out tagging, which is unrestrained; Mark are you worried about that?

No. I'm not concerned about what happens in places that we don't control; I'm concerned when we act like we do control them. Each WG is going to need to find a name that works for them, within the constraints of what's available. 

As I have said, I'm OK with advice or a suggestion for a good name here (as common senses dictates; "QUIC-WG" is better than "xwhevhw7w"). Requiring a particular structure with RFC2119 language isn't well-matched with reality.