Subject: [Ietf-and-github] GitHub best practices document?

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 20 Jan 2017 08:10:50 +0000

Hi,

I've just went through setting up GitHub for the QUIC WG, and there were some non-trivial configuration steps in order to get, e.g., an "issues" mailing list set up @ietf.org and making sure it receives (only) the necessary emails from GitHub.

Is anyone working on a "GitHub best practices I-D"? If not, should we start one?

Lars

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 20 Jan 2017 19:29:31 +1100

I'm not sure we're *quite* at the **best** practices stage yet -- we're still feeling our way around.

That said, documenting some common pitfalls / options / etc. would be helpful. Happy to help...

> On 20 Jan 2017, at 7:10 pm, Eggert, Lars <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

--
Mark Nottingham   https://www.mnot.net/

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 20 Jan 2017 08:46:42 +0000

> I'm not sure we're *quite* at the **best** practices stage yet -- we're still feeling our way around.

What do you mean? Whatever I do is a best practice :-)

> That said, documenting some common pitfalls / options / etc. would be helpful. Happy to help...

What Mark said.

Lars

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 20 Jan 2017 13:28:40 +0100

>> That said, documenting some common pitfalls / options / etc. would be helpful. Happy to help...

Would be extremely helpful, happy to contribute as well.

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                     678B 08B5 A0F2 636D 68E9

---

From: Dave Crocker <[email-masked]>
Date: Fri, 20 Jan 2017 06:59:58 -0800

>> Is anyone working on a "GitHub best practices I-D"? If not, should we start one?

Yes, please.  I'm a github extreme novice and would be eager to assist 
in the writing/editing of such a document.

I'd try to produce an initial draft, except for that novice bit getting 
in my way...

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 20 Jan 2017 08:24:57 -0800

On 20 Jan 2017, at 0:10, Eggert, Lars wrote:

> I've just went through setting up GitHub for the QUIC WG, and there 
> were some non-trivial configuration steps in order to get, e.g., an 
> "issues" mailing list set up @ietf.org and making sure it receives 
> (only) the necessary emails from GitHub.
>

I am not working on one yet, but if no one else is, I'll start one where 
the first four people who offer substantial text can be co-authors. :-)

--Paul Hoffman

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 20 Jan 2017 17:18:26 +0000

Hi,

I put a start here: https://github.com/larseggert/github-bcp

Also, Martin Thomson (CC'ed in case he is not on this list) has lots of suitable text already, e.g., here in the various .md files here: https://github.com/martinthomson/i-d-template/tree/master/doc

Lars