Subject: Re: [httpwg/http-extensions] multiple 103s are cumulating or overwriting headers? (#371)

From: HTTP issue updates <[email-masked]>
Date: Thu, 03 Aug 2017 22:00:49 -0700

This is an interesting question. I think that we should agree on what the expected behavior is before discussing how (or if) we should update the text.

Regarding the question, I think that we should consider two (or more) Early Hints responses as expectations from different sources, rather than considering the following one to update the earlier ones. 

The reason I think so is because nonexistence of a header field in the 103 response does not imply that the header field will not exist in the final response, since we are not required to include in 103 response all the headers that are expected to be included in the final response.

So consider the following example: a caching intermediary might generate an Early Hints response from a stale-cached response. That Early Hints response could contain a header field that will never be included within an Early Hints response sent from the origin. In such case, considering both of the Early Hints responses as genuine makes the most sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/371#issuecomment-320156679

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 10 Aug 2017 21:00:35 -0700

Closed #371 via #380.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/371#event-1202035059