Subject: Re: [httpwg/http-extensions] Form-encode Expect-CT report bodies? (#356)

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 12:52:58 +0000 (UTC)

Moving discussion over to Fetch (https://github.com/whatwg/fetch/issues/567), will circle back here if it turns out there's something we should do in Expect-CT specifically. cc @martinthomson 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#issuecomment-316376170

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 12:52:59 +0000 (UTC)

Closed #356.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#event-1170168934

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 14:06:51 +0000 (UTC)

@estark37, I don't want to create a false impression that there is no issue remaining.  Is your intent to track the issue we discussed in some other way?

As we discussed, I think that the requesting origin for the request is the origin of the response that contained the Expect-CT header field.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#issuecomment-316397412

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 07:18:55 -0700

@martinthomson I thought your suggestion was to discuss with Fetch how to handle these requests?

I'm fine with using the Expect-CT origin as the Origin for the preflight, but I'm still not sure that the Expect-CT spec is the right place to say that, as it doesn't make sense for non-browser clients. (I think it belongs better in Fetch.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#issuecomment-316402359

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 07:18:56 -0700

Reopened #356.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#event-1170328769

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 19 Jul 2017 14:32:35 +0000 (UTC)

OK, that sounds good.  My suggestion is to keep this open until we have greater clarity about how this is captured, even if that means closing this with no action because Fetch is covering it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/356#issuecomment-316406555