Subject: [httpwg/http-extensions] Expectations of Origin Set Size (#369)

From: HTTP issue updates <[email-masked]>
Date: Tue, 18 Jul 2017 05:28:21 -0700

>From Lucas:

If my interpretation of the specification is correct, the Origin Set is currently unbounded. While the size of an individual H2 frame is bounded and negotiated, the Origin set can seemingly be added to ad nauseam. Even in the default size case, for a short ASCII-Origin such as http://dk, if might be possible to create an Origin set with ~1500 entries. I like the fact that ORIGIN frame extension doesn’t need any negotiation, so perhaps some guidance for client-side implementations would help e.g. be aware of the Origin Set size and be prepared to close the connection if you’re getting unhappy.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/369

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 31 Jul 2017 04:36:06 +0000 (UTC)

Closed #369 via 8b3b56bd17dccec24386a1916f6e7975b0bc3da3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/369#event-1185091805