Subject: Re: [httpwg/http-extensions] Address client-hints-04 feedback (#361)

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Jun 2017 14:01:38 -0700

@igrigorik pushed 1 commit.

78a0a61  define repeat Accept-CH-Lifetime behavior

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/361/files/23134069680a43fbce80ecd2f0fb781e1d397ff8..78a0a61a8460c3da4415b76bea52cb3953dec7f7

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Jun 2017 18:30:49 -0700

mnot approved this pull request.

LGTM. I suspect you might have people bring up further nits about the boilerplate, etc. in IETF LC, but let's let them raise them (gives people something to do :)

Go ahead and ship a new draft and we'll kick it down the road.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/361#pullrequestreview-46425122

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Jun 2017 21:21:52 -0700

Oh, one thing -- you removed Downlink. It'd be good to mention that in the change notes, and on list, so people are aware.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/361#issuecomment-311249084

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Jun 2017 23:33:25 -0700

reschke commented on this pull request.

> @@ -89,7 +89,7 @@ Client Hints does not supersede or replace the User-Agent header field. Existing
 
 ## Notational Conventions
 
-The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this document are to be interpreted as described in {{RFC2119}}.
+The key words "MUST", "MUST NOT", "REQUIRED", "SHOULD", "SHOULD NOT", "MAY", and "OPTIONAL" in this document are to be interpreted as described in BCP 14 {{RFC2119}} when, and only when, they appear capitalized, as shown.

This doesn't seem to be consistent with https://tools.ietf.org/html/rfc8174#section-2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/361#pullrequestreview-46453954

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Jun 2017 00:42:50 -0700

igrigorik commented on this pull request.

 

Good catch, looks like I took the text from outdated draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/361#discussion_r124199273

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Jun 2017 00:43:36 -0700

@igrigorik pushed 2 commits.

0fd7787  update upper vs lower case to latest guidance
e3827a9  since 04 changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/361/files/78a0a61a8460c3da4415b76bea52cb3953dec7f7..e3827a9a89eddb85606112d4f2caea7aaa5e11dd

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Jun 2017 00:44:28 -0700

Thanks guys, pushed a few more updates. 

@reschke everything else looks good? If so I'll squash+push a new draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/361#issuecomment-311279828