Subject: [httpwg/http-extensions] Header relationships, cardinality (#360)

From: HTTP issue updates <[email-masked]>
Date: Mon, 19 Jun 2017 17:18:34 -0700

>From thread at <http://www.w3.org/mid/[email-masked]>:

> Is it assumed that "Accept-CH" is given in http-equiv attribute, but "Accept-CH-Lifetime" on http response ?

Yes. 

> Or is that needed so that "Accept-CH" can be given on several times?

No, that's implicit in its definition as a comma separated list of values. Correct me if I'm wrong, but my understanding is that default semantics allow multiple headers with same field-name, as long as the field-value is defined as a comma separated list.. Meaning, there can be multiple Accept-CH header fields and they can be combined into a single list.
 
> What happens if there is several "Accept-CH-Lifetime" on response?

For Accept-CH-Lifetime, I guess we just need to specify which one wins, correct? Any defaults I can point to or reuse? Last one wins?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/360

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Jun 2017 14:02:23 -0700

I believe https://github.com/httpwg/http-extensions/pull/361 should address this, ptal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/360#issuecomment-311180948