Subject: Re: [httpwg/http-extensions] settings parameter to indicate support for CACHE_DIGEST (#340)

From: HTTP issue updates <[email-masked]>
Date: Sun, 30 Apr 2017 18:11:58 -0700

mnot commented on this pull request.

Looks good to me, delta the one comment I made.

+FRESH (0x1): When set, it indicates that the server is willing to make use of a digest of freshly-cached responses.
+
+STALE (0x2): When set, it indicates that the server is willing to make use of a digest of stale-cached responses.
+
+Rest of the bits MUST be ignored and MUST be left unset when sending.
+
+The initial value of the parameter is zero (0x0) meaning that the server is not interested in seeing a CACHE_DIGEST frame.
+
+Some underlying transports allow the server's first flight of application data to reach the client at around the same time when the client sends it's first flight data. When such transport (e.g., TLS 1.3 {{I-D.ietf-tls-tls13}} in full-handshake mode) is used, a client can postpone sending the CACHE_DIGEST frame until it receives a SETTINGS_CACHE_DIGEST settings value.
+
+When the underlying transport does not have such property (e.g., TLS 1.3 in 0-RTT mode), a client can reuse the settings value found in previous connections to make assumptions.

"... found in previous connections to that origin {{RFC6454}} to make ... "?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/340#pullrequestreview-35531008

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 30 Apr 2017 20:52:03 -0700

@kazuho pushed 1 commit.

75f9150  clarify the settings of the connections that can be reused

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/340/files/0ac82a58c13a1c60f612d1bb49ff0f436b58f241..75f915082fe3d1571d3c8c642938907cfde44f7d

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 30 Apr 2017 20:52:57 -0700

kazuho commented on this pull request.

Thank you for the suggestion. Applied in the commit below. That makes the sentence clearer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/340#discussion_r114096499