Subject: Re: [httpwg/http-extensions] Incomplete responses and immutable (#325)

From: HTTP issue updates <[email-masked]>
Date: Wed, 12 Apr 2017 19:28:12 -0700

so firefox calls this "strongly vs weakly framed".

Hitting reload, which normally does conditional revals, doesn't really help with weakly framed things because you just revalidate the etag or LM in the header.. and in the case of truncation (the common fail mode) the header is not what's wrong.

so if you're weakly framed we don't do conditional revals at all - we just load unconditionally (the same as if you did a hard reload) because its not really trustworthy.

none of this is really an immutable specific issue though. immutable never bypasses 'hard reloads' and that's the only thing that's going to work here..

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-293759587

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 12 Apr 2017 21:05:14 -0700

I was wondering if weakly framed content should be unconditionally be requested on a "normal" load, even despite the presence of immutable. 

See also https://github.com/whatwg/fetch/issues/524

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-293774197

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 13 Apr 2017 04:58:19 -0700

you mean in normal reloads not normal loads, right? (the latter would just mean no-store I think.)

and yes, that's what I believe we do.. and it isn't related to the presence of immutable. (Though I admit I think I put it in at the same time as working on immutable because these questions came up.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-293871545

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 13 Apr 2017 05:02:47 -0700

a large component of weakly framed responses are actually buggy responses that we tolerate due to server errors.. e.g. chunked without a 0 chunk or stuff that is short of its content-length

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-293873191

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 18 Apr 2017 19:02:26 -0700

The current draft says:

    Clients SHOULD NOT issue a conditional request during the response’s freshness lifetime (e.g. upon a reload) unless explicitly overridden by the user (e.g. a force reload).

What about amending it to:

    Clients SHOULD NOT issue a conditional request during the response’s freshness lifetime (e.g. upon a reload) unless explicitly overridden by the user (e.g. a force reload), or when the stored response is potentially corrupted (e.g., lacks strong framing).

?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/325#issuecomment-295040975