Subject: [hackathon] network and power requests

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 6 Jun 2019 23:32:36 +0000

Hackathoners,

We are trying something new this time. Champions of projects who have special requests in terms of the network and/or power can now make those requests known by adding them to the hackathon wiki. Please note the new section in the wiki that looks as follows:

---

Network and Power

  *   Network
     *   Wireless access to the IETF network will be provided, and from there to the outside world
     *   The IETF network will be dual stack with both IPv6 and IPv4
     *   Wired access to the IETF network is available by request only
     *   For wired access, static IP addresses, or any other special network requests, please add your name, email address, and details of your request in the Requests section below.
  *   Power
     *   There will be two power strips per table (roughly one outlet per person/seat). If you need additional power for your project/team, please add your name, email address, and details of your request in the Requests section below.
  *   Requests
     *   <your name>, <your email address>, <your network and/or power request>

---

The sooner you make your request known, the better the odds of us accommodating it. Equipment ships the end of June, so submitting your request before then if at all possible.

Also, please be sure to register for the hackathon asap. This will help with space planning, t-shirt ordering, etc.

Cheers,

Charles

---

From: Michael Richardson <[email-masked]>
Date: Fri, 07 Jun 2019 15:01:54 -0400

> *   Wired access to the IETF network is available by request only

With DHCPv6PD?

---

From: <[email-masked]>
Date: Fri, 7 Jun 2019 15:32:26 -0400

A user's machine can just use DHCPv6 client to acquire an IPv6 address.  

Why do we need DHCPv6 PD? Is anyone bringing a home router which would need
a DHCPv6 PD.  Anyone writing a home router in P4 at the hackathon?

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of Michael Richardson
Sent: Friday, June 07, 2019 3:02 PM
To: Charles Eckel (eckelcu) <[email-masked]>
Cc: [email-masked]
Subject: Re: [hackathon] network and power requests

With DHCPv6PD?

_______________________________________________
hackathon mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hackathon

---

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2019 16:01:35 -0400

> a DHCPv6 PD.  Anyone writing a home router in P4 at the hackathon?

Yes, we’d like to be able to plug home routers into a router at our hackathon table as if they were customer edge routers and get a routable prefix using DHCPv6 PD.

---

From: <[email-masked]>
Date: Fri, 7 Jun 2019 16:07:04 -0400

Got it, Ted  thanks.   So, now it depends if the router and its software deployed at the hackathon supports DHCPv6 PD.  

Good to hear from you after a long while.  

Hemant

From: hackathon <[email-masked]> On Behalf Of Ted Lemon
Sent: Friday, June 07, 2019 4:02 PM
To: [email-masked]
Cc: [email-masked]; Michael Richardson <[email-masked]>; Charles Eckel (eckelcu) <[email-masked]>
Subject: Re: [hackathon] network and power requests

On Jun 7, 2019, at 3:32 PM, <[email-masked] <mailto:[email-masked]> > <[email-masked] <mailto:[email-masked]> > wrote:

---

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2019 16:09:18 -0400

> Good to hear from you after a long while. 

Oh cool!   I was wondering if it was you!   Yes, these routers will need to support DHCPv6 PD.   :)

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 8 Jun 2019 00:26:57 +0000

We did it 2 or 3 hackathons ago to test with subnets and using PvD announced in RA. It worked like a charm

-éric

From: hackathon <[email-masked]> on behalf of Ted Lemon <[email-masked]>
Date: Friday, 7 June 2019 at 13:02
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Michael Richardson <[email-masked]>, "Charles Eckel (eckelcu)" <[email-masked]>
Subject: Re: [hackathon] network and power requests

On Jun 7, 2019, at 3:32 PM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:
Why do we need DHCPv6 PD? Is anyone bringing a home router which would need
a DHCPv6 PD.  Anyone writing a home router in P4 at the hackathon?