Subject: Re: [hackathon] Sponsor for the hackathon?

From: <[email-masked]>
Date: Mon, 10 Jun 2019 13:30:18 -0400

I could not find a wiki for the hackathon.  I wanted to enter one thought for what I’d do on Saturday of the hackathon.  I cannot make it for Sunday.  Anyway, here is my thought via email.

Change Linux networking stack to filter IPv6 traffic on a new link-local multicast address, e.g., FF02:0:0:0:0:0:1:8.  I will make the address configurable.  Time permitting, I will change FreeBSD as well.  The work support this draft: 

https://tools.ietf.org/html/draft-hsingh-ipv6-coin-ml-02 

Later, I can send the code out for review to the respective communities.  This way, the switch ML algorithms can move to IPv6 using Linux hosts.  The latest version of the above draft now includes a formal technical report research paper on switch ML.

Best,

Hemant

From: hackathon <[email-masked]> On Behalf Of Charles Eckel (eckelcu)
Sent: Monday, June 03, 2019 4:29 PM
To: Marie-Jose Montpetit <[email-masked]>; [email-masked]
Subject: Re: [hackathon] Sponsor for the hackaton?

Hi Marie-Jose,

Thanks for championing this project at the hackathon. It is great to have Noviflow involved and helping in this way. We will work with you offline to determine how best to proceed with recognizing them.

Cheers,

Charles

From: hackathon <[email-masked] <mailto:[email-masked]> > on behalf of Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]> >
Date: Thursday, May 30, 2019 at 5:06 PM
To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: [hackathon] Sponsor for the hackaton?

Hi: 

I am the champion behind the P4 hackaton. We have had a lot of support but in particular from a local Montreal company called “Noviflow” who are getting us licenses for tools and will send some of  their programmers to help us. So in fact they are “sponsoring” our hackaton. Would there be a way to thank them on the site? Actually this is going multi-way: as a IRTF co-chair and long time IETF collaborator as well as a Montreal native, I am trying to get more participation from Montreal-based companies and academic institutions in IETF/IRTF and Noviflow is frankly my first success story :) 

Let me know…

Marie-Jose Montpetit, Ph.D.

Research Affiliate, MIT Media Laboratory

Co-chair NWCRG and COINRG

[email-masked] <mailto:[email-masked]> 

[email-masked] <mailto:[email-masked]> 

+1-781-526-2661

@SocialTVMIT

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 10 Jun 2019 13:33:41 -0400

I will upload the material to the coin wiki. I have a deadline for Thursday
so please be patient :)

On Mon, Jun 10, 2019, 1:30 PM <[email-masked]> wrote:

> I could not find a wiki for the hackathon.  I wanted to enter one thought
> for what I’d do on Saturday of the hackathon.  I cannot make it for
> Sunday.  Anyway, here is my thought via email.
>
>
>
> Change Linux networking stack to filter IPv6 traffic on a new link-local
> multicast address, e.g., FF02:0:0:0:0:0:1:8.  I will make the address
> configurable.  Time permitting, I will change FreeBSD as well.  The work
> support this draft:
>
>
>
> Later, I can send the code out for review to the respective communities.
> This way, the switch ML algorithms can move to IPv6 using Linux hosts.  The
> latest version of the above draft now includes a formal technical report
> research paper on switch ML.
>
>
>
> Best,
>
>
>
> Hemant
>
>
>
> *From:* hackathon <[email-masked]> *On Behalf Of *Charles
> Eckel (eckelcu)
> *Sent:* Monday, June 03, 2019 4:29 PM
> *To:* Marie-Jose Montpetit <[email-masked]>; [email-masked]
> *Subject:* Re: [hackathon] Sponsor for the hackaton?
>
>
>
> Hi Marie-Jose,
>
>
>
> Thanks for championing this project at the hackathon. It is great to have
> Noviflow involved and helping in this way. We will work with you offline to
> determine how best to proceed with recognizing them.
>
>
>
> Cheers,
>
> Charles
>
>
>
> *From: *hackathon <[email-masked]> on behalf of Marie-Jose
> Montpetit <[email-masked]>
> *Date: *Thursday, May 30, 2019 at 5:06 PM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[hackathon] Sponsor for the hackaton?
>
>
>
> Hi:
>
>
>
> I am the champion behind the P4 hackaton. We have had a lot of support but
> in particular from a local Montreal company called “Noviflow” who are
> getting us licenses for tools and will send some of  their programmers to
> help us. So in fact they are “sponsoring” our hackaton. Would there be a
> way to thank them on the site? Actually this is going multi-way: as a IRTF
> co-chair and long time IETF collaborator as well as a Montreal native, I am
> trying to get more participation from Montreal-based companies and academic
> institutions in IETF/IRTF and Noviflow is frankly my first success story :)
>
>
>
> Let me know…
>
>
>
>
>
> [email-masked]
> [email-masked]

---

From: <[email-masked]>
Date: Mon, 10 Jun 2019 13:38:46 -0400

Note, the code changes in the email below are in C so that switch ML has hosts with IPv6 and switch ML support. 

For P4,  I will write p4-16 code for switch ML to send a IPv6 link-local multicast message with configurable payload.

Hemant 

From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, June 10, 2019 1:30 PM
To: 'Charles Eckel (eckelcu)' <[email-masked]>; 'Marie-Jose Montpetit' <[email-masked]>; [email-masked]
Subject: Re: [hackathon] Sponsor for the hackathon?

Change Linux networking stack to filter IPv6 traffic on a new link-local multicast address, e.g., FF02:0:0:0:0:0:1:8.  I will make the address configurable.  Time permitting, I will change FreeBSD as well.  The work supports this draft: 

Best,

Hemant

From: hackathon <[email-masked] <mailto:[email-masked]> > On Behalf Of Charles Eckel (eckelcu)
Sent: Monday, June 03, 2019 4:29 PM
To: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [hackathon] Sponsor for the hackaton?

Hi Marie-Jose,

Cheers,

Charles

Hi: 

Let me know…

+1-781-526-2661

@SocialTVMIT

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 10 Jun 2019 17:43:23 +0000

Here is the main hackathon info page:
https://www.ietf.org/how/runningcode/hackathons/105-hackathon/

It includes important info and links for the hackathon, including a link to the wiki.
https://trac.ietf.org/trac/ietf/meeting/wiki/105hackathon

A link to the code, in GitHub or elsewhere, would be a good thing to include in your description.
If you don’t already have a location for the code, I’d be happy to create a repo for you here:
https://github.com/ietf-hackathon

Cheers,
Charles

From: hackathon <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Organization: MNK Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Monday, June 10, 2019 at 10:40 AM
To: "[email-masked]" <[email-masked]>, 'Marie-Jose Montpetit' <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [hackathon] Sponsor for the hackathon?

Hemant

Best,

Hemant

From: hackathon <[email-masked]<mailto:[email-masked]>> On Behalf Of Charles Eckel (eckelcu)
Sent: Monday, June 03, 2019 4:29 PM
To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [hackathon] Sponsor for the hackaton?

Hi Marie-Jose,

Cheers,
Charles

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 30, 2019 at 5:06 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] Sponsor for the hackaton?

Hi:

Let me know…

Marie-Jose Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
Co-chair NWCRG and COINRG
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

---

From: <[email-masked]>
Date: Mon, 10 Jun 2019 14:39:18 -0400

Charles,

Thanks.  

I added my project.  Please search for “IPv6 Switch ML”.  I have been careful to show what P4 code I am writing vs. not.  Since my plan is to change Linux IPv6 stack, this is C code to change.   

Cheers,

Hemant

From: hackathon <[email-masked]> On Behalf Of Charles Eckel (eckelcu)
Sent: Monday, June 10, 2019 1:43 PM
To: [email-masked]; 'Marie-Jose Montpetit' <[email-masked]>; [email-masked]
Subject: Re: [hackathon] Sponsor for the hackathon?

Cheers,

Charles

From: hackathon <[email-masked] <mailto:[email-masked]> > on behalf of "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Organization: MNK Consulting
Reply-To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Date: Monday, June 10, 2019 at 10:40 AM
To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, 'Marie-Jose Montpetit' <[email-masked] <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Subject: Re: [hackathon] Sponsor for the hackathon?

Hemant 

From: hackathon <[email-masked] <mailto:[email-masked]> > On Behalf Of [email-masked] <mailto:[email-masked]> 
Sent: Monday, June 10, 2019 1:30 PM
To: 'Charles Eckel (eckelcu)' <[email-masked] <mailto:[email-masked]> >; 'Marie-Jose Montpetit' <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [hackathon] Sponsor for the hackathon?

Best,

Hemant

From: hackathon <[email-masked] <mailto:[email-masked]> > On Behalf Of Charles Eckel (eckelcu)
Sent: Monday, June 03, 2019 4:29 PM
To: Marie-Jose Montpetit <[email-masked]>; [email-masked] <mailto:[email-masked]> 
Subject: Re: [hackathon] Sponsor for the hackaton?

Hi Marie-Jose,

Cheers,

Charles

Hi: 

Let me know…

+1-781-526-2661

@SocialTVMIT

---

From: <[email-masked]>
Date: Wed, 12 Jun 2019 08:28:38 -0400

Since I am attending the hackathon remotely, and only for one day (Saturday), I started early to get the project going.  

I completed Linux user-space code to have a host join a new IPv6 link-local multicast address.  Hosts being used in the switch ML paper can use this code for IPv6 switch ML.   See https://github.com/hesingh/linux-user-space-ipv6-mcast

Next, I am looking into the Linux kernel so that a network interface joins a new well-known IPv6 link-local multicast address on interface initialization.   After the kernel work, the Linux host software would be complete.  Hosts can use either user-space software or kernel software.  Thereafter, I will move to writing P4 code for the switch to send ML updates to the IPv6 hosts.  

Since Charles Eckel is at Cisco Live, I will get my github user account added to the IETF github hackathon repo later.  My goal is to first complete the code in any public repo.

Cheers,

Hemant

Cheers,

Charles

Hemant 

Best,

Hemant

Hi Marie-Jose,

Cheers,

Charles

Hi: 

Let me know…

+1-781-526-2661

@SocialTVMIT

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 12 Jun 2019 08:29:57 -0400

Great!

> On Jun 12, 2019, at 8:28 AM, <[email-masked]> <[email-masked]> wrote:
> 
> I completed Linux user-space code to have a host join a new IPv6 link-local multicast address.  Hosts being used in the switch ML paper can use this code for IPv6 switch ML.   See https://github.com/hesingh/linux-user-space-ipv6-mcast <https://github.com/hesingh/linux-user-space-ipv6-mcast>
>  
> From: hackathon <[email-masked] <mailto:[email-masked]>> On Behalf Of Charles Eckel (eckelcu)
> To: [email-masked] <mailto:[email-masked]>; 'Marie-Jose Montpetit' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/how/runningcode/hackathons/105-hackathon/ <https://www.ietf.org/how/runningcode/hackathons/105-hackathon/>
>  
> https://trac.ietf.org/trac/ietf/meeting/wiki/105hackathon <https://trac.ietf.org/trac/ietf/meeting/wiki/105hackathon>
>  
> https://github.com/ietf-hackathon <https://github.com/ietf-hackathon>
>  
> Cheers,
> Charles
>  
> From: hackathon <[email-masked] <mailto:[email-masked]>> on behalf of "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Reply-To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, 'Marie-Jose Montpetit' <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> From: hackathon <[email-masked] <mailto:[email-masked]>> On Behalf Of [email-masked] <mailto:[email-masked]>
> To: 'Charles Eckel (eckelcu)' <[email-masked] <mailto:[email-masked]>>; 'Marie-Jose Montpetit' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> https://tools.ietf.org/html/draft-hsingh-ipv6-coin-ml-02 <https://tools.ietf.org/html/draft-hsingh-ipv6-coin-ml-02>
>  
> From: hackathon <[email-masked] <mailto:[email-masked]>> On Behalf Of Charles Eckel (eckelcu)
> To: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> From: hackathon <[email-masked] <mailto:[email-masked]>> on behalf of Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>

---

From: <[email-masked]>
Date: Wed, 12 Jun 2019 16:16:24 -0400

Regarding Linux kernel work, I realized it’s not needed.  ML is an application protocol which should only configure a multicast address to join from the Linux user space.  Only IPv6 ND and SLAAC (RFC 4861 and RFC 4862), during interface initialization, join the all-nodes and solicited-node multicast addresses in the Linux kernel. 

Hemant

From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, June 12, 2019 8:29 AM
To: 'Charles Eckel (eckelcu)' <[email-masked]>; 'Marie-Jose Montpetit' <[email-masked]>; [email-masked]
Subject: Re: [hackathon] Sponsor for the hackathon?

---

From: <[email-masked]>
Date: Wed, 12 Jun 2019 16:21:40 -0400

The P4 code for IPv6 switch ML for https://datatracker.ietf.org/doc/draft-hsingh-ipv6-coin-ml/ is also complete and checked into the repo below.

https://github.com/hesingh/p4-ipv6-switch-ml

This is p4-16 code that supports switch ML using a well-known IPv6 link-local multicast address to send ML updates to all hosts.  Now, the authors of the switch ML paper can use this code to add their switch ML logic and make the whole switch ML work for IPv6 on the Tofino asic.  I have tested the code using p4c (P4 compiler) STF packets.  STS is described on slide 136 of https://github.com/p4lang/p4c/blob/master/docs/compiler-design.pptx

This is all the code I had to write on the day of the hackathon.  I will use the day for working with any author of the switch ML IPv4 implementation to shoe-horn more code into the public-domain repo.  

Hemant

Cheers,

Charles

Hemant 

Best,

Hemant

Hi Marie-Jose,

Cheers,

Charles

Hi: 

Let me know…

+1-781-526-2661

@SocialTVMIT