Subject: [hackathon] LPWAN CoAP/UDP/IPv6 compression at IETF102

From: <[email-masked]>
Date: Sat, 7 Jul 2018 06:11:53 +0000

Dear all,

At the coming hackathon, we'll carry on with our effort to provide an open-source reference code for the CoAP/UDP/IPv6 compression and fragmentation (see the specs at ​https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-context-hc/ and ​https://datatracker.ietf.org/doc/draft-ietf-lpwan-coap-static-context-hc/)

More specifically, at this Hackathon, the goal is to integrate the compression and fragmentation codes which are currently separate: ​https://github.com/ltn22/SCHC and ​https://github.com/tanupoo/schc-test

We will live LoRaWAN connectivity (Sigfox is TBC).
If you feel interested, please join us!
Newcomers are always welcome. We will have a few spare Pycom boards (​https://pycom.io/), we'll set you up so that you can get started with the technology and the code base.
Best regards

Dominique

https://trac.ietf.org/trac/ietf/meeting/wiki/102hackathon

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Ludwig Seitz <[email-masked]>
Date: Thu, 12 Jul 2018 09:00:09 +0200

On 2018-07-07 08:11, [email-masked] wrote:
> Dear all,
> 
> At the coming hackathon, we'll carry on with our effort to provide an 
> open-source reference code for the CoAP/UDP/IPv6 compression and 
> fragmentation (see the specs at ​ 
> https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-context-hc/ and 
> ​https://datatracker.ietf.org/doc/draft-ietf-lpwan-coap-static-context-hc/)
> 
> More specifically, at this Hackathon, the goal is to integrate the 
> compression and fragmentation codes which are currently separate: ​ 
> https://github.com/ltn22/SCHC and ​https://github.com/tanupoo/schc-test
> 
> Newcomers are always welcome. We will have a few spare Pycom boards (​ 
> https://pycom.io/), we'll set you up so that you can get started with 
> the technology and the code base.
> Best regards
> 
> Dominique
> 

I'm championing another hackathon event so I will probably not be able 
to join you, but I'm very interested in any efforts to transport CoAP 
over LoRa. Are you perchance looking into this?

/Ludwig

-- 
Ludwig Seitz, PhD
Security Lab, RISE SICS
Phone +46(0)70-349 92 51