Subject: [hackathon] Codestand

From: Christian O'Flaherty <[email-masked]>
Date: Tue, 18 Jul 2017 11:51:09 +0200

Dear Hackathon participants,

It will be valuable to capture the great work you’ve done and the relationship with IETF documents. We’re encouraging the use of CODESTAND for that.

It’s simple (or should be) to add your project to the tool: codestand.ietf.org <http://www.codestand.ietf.org/> 

Login using your Datatracker credentials (or register if you don’t have one already)

Select Projects -> New Project (at the bottom) 

The tool is in beta state (based on Datatracker but not fully integrated yet). Please let us know if there’s any problem or suggestion you may have as we’re trying to fix bugs and include all the required features before the integration.  

Feel free to contact me. I’ll be happy to meet and get your feedback

Thank you!

Christian O’Flaherty - [email-masked]
Regional Development - Internet Society
Skype/Gmail/++: christian.oflaherty
Mobile/WhatsApp: +598 98769636

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 19 Jul 2017 08:20:14 +0200

On Tue, Jul 18, 2017 at 11:51:09AM +0200,
 Christian O'Flaherty <[email-masked]> wrote 
 a message of 115 lines which said:

> It’s simple (or should be) to add your project to the tool:
> codestand.ietf.org <http://www.codestand.ietf.org/>

Actually <https://codestand.ietf.org/>. www.codestand.ietf.org does
not exist.

> Select Projects -> New Project (at the bottom) 

It crashed:

ValueError at /codestand/matches/new/

"<ProjectContainer: dnstap to C-DNS>" needs to have a value for field "projectcontainer" before this many-to-many relationship can be used.

Request Method: 	POST
Request URL: 	https://codestand.ietf.org/codestand/matches/new/
Django Version: 	1.10.7
Exception Type: 	ValueError
Exception Value: 	

"<ProjectContainer: dnstap to C-DNS>" needs to have a value for field "projectcontainer" before this many-to-many relationship can be used.

Exception Location: 	/usr/local/lib/python2.7/dist-packages/django/db/models/fields/related_descriptors.py in __init__, line 783
Python Executable: 	/usr/bin/python
Python Version: 	2.7.6
Python Path: 	

['/var/www/codestand',
 '/usr/lib/python2.7',
 '/usr/lib/python2.7/plat-x86_64-linux-gnu',
 '/usr/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/lib-old',
 '/usr/lib/python2.7/lib-dynload',
 '/usr/local/lib/python2.7/dist-packages',
 '/usr/lib/python2.7/dist-packages',
 '/usr/lib/python2.7/dist-packages/PILcompat',
 '/var/www/codestand']

Server time: 	Tue, 18 Jul 2017 23:15:36 -0700

I also tried without the spaces in the name, and in all lowercase. Same result.

Also:

* "Coding title" is quite lmysterious. What is it supposed to store?

* Contact type: two decentralized protocols (email and XMPP), two
centralized silos. Why not adding things like Mastodon
<https://joinmastodon.org/>?

---

From: Christian O'Flaherty <[email-masked]>
Date: Wed, 19 Jul 2017 07:53:12 +0000

Hi Stephane,

> On Jul 19, 2017, at 8:27 AM, Stephane Bortzmeyer <[email-masked]> wrote:
> 

The www was probably assumed by my 'smart' email client :-)

>> Select Projects -> New Project (at the bottom)

Thanks! We need to catch those cases. 

 I'll try to reproduce it using the same name but I will need your help if I can't. 

> I also tried without the spaces in the name, and in all lowercase. Same result.

Spaces and many other characters are allowed. I'll check

> * "Coding title" is quite lmysterious. What is it supposed to store?

This is the name of your project in github or wherever it is. 

> <https://joinmastodon.org/>?

I didn't know about Mastodon. I'm going to check it now

Christian