Subject: [hackathon] SCHC testing

From: Laurent Toutain <[email-masked]>
Date: Thu, 22 Jun 2017 20:10:52 +0200

Hi,

The LPWAN compression mechanism SCHC defined in
draft-ietf-lpwan-ipv6-static-context-hc is mature and at least 3
implementations already exist. During the next Hackathon in Prague, a
LoRaWAN and a Sigfox network will be available to perform test of SCHC with
several objectives:

-       allow developers to understand SCHC behavior and implement their
own version of the mechanism

-       test interoperability between the existing implementations

-       define compression and fragmentation rules related to specific
traffic

Come with your own devices or use the pycom devices we will bring to
participate to the real Internet of Things. To participate you need to
register as quickly as possible on
http://ietf.org/hackathon/99-hackathon.html

We will provide more technical details on the coming days.

Laurent

---

From: "weigengyu" <[email-masked]>
Date: Fri, 23 Jun 2017 14:14:44 +0800

Hi all,

The doc is just a draft. 

> The LPWAN compression mechanism SCHC defined in draft-ietf-lpwan-ipv6-static-context-hc is mature 
>From a technical view point, it is not a mature because it can be optimize apparently.

Regards, 

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Laurent Toutain 
Sent: Friday, June 23, 2017 2:10 AM
To: lp-wan ; [email-masked] 
Subject: [lp-wan] SCHC testing

Hi,

The LPWAN compression mechanism SCHC defined in draft-ietf-lpwan-ipv6-static-context-hc is mature and at least 3 implementations already exist. During the next Hackathon in Prague, a LoRaWAN and a Sigfox network will be available to perform test of SCHC with several objectives:

-       allow developers to understand SCHC behavior and implement their own version of the mechanism

-       define compression and fragmentation rules related to specific traffic

Come with your own devices or use the pycom devices we will bring to participate to the real Internet of Things. To participate you need to register as quickly as possible on http://ietf.org/hackathon/99-hackathon.html 

Laurent

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 26 Jun 2017 08:32:34 +0000

Hello Gengyu

I thing that by ”mature” Laurent meant “stable”. And I agree it is stable. It works. We are now getting ready for last call. I agree that real maturity will come with deployment experience.

Cheers;

Pascal
From: lp-wan [mailto:[email-masked]] On Behalf Of weigengyu
Sent: vendredi 23 juin 2017 08:15
To: Laurent Toutain <[email-masked]>; lp-wan <[email-masked]>; [email-masked]
Subject: Re: [lp-wan] SCHC testing

Hi all,
The doc is just a draft.

Regards,

Gengyu WEI

From: Laurent Toutain<mailto:[email-masked]>
Sent: Friday, June 23, 2017 2:10 AM
To: lp-wan<mailto:[email-masked]> ; [email-masked]<mailto:[email-masked]>
Subject: [lp-wan] SCHC testing

Hi,

Laurent
________________________________
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan