Subject: [hackathon] Looking for something to work on for IETF 98

From: Kyle Larose <[email-masked]>
Date: Mon, 13 Feb 2017 20:51:57 +0000

Hello fellow hackathon attendees,

I'm looking for something to work on this hackathon. Charles recently sent out an email indicating that we didn't have enough technologies and champions, so ideally I could champion something.

I was thinking of doing something related to dots (maybe try to implement the signal channel between a hacky client and server).

I'd also like to do something related to capport, but there doesn't seem to be much activity on the wg (no documents, little in the mailing list) to work from. Dave Dolson suggested working on this: https://tools.ietf.org/html/draft-wkumari-capport-icmp-unreach-01. It has expired, but oh well. :) Maybe I could breathe some life into it.

Anyway, I figured I'd ask here to gauge interest from other attendees with respect to these technologies. Would anyone else feel like working on them?

I'll probably head over to the mailing lists for those two WGs to see if anyone on them has ideas, but I'd welcome any feedback here as well.

Thanks,

Kyle

---

From: Barry Leiba <[email-masked]>
Date: Mon, 13 Feb 2017 16:03:28 -0500

> I was thinking of doing something related to dots (maybe try to implement
> the signal channel between a hacky client and server).
>
> I’d also like to do something related to capport, but there doesn’t seem to
> be much activity on the wg (no documents, little in the mailing list) to
> work from. Dave Dolson suggested working on this:
> https://tools.ietf.org/html/draft-wkumari-capport-icmp-unreach-01. It has
> expired, but oh well. J Maybe I could breathe some life into it.
...
> I’ll probably head over to the mailing lists for those two WGs to see if
> anyone on them has ideas, but I’d welcome any feedback here as well.

Asking on the mailing lists is the best approach to get started, but
comments from me as Hackathon co-chair and former ART AD:  I'd *love*
to see Hackathon work on the captive portal stuff, for a couple of
reasons.  I'd like to get some proof-of-concept work out there, and
I'd like to use that to push more interest and energy into the working
group.  With captive portals, we have an unfortunate mix of (1) work
that really ought to happen and that would be very useful to Internet
users who travel/roam, and (2) real questions about whether anything
that we built would actually wind up in use and providing the benefits
that we hope for.

(Also, in addition to the draft you mention, there's also RFC 7710 to
play with.)

And DOTS is also a great opportunity, getting some early
implementations done and encouraging people to make sure that the
information sharing works.

So... please!  I know the chairs of both of these WGs will help you
beat the bushes (get to Warren quickly, before be becomes immersed in
AD-land!).  And let us know what happens.

And it wouldn't hurt to put placeholders into the Hackathon wiki while
you see what you can drum up.

Barry