Subject: [hackathon] IETF 97 Hackathon Summary

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 15 Nov 2016 03:26:51 +0000

Thanks to all of you who joined us this weekend in making the hackathon at IETF 97 a big success. We had 117 registered participants<https://www.ietf.org/registration/ietf97/hackathonattendance.py?sortkey=3&login=%0A> working on roughly 15 different projects<https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon>. Among these were many first time IETFers and even more first time IETF hackathoners. Local and remote universities had a strong representation both in terms of number of participants as well as in terms of contributions.

Teams produced and delivered summary presentations of their work, including feedback for working groups responsible for drafts and protocols relevant to their projects. The presentations are available here:

https://datatracker.ietf.org/meeting/97/session/hackathon/

A recording of the project presentations and awards is available here: (watch video<http://recs.conf.meetecho.com/ietf97/recs/Hackathon-ProjectsPresentation.webm> or go HTML5<http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF97_HACKATHON_II&chapter=chapter_2>)

The winning teams are as follows:

- Best Overall - MPTCP team

    - Transport Area

    -  Champion(s)

        - Benjamin Hesmans [email-masked]

- Best Input to a Working Group - ACTN team

    - Routing Area

    - Champion(s)

        - Dhruv Dhody [email-masked]

        - Haomian Zheng [email-masked]

- Best Group Work - I2NSF team

    - Security Area

    - Champion(s)

        - Jaehoon Paul Jeong [email-masked]

        - Jinyong Tim Kim [email-masked]

        - Jung-Soo Park [email-masked]

        - Tae-Jin Ahn [email-masked]

- Best New Work to IETF - Service Function DevKit team and SFC team

    - Routing Area

    - Service Function Dev Kit Champion(s)

        - David Dolson [email-masked]

        - Kyle Larose [email-masked]

    - SFC Champion(s)

        - Vu Anh Vu [email-masked]<mailto:[email-masked]>

Please join us at Bit-n-Bites Thursday evening where you can see demos and discuss results and findings with members of the following teams:

- Service Function Dev Kit

- I2NSF

- SFC

- DNS

More information and useful links for the IETF 97 hackathon can be found here: https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon

Please start making your plans to join us for the IETF 98 hackathon in Chicago, March 25-26, 2017.

Cheers,

Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 18 Nov 2016 01:44:27 +0000

Here is a blogpost that includes the info below plus some addition background, stats, and photos. We are still waiting for all the photos from the photographer to be uploaded, so I made due with what we have so far. My apologies for not having photos from all the winning teams. I used your posters in their place.

https://communities.cisco.com/community/developer/opensource/blog/2016/11/17/ietf-97-hackathon-improving-open-standards-through-open-source

I generally submit a version of this for the IETF journal as well. If anyone else has a hackathon or open source/running code story they would like to have published in the IETF journal, let me know and I can hook you up ☺

Congrats and thanks to those who showed off their projects at Bit-n-Bites last night. The hackathon tables saw good traction. Your efforts and positive impact on bringing running code back into the IETF are clearly evident and appreciated.

Cheers,
Charles

From: Charles Eckel <[email-masked]>
Date: Tuesday, November 15, 2016 at 12:26 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: IETF 97 Hackathon Summary

    - Transport Area

    -  Champion(s)

    - Routing Area

    - Champion(s)

    - Security Area

    - Champion(s)

    - Routing Area

    - SFC Champion(s)

- I2NSF

- SFC

- DNS

Cheers,

Charles

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 18 Nov 2016 10:52:40 +0900

Hi Charles,

Thanks for making sure that Hackathon had a big table at Bits n Bytes, so
that multiple projects could be showcased.
Thanks for everything that you do for Hackathon!

Dhruv

On Fri, Nov 18, 2016 at 10:44 AM, Charles Eckel (eckelcu) <[email-masked]
> wrote:

> Here is a blogpost that includes the info below plus some addition
> background, stats, and photos. We are still waiting for all the photos from
> the photographer to be uploaded, so I made due with what we have so far. My
> apologies for not having photos from all the winning teams. I used your
> posters in their place.
>
>
>
> https://communities.cisco.com/community/developer/
> opensource/blog/2016/11/17/ietf-97-hackathon-improving-
> open-standards-through-open-source
>
>
>
> I generally submit a version of this for the IETF journal as well. If
> anyone else has a hackathon or open source/running code story they would
> like to have published in the IETF journal, let me know and I can hook you
> up J
>
>
>
> Congrats and thanks to those who showed off their projects at Bit-n-Bites
> last night. The hackathon tables saw good traction. Your efforts and
> positive impact on bringing running code back into the IETF are clearly
> evident and appreciated.
>
>
>
> Cheers,
>
> Charles
>
>
>
> *From: *Charles Eckel <[email-masked]>
> *Date: *Tuesday, November 15, 2016 at 12:26 PM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *IETF 97 Hackathon Summary
>
>
>
> Thanks to all of you who joined us this weekend in making the hackathon at
> IETF 97 a big success. We had 117 registered participants
> <https://www.ietf.org/registration/ietf97/hackathonattendance.py?sortkey=3&login=%0A>
> working on roughly 15 different projects
> <https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon>. Among
> these were many first time IETFers and even more first time IETF
> hackathoners. Local and remote universities had a strong representation
> both in terms of number of participants as well as in terms of
> contributions.
>
>
>
> Teams produced and delivered summary presentations of their work,
> including feedback for working groups responsible for drafts and protocols
> relevant to their projects. The presentations are available here:
>
> A recording of the project presentations and awards is available here:
> (watch video
> <http://recs.conf.meetecho.com/ietf97/recs/Hackathon-ProjectsPresentation.webm>
> or go HTML5
> <http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF97_HACKATHON_II&chapter=chapter_2>
> )
>
>
>
>         - Vu Anh Vu [email-masked]
>
>
>
> Please join us at Bit-n-Bites Thursday evening where you can see demos and
> discuss results and findings with members of the following teams:
>
> More information and useful links for the IETF 97 hackathon can be found
> here: https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon
>
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 17 Nov 2016 20:53:17 -0500

+1  - Charles – thank you for your leadership of the Hackathon!  

Sue 

From: hackathon [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Thursday, November 17, 2016 8:53 PM
To: Charles Eckel (eckelcu)
Cc: [email-masked]
Subject: Re: [hackathon] IETF 97 Hackathon Summary

Hi Charles, 

Thanks for making sure that Hackathon had a big table at Bits n Bytes, so that multiple projects could be showcased. 

Dhruv

On Fri, Nov 18, 2016 at 10:44 AM, Charles Eckel (eckelcu) <[email-masked]> wrote:

I generally submit a version of this for the IETF journal as well. If anyone else has a hackathon or open source/running code story they would like to have published in the IETF journal, let me know and I can hook you up J

Cheers,

Charles

Thanks to all of you who joined us this weekend in making the hackathon at IETF 97 a big success. We had 117 registered participants <https://www.ietf.org/registration/ietf97/hackathonattendance.py?sortkey=3&login=%0A>  working on roughly 15 different projects <https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon> . Among these were many first time IETFers and even more first time IETF hackathoners. Local and remote universities had a strong representation both in terms of number of participants as well as in terms of contributions. 

A recording of the project presentations and awards is available here: (watch video <http://recs.conf.meetecho.com/ietf97/recs/Hackathon-ProjectsPresentation.webm>  or go HTML5 <http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF97_HACKATHON_II&chapter=chapter_2> )

    - Transport Area

    -  Champion(s)

    - Routing Area

    - Champion(s)

    - Security Area

    - Champion(s)

    - Routing Area

    - SFC Champion(s)

- I2NSF

- SFC

- DNS

Cheers,

Charles

---

From: 闫伯元 <[email-masked]>
Date: Fri, 18 Nov 2016 11:21:22 +0900

^2 Charles, Thanks a lot!!!

发自我的 iPhone

> 在 2016年11月18日，10:53，Susan Hares <[email-masked]> 写道：
> 
> Thanks to all of you who joined us this weekend in making the hackathon at IETF 97 a big success. We had 117 registered participants working on roughly 15 different projects. Among these were many first time IETFers and even more first time IETF hackathoners. Local and remote universities had a strong representation both in terms of number of participants as well as in terms of contributions.
> 
>  
> 
> A recording of the project presentations and awards is available here: (watch video or go HTML5)
> 
>  
>

---

From: Jari Arkko <[email-masked]>
Date: Tue, 22 Nov 2016 14:49:11 +0200

Thanks for this, Charles, and for your and Barry’s and other people’s work organising the Hackathon. And thanks for the participants! I look forward to being able to participate more in the code-writing role in the future :-)

Jari