Subject: [hackathon] pyang output formats

From: William Lupton <[email-masked]>
Date: Thu, 14 Jul 2016 18:22:17 +0100

All,

Sorry for the late notice. FYI I will be at the hackathon from Saturday afternoon and plan to work on some pyang extensions. Please see the following for a little background:
yang-edit: https://github.com/mbj4668/pyang/pull/244
html: https://github.com/mbj4668/pyang/issues/236

I’d also love to work on increasing the amount of pyang XPath validation (as far as is possible without having an instance document) but have so far put zero effort into thinking about that.

Do let me know if you are interested, and/or see you in Berlin.

Thanks,
William

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 14 Jul 2016 18:51:19 +0000

Welcome William. Definitely a case of better late than not at all.
In case you missed it, here is the recording of the prep call held last week:

Hackathon Prep Call-20160706 1403-1
Wednesday, July 6, 2016
7:03 am  |  Pacific Daylight Time (San Francisco, GMT-07:00)

Play recording<https://cisco.webex.com/ciscosales/lsr.php?RCID=9cbb9ec436b84dffa56af3d42f45d7fc> (41 min 3 sec)
Recording password: fNCj7kQd

Thanks, and see you at the hackathon.

Cheers,
Charles

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of William Lupton <[email-masked]<mailto:[email-masked]>>
Date: Thursday, July 14, 2016 at 7:22 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] pyang output formats

All,

  *   yang-edit: https://github.com/mbj4668/pyang/pull/244
  *   html: https://github.com/mbj4668/pyang/issues/236

Thanks,
William

---

From: Benoit Claise <[email-masked]>
Date: Thu, 14 Jul 2016 22:33:15 +0200

William,
> All,
>
> Sorry for the late notice. FYI I will be at the hackathon from 
> Saturday afternoon and plan to work on some pyang extensions. Please 
> see the following for a little background:
>
> I’d also love to work on increasing the amount of pyang XPath 
> validation (as far as is possible without having an instance document) 
> but have so far put zero effort into thinking about that.
And I'll be working on the confd YANG module compiler integration on my 
YANG modules reporting on www.claise.be, as confd validates xpath.
See you during the Hackathon.

Regards, Benoit
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon