Subject: Re: [hackathon] [vpp-dev] IETF 96 hackathon registration, champions/projects, and format tweaks

From: Christophe FONTAINE <[email-masked]>
Date: Thu, 30 Jun 2016 13:28:14 +0000

Hi all,

I'll will be with a colleague from Qosmos at the next IETF Hackathon in Berlin :-)
We'd like to focus on VPP/NSH : creating a NSH Proxy is one possibility among other things.

Who is interested ?

See you there,
Christophe

From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles Eckel (eckelcu)
Sent: mardi 24 mai 2016 23:43
To: Ole Troan; vpp-dev
Subject: Re: [vpp-dev] IETF 96 hackathon registration, champions/projects, and format tweaks

It would be great to have VPP in Berlin. I am running the hackathon and am happy to answer any questions and help you get started.

Cheers,
Charles

From: Ole Troan <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 23, 2016 at 7:45 AM
To: vpp-dev <[email-masked]<mailto:[email-masked]>>
Cc: Charles Eckel <[email-masked]<mailto:[email-masked]>>
Subject: Fwd: IETF 96 hackathon registration, champions/projects, and format tweaks

Anyone on the list going to the IETF in Berlin? Want to do something on VPP?

We had great fun doing SADR for VPP in Buenos Aires. Second best in show, and we attracted a few external people who only showed up to the IETF because of VPP.

This is where running code meets the IETF, so if someone has an active draft in the IETF they want to implement that would be a great fit.

This is in the middle of my summer holiday, so I might not be able to champion, but I would certainly be very supportive (while on the beach. ;-))

Best regards,
Ole

Begin forwarded message:

From: "Charles Eckel (eckelcu)" <[email-masked]<mailto:[email-masked]>>
Subject: IETF 96 hackathon registration, champions/projects, and format tweaks
Date: 20 May 2016 at 23:53:40 GMT+2
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IETF chairs <[email-masked]<mailto:[email-masked]>>

Hey Folks,

IETF 96 is rapidly approaching. As usual, the hackathon will be the weekend before, July 16-17. Check out the info page and register today:
https://www.ietf.org/hackathon/96-hackathon.html

So far, we have only two confirmed technologies represented on the wiki:
https://www.ietf.org/registration/MeetingWiki/wiki/96hackathon

Many of you have expressed interest in championing something in Berlin. Now is the time to update the wiki and inform others of your intentions. You don't need to put much, just enough to give others a reasonable idea of what you plan to do and links to where to go for more info, suggested reading, existing code, etc. Do this asap to help recruit others to join you and make their travel arrangements accordingly.

In anticipation of the largest hackathon ever, we are considering adjusting the format a bit to reduce the amount of time spent sharing project overviews at the beginning and presenting results at the end. If you have suggestions for how we can improve the hackathon, now is the time to share those thoughts as well.

Cheers,
Charles

This message and any attachments (the "message") are confidential, intended solely for the addressees. If you are not the intended recipient, please notify the sender immediately by e-mail and delete this message from your system. In this case, you are not authorized to use, copy this message and/or disclose the content to any other person. E-mails are susceptible to alteration. Neither Qosmos nor any of its subsidiaries or affiliates shall be liable for the message if altered, changed or falsified.

Ce message et toutes ses pi?ces jointes (ci-apr?s le "message")sont confidentiels et ?tablis ? l'intention exclusive de ses destinataires. Si vous avez re?u ce message par erreur, merci d'en informer imm?diatement son ?metteur par courrier ?lectronique et d'effacer ce message de votre syst?me. Dans cette hypoth?se, vous n'?tes pas autoris? ? utiliser, copier ce message et/ou en divulguer le contenu ? un tiers. Tout message ?lectronique est susceptible d'alt?ration. Qosmos et ses filiales d?clinent toute responsabilit? au titre de ce message s'il a ?t? alt?r?, d?form? ou falsifi?.

---

From: Keith Burns <[email-masked]>
Date: Fri, 01 Jul 2016 03:54:45 +0000

Is there any possibility to participate remotely?

I'm not sure if Hongjun is planning on going or if he could attend remotely
but he has been doing work on NSH Proxy in the NSH_SFC project...

On Thu, Jun 30, 2016 at 6:38 AM Christophe FONTAINE <
[email-masked]> wrote:

> Hi all,
>
>
>
> I’ll will be with a colleague from Qosmos at the next IETF Hackathon in
> Berlin :-)
>
> We’d like to focus on VPP/NSH : creating a NSH Proxy is one possibility
> among other things.
>
>
>
> Who is interested ?
>
>
>
> See you there,
>
> Christophe
>
>
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Charles Eckel (eckelcu)
> *Sent:* mardi 24 mai 2016 23:43
> *To:* Ole Troan; vpp-dev
> *Subject:* Re: [vpp-dev] IETF 96 hackathon registration,
> champions/projects, and format tweaks
>
>
>
> It would be great to have VPP in Berlin. I am running the hackathon and am
> happy to answer any questions and help you get started.
>
>
>
> Cheers,
>
> Charles
>
>
>
> *From: *Ole Troan <[email-masked]>
> *Date: *Monday, May 23, 2016 at 7:45 AM
> *To: *vpp-dev <[email-masked]>
> *Cc: *Charles Eckel <[email-masked]>
> *Subject: *Fwd: IETF 96 hackathon registration, champions/projects, and
> format tweaks
>
>
>
> We had great fun doing SADR for VPP in Buenos Aires. Second best in show,
> and we attracted a few external people who only showed up to the IETF
> because of VPP.
>
>
>
> This is where running code meets the IETF, so if someone has an active
> draft in the IETF they want to implement that would be a great fit.
>
>
>
> This is in the middle of my summer holiday, so I might not be able to
> champion, but I would certainly be very supportive (while on the beach. ;-))
>
>
>
> Best regards,
>
> Ole
>
>
>
> Begin forwarded message:
>
>
>
> *From: *"Charles Eckel (eckelcu)" <[email-masked]>
>
> *Subject: IETF 96 hackathon registration, champions/projects, and format
> tweaks*
>
> *Date: *20 May 2016 at 23:53:40 GMT+2
>
> *To: *"[email-masked]" <[email-masked]>, IETF chairs <
> [email-masked]>
>
>
>
> Hey Folks,
>
>
>
> IETF 96 is rapidly approaching. As usual, the hackathon will be the
> weekend before, July 16-17. Check out the info page and register today:
>
> Many of you have expressed interest in championing something in Berlin.
> Now is the time to update the wiki and inform others of your intentions.
> You don’t need to put much, just enough to give others a reasonable idea of
> what you plan to do and links to where to go for more info, suggested
> reading, existing code, etc. Do this asap to help recruit others to join
> you and make their travel arrangements accordingly.
>
>
>
> In anticipation of the largest hackathon ever, we are considering
> adjusting the format a bit to reduce the amount of time spent sharing
> project overviews at the beginning and presenting results at the end. If
> you have suggestions for how we can improve the hackathon, now is the time
> to share those thoughts as well.
>
>
>
> Cheers,
>
> Charles
>
>
>
>
>
>
>
> This message and any attachments (the "message") are confidential,
> intended solely for the addressees. If you are not the intended recipient,
> please notify the sender immediately by e-mail and delete this message from
> your system. In this case, you are not authorized to use, copy this message
> and/or disclose the content to any other person. E-mails are susceptible to
> alteration. Neither Qosmos nor any of its subsidiaries or affiliates shall
> be liable for the message if altered, changed or falsified.
>
> Ce message et toutes ses pièces jointes (ci-après le "message")sont
> confidentiels et établis à l'intention exclusive de ses destinataires. Si
> vous avez reçu ce message par erreur, merci d’en informer immédiatement son
> émetteur par courrier électronique et d’effacer ce message de votre
> système. Dans cette hypothèse, vous n’êtes pas autorisé à utiliser, copier
> ce message et/ou en divulguer le contenu à un tiers. Tout message
> électronique est susceptible d'altération. Qosmos et ses filiales déclinent
> toute responsabilité au titre de ce message s'il a été altéré, déformé ou
> falsifié.
> _______________________________________________
> vpp-dev mailing list
> [email-masked]
> https://lists.fd.io/mailman/listinfo/vpp-dev

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Fri, 1 Jul 2016 04:41:27 +0000

That is a very good question. If code is in some repo we could certainly divide tasks and have remote participants.

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Keith Burns <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 1, 2016 at 12:54 AM
To: Christophe FONTAINE <[email-masked]<mailto:[email-masked]>>, "Charles Eckel (eckelcu)" <[email-masked]<mailto:[email-masked]>>, Ole Troan <[email-masked]<mailto:[email-masked]>>, vpp-dev <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [hackathon] [vpp-dev] IETF 96 hackathon registration, champions/projects, and format tweaks

I'm not sure if Hongjun is planning on going or if he could attend remotely but he has been doing work on NSH Proxy in the NSH_SFC project...

On Thu, Jun 30, 2016 at 6:38 AM Christophe FONTAINE <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Who is interested ?

See you there,
Christophe

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Charles Eckel (eckelcu)
Sent: mardi 24 mai 2016 23:43
To: Ole Troan; vpp-dev
Subject: Re: [vpp-dev] IETF 96 hackathon registration, champions/projects, and format tweaks

Cheers,
Charles

Best regards,
Ole

Begin forwarded message:

Hey Folks,

Cheers,
Charles

Ce message et toutes ses pièces jointes (ci-après le "message")sont confidentiels et établis à l'intention exclusive de ses destinataires. Si vous avez reçu ce message par erreur, merci d'en informer immédiatement son émetteur par courrier électronique et d'effacer ce message de votre système. Dans cette hypothèse, vous n'êtes pas autorisé à utiliser, copier ce message et/ou en divulguer le contenu à un tiers. Tout message électronique est susceptible d'altération. Qosmos et ses filiales déclinent toute responsabilité au titre de ce message s'il a été altéré, déformé ou falsifié.

_______________________________________________
vpp-dev mailing list
[email-masked]<mailto:[email-masked]>
https://lists.fd.io/mailman/listinfo/vpp-dev

---

From: "Jerome Tollet (jtollet)" <[email-masked]>
Date: Fri, 1 Jul 2016 06:08:19 +0000

During last IETF hackathon, I know some people were remote.
Jerome

De : hackathon <[email-masked]> au nom de "Reinaldo Penno (repenno)" <[email-masked]>
Date : vendredi 1 juillet 2016 06:41
À : Keith Burns <[email-masked]>, Christophe Fontaine <[email-masked]>, "Charles Eckel (eckelcu)" <[email-masked]>, Ole Troan <[email-masked]>, vpp-dev <[email-masked]>
Cc : "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Objet : Re: [hackathon] [vpp-dev] IETF 96 hackathon registration, champions/projects, and format tweaks

I’ll will be with a colleague from Qosmos at the next IETF Hackathon in Berlin :-)
We’d like to focus on VPP/NSH : creating a NSH Proxy is one possibility among other things.

Who is interested ?

See you there,
Christophe

Cheers,
Charles

Best regards,
Ole

Begin forwarded message:

Hey Folks,

Many of you have expressed interest in championing something in Berlin. Now is the time to update the wiki and inform others of your intentions. You don’t need to put much, just enough to give others a reasonable idea of what you plan to do and links to where to go for more info, suggested reading, existing code, etc. Do this asap to help recruit others to join you and make their travel arrangements accordingly.

Cheers,
Charles

Ce message et toutes ses pièces jointes (ci-après le "message")sont confidentiels et établis à l'intention exclusive de ses destinataires. Si vous avez reçu ce message par erreur, merci d’en informer immédiatement son émetteur par courrier électronique et d’effacer ce message de votre système. Dans cette hypothèse, vous n’êtes pas autorisé à utiliser, copier ce message et/ou en divulguer le contenu à un tiers. Tout message électronique est susceptible d'altération. Qosmos et ses filiales déclinent toute responsabilité au titre de ce message s'il a été altéré, déformé ou falsifié.
_______________________________________________
vpp-dev mailing list
[email-masked]<mailto:[email-masked]>
https://lists.fd.io/mailman/listinfo/vpp-dev

---

From: Pierre Pfister <[email-masked]>
Date: Fri, 1 Jul 2016 08:37:12 +0200

Indeed.
I was remote during the last hackathon, and it was almost as fun !

Cheers,

- Pierre

> Le 1 juil. 2016 à 08:08, Jerome Tollet (jtollet) <[email-masked]> a écrit :
> 
> De : hackathon <[email-masked] <mailto:[email-masked]>> au nom de "Reinaldo Penno (repenno)" <[email-masked] <mailto:[email-masked]>>
> À : Keith Burns <[email-masked] <mailto:[email-masked]>>, Christophe Fontaine <[email-masked] <mailto:[email-masked]>>, "Charles Eckel (eckelcu)" <[email-masked] <mailto:[email-masked]>>, Ole Troan <[email-masked] <mailto:[email-masked]>>, vpp-dev <[email-masked] <mailto:[email-masked]>>
> Cc : "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> From: hackathon <[email-masked] <mailto:[email-masked]>> on behalf of Keith Burns <[email-masked] <mailto:[email-masked]>>
> To: Christophe FONTAINE <[email-masked] <mailto:[email-masked]>>, "Charles Eckel (eckelcu)" <[email-masked] <mailto:[email-masked]>>, Ole Troan <[email-masked] <mailto:[email-masked]>>, vpp-dev <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> On Thu, Jun 30, 2016 at 6:38 AM Christophe FONTAINE <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
>  
> From:[email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Charles Eckel (eckelcu)
> From: Ole Troan <[email-masked] <mailto:[email-masked]>>
> To: vpp-dev <[email-masked] <mailto:[email-masked]>>
> Cc: Charles Eckel <[email-masked] <mailto:[email-masked]>>
> From: "Charles Eckel (eckelcu)" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, IETF chairs <[email-masked] <mailto:[email-masked]>>
>  
> Hey Folks,
>  
> https://www.ietf.org/hackathon/96-hackathon.html <https://www.ietf.org/hackathon/96-hackathon.html>
>  
> https://www.ietf.org/registration/MeetingWiki/wiki/96hackathon <https://www.ietf.org/registration/MeetingWiki/wiki/96hackathon>
>  
> [email-masked] <mailto:[email-masked]>
> https://lists.fd.io/mailman/listinfo/vpp-dev <https://lists.fd.io/mailman/listinfo/vpp-dev>_______________________________________________
> hackathon mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>

---

From: Melinda Shore <[email-masked]>
Date: Thu, 30 Jun 2016 22:42:54 -0800

> During last IETF hackathon, I know some people were remote.

I was among them, and I've done it twice (I think).  The #1
thing to plan ahead of time is which collaboration tools to
use, and how to maintain contact with the team.

BTW, many thanks to Dan York for setting up the Youtube livestream
of the results - that was a huge thing for those of us who were
remote.  I hope it can be repeated in Berlin!

Melinda