Subject: [hackathon] ILA on VPP for next Hackathon

From: Pierre Pfister <[email-masked]>
Date: Mon, 20 Jun 2016 14:16:51 +0200

Hello all,

I added a project proposal for next Hackathon.
It would consist in implementing ILA (https://tools.ietf.org/html/draft-herbert-nvo3-ila-02) in the Vector Packet Processor (VPP - fd.io).

ILA is traditionally defined as a bump-in-the-stack, but would in that case be implemented as a bump-in-the-(virtual)-wire.

VPP is a DPDK-based open-source extensible framework that provides out-of-the-box production quality switch/router functionality. The current source-code (https://git.fd.io/cgit/vpp/) already includes plenty of different v4 or v6 encapsulation technologies. Given that VPP can be used as a virtual router, it would be fairly natural to offer a functionality such as ILA.

ILA shouldn't be hard to implement as a VPP plugin and is therefore a very nice candidate to learn a bit about this high-perf platform. If you are interested in participating or have any question, feel free to get in touch with us, as well as checkout the code and documentation (https://wiki.fd.io/view/VPP).

Also, if you have other projects related to ILA, you are very welcome to join the team !
It would be even nicer, I guess, to have multiple implementations, or a live perf test, etc...

See you in Berlin !

- Pierre

---

From: Jon Hudson <[email-masked]>
Date: Mon, 20 Jun 2016 11:46:00 -0700

Excellent!!!!!

> On Jun 20, 2016, at 5:16 AM, Pierre Pfister <[email-masked]> wrote:
> 
> Hello all,
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Dr. Karan Verma" <[email-masked]>
Date: Tue, 21 Jun 2016 16:04:27 +0530

i have to join your team

On Tue, Jun 21, 2016 at 12:16 AM, Jon Hudson <[email-masked]> wrote:

> > It would consist in implementing ILA (
> https://tools.ietf.org/html/draft-herbert-nvo3-ila-02) in the Vector
> Packet Processor (VPP - fd.io).
> >
> > ILA is traditionally defined as a bump-in-the-stack, but would in that
> case be implemented as a bump-in-the-(virtual)-wire.
> >
> > VPP is a DPDK-based open-source extensible framework that provides
> out-of-the-box production quality switch/router functionality. The current
> source-code (https://git.fd.io/cgit/vpp/) already includes plenty of
> different v4 or v6 encapsulation technologies. Given that VPP can be used
> as a virtual router, it would be fairly natural to offer a functionality
> such as ILA.
> >
> > ILA shouldn't be hard to implement as a VPP plugin and is therefore a
> very nice candidate to learn a bit about this high-perf platform. If you
> are interested in participating or have any question, feel free to get in
> touch with us, as well as checkout the code and documentation (
> https://wiki.fd.io/view/VPP).
> >
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
>

-- 
Best Regards

Dr. Karan Verma
Assistant Professor
Computer Science and Engineering Dept.
Central University Rajasthan, India
Website: www.drkaranverma.com
Phone: +917568169258

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 21 Jun 2016 14:46:25 +0000

Joining the team is easy and free. You can find more info on the hackathon and registration links at https://www.ietf.org/hackathon/96-hackathon.html
When you register, you can indicate which technologies interest you, e.g. VPP, ILA, etc.

Cheers,
Charles

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of "Dr. Karan Verma" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 21, 2016 at 3:34 AM
To: Jon Hudson <[email-masked]<mailto:[email-masked]>>
Cc: Tom Herbert <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Pierre Pfister <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [hackathon] [nvo3] ILA on VPP for next Hackathon

i have to join your team

On Tue, Jun 21, 2016 at 12:16 AM, Jon Hudson <[email-masked]<mailto:[email-masked]>> wrote:

Excellent!!!!!

> On Jun 20, 2016, at 5:16 AM, Pierre Pfister <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hello all,
>
> It would consist in implementing ILA (https://tools.ietf.org/html/draft-herbert-nvo3-ila-02) in the Vector Packet Processor (VPP - fd.io<http://fd.io>).
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
hackathon mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hackathon

--
Best Regards

Dr. Karan Verma
Assistant Professor
Computer Science and Engineering Dept.
Central University Rajasthan, India
Website: www.drkaranverma.com<http://www.drkaranverma.com/>
Phone: +917568169258

---

From: Tom Herbert <[email-masked]>
Date: Tue, 21 Jun 2016 09:52:26 -0700

> It would be even nicer, I guess, to have multiple implementations, or a live perf test, etc...
Awesome! I'll be there. We should be able to share some code shortly
for an ILA router in XDP for reference.

Tom

---

From: Pierre Pfister <[email-masked]>
Date: Tue, 21 Jun 2016 19:37:56 +0200

Great ! Welcome in the team !

Wonder why you 'have to' join us though. Is someone threatening you ? ;-)

Your ideas and proposals are welcome.

Regards,

- Pierre

> Le 21 juin 2016 à 12:34, Dr. Karan Verma <[email-masked]> a écrit :
> 
> i have to join your team 
> 
> On Tue, Jun 21, 2016 at 12:16 AM, Jon Hudson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Excellent!!!!!
> 
> > On Jun 20, 2016, at 5:16 AM, Pierre Pfister <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hello all,
> >
> > It would consist in implementing ILA (https://tools.ietf.org/html/draft-herbert-nvo3-ila-02 <https://tools.ietf.org/html/draft-herbert-nvo3-ila-02>) in the Vector Packet Processor (VPP - fd.io <http://fd.io/>).
> >
> > VPP is a DPDK-based open-source extensible framework that provides out-of-the-box production quality switch/router functionality. The current source-code (https://git.fd.io/cgit/vpp/ <https://git.fd.io/cgit/vpp/>) already includes plenty of different v4 or v6 encapsulation technologies. Given that VPP can be used as a virtual router, it would be fairly natural to offer a functionality such as ILA.
> >
> > ILA shouldn't be hard to implement as a VPP plugin and is therefore a very nice candidate to learn a bit about this high-perf platform. If you are interested in participating or have any question, feel free to get in touch with us, as well as checkout the code and documentation (https://wiki.fd.io/view/VPP <https://wiki.fd.io/view/VPP>).
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/nvo3 <https://www.ietf.org/mailman/listinfo/nvo3>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>
> 
> 
> 
> -- 
> Best Regards 
> 
> Dr. Karan Verma 
> Assistant Professor  
> Website: www.drkaranverma.com <http://www.drkaranverma.com/>
> Phone: +917568169258