Subject: [hackathon] Introducing ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS in IETF 96 Hackathon

From: Dhruv Dhody <[email-masked]>
Date: Wed, 25 May 2016 14:41:03 +0000

Hi Hackers!

We have updated the wiki with details regarding our projects at https://www.ietf.org/registration/MeetingWiki/wiki/96hackathon

ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS
Project(s)

l  ACTN (Abstraction and Control of TE network)

n  Setup a hierarchy of controllers and extend for multi-destination option ( i.e. selection of an endpoint from a possible list)

l  PCECC (PCE as central controller)

n  Use PCEP as an SBI and extend for Label DB synchronization optimization

l  BGP-LS or BGP-Flowspec

n  Support for Segment Routing (SR) in BGP-LS

n  RDP in BGP-Flowspec

l  Yang Metadata

n  add user specific information in yang model

l  For all the projects we would be using ONOS platform

n  http://onosproject.org/

l  Detailed information at -

n  [Google Drive] https://drive.google.com/folderview?id=0B-76cYXo_ss9NzA5ODlGY0ZUQTA&usp=sharing

n  [GitHub] https://github.com/dhruvdhody-huawei/ietf-hackathon-96.git

If any of these interest you, please do register!

For those new to ONOS controller, we would be planning a webinar last week of June!

See you all in Berlin!

Regards,
Dhruv

---

From: "Yangbangwen (Ben Yang, Fixed Network Solution MO)" <[email-masked]>
Date: Thu, 26 May 2016 02:24:55 +0000

Who will forward this mail to ONOS community or ONOS announcement? We need more ONOS developers to be aware of this hackathon and attend it.

发件人: Dhruv Dhody
发送时间: 2016年5月25日 22:41
收件人: [email-masked]
抄送: Yangbangwen (Ben Yang, Fixed Network Solution MO) <[email-masked]>; Jiangrui (Henry, R&D) <[email-masked]>; Kalyankumar Asangi <[email-masked]>
主题: Introducing ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS in IETF 96 Hackathon

Hi Hackers!

l  BGP-LS or BGP-Flowspec

n  RDP in BGP-Flowspec

l  Yang Metadata

See you all in Berlin!

Regards,
Dhruv

---

From: Kalyankumar Asangi <[email-masked]>
Date: Thu, 26 May 2016 02:29:17 +0000

Should I ask William to publish it in ONOS community or let's do it by ourself ?

Sent from HUAWEI AnyOffice
From:Yangbangwen (Ben Yang, Fixed Network Solution MO)
To:Dhruv Dhody,[email-masked],
Cc:Jiangrui (Henry, R&D),Kalyankumar Asangi,
Date:2016-05-26 07:55:02
Subject:答复: Introducing ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS in IETF 96 Hackathon

发件人: Dhruv Dhody
发送时间: 2016年5月25日 22:41
收件人: [email-masked]

Hi Hackers!

l  BGP-LS or BGP-Flowspec

n  RDP in BGP-Flowspec

l  Yang Metadata

See you all in Berlin!

Regards,
Dhruv

---

From: "Yangbangwen (Ben Yang, Fixed Network Solution MO)" <[email-masked]>
Date: Thu, 26 May 2016 02:48:26 +0000

I suggest you ask William as William already be aware of it.

发件人: Kalyankumar Asangi
发送时间: 2016年5月26日 10:29
收件人: Yangbangwen (Ben Yang, Fixed Network Solution MO) <[email-masked]>; Dhruv Dhody <[email-masked]>; [email-masked]
抄送: Jiangrui (Henry, R&D) <[email-masked]>
主题: Re: 答复: Introducing ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS in IETF 96 Hackathon

发件人: Dhruv Dhody
发送时间: 2016年5月25日 22:41
收件人: [email-masked]<mailto:[email-masked]>
抄送: Yangbangwen (Ben Yang, Fixed Network Solution MO) <[email-masked]<mailto:[email-masked]>>; Jiangrui (Henry, R&D) <[email-masked]<mailto:[email-masked]>>; Kalyankumar Asangi <[email-masked]<mailto:[email-masked]>>
主题: Introducing ACTN/PCECC/BGP-Flowspec/BGP-LS/Yang/ONOS in IETF 96 Hackathon

Hi Hackers!

*  ACTN (Abstraction and Control of TE network)

*  Setup a hierarchy of controllers and extend for multi-destination option ( i.e. selection of an endpoint from a possible list)

*  PCECC (PCE as central controller)

*  Use PCEP as an SBI and extend for Label DB synchronization optimization

*  BGP-LS or BGP-Flowspec

*  Support for Segment Routing (SR) in BGP-LS

*  RDP in BGP-Flowspec

*  Yang Metadata

*  add user specific information in yang model

*  For all the projects we would be using ONOS platform

*  http://onosproject.org/

*  Detailed information at -

*  [Google Drive] https://drive.google.com/folderview?id=0B-76cYXo_ss9NzA5ODlGY0ZUQTA&usp=sharing

*  [GitHub] https://github.com/dhruvdhody-huawei/ietf-hackathon-96.git

See you all in Berlin!

Regards,
Dhruv