Subject: [hackathon] RIOT@IETF 94 Hackathon

From: "Thomas Eichinger" <[email-masked]>
Date: Mon, 05 Oct 2015 15:49:50 +0200

Hi,

   in continuation of the last Hackathon in Prague, some RIOT community 
members
will also attend the Hackathon in Yokohama. By now we added one task to 
the
wiki, to add the TSCH implementation of the OpenWSN project [1] as MAC 
layer
to RIOT [2]. More tasks could follow depending on availability of 
developers
and demand.

   Anybody who is interested in working on this is more than welcome to 
join!
If you have your own topic and want to implement this on RIOT, let us 
know
in advance and we will tailor introduction etc.

Cheers,
Thomas

[1] 
https://openwsn.atlassian.net/wiki/display/OW?src=breadcrumbs-homepage
[2] http://www.riot-os.org

---

From: Oliver Hahm <[email-masked]>
Date: Tue, 13 Oct 2015 12:03:31 +0200

Hi,

I'd like to propose another follow-up to the good work on RIOT people started
in Prague. Updating the CCN-Lite stack in RIOT, I plan to work on a flexible
transport implementation. The goal is to make it configurable whether CCN runs
over UDP or directly over any link-layer (Ethernet, IEEE 802.15.4...)

I would be happy to work with anyone interested in this or another ICN-related
topic in RIOT.

Cheers,
Oleg
-- 
Institute of Computer Science
Freie Universität Berlin
AG-Tech, Room 148
Takustr. 9, 14195 Berlin
Mail: [email-masked]
Web: http://www.des-testbed.net
     http://www.riot-os.org

---

From: Dirk Kutscher <[email-masked]>
Date: Tue, 13 Oct 2015 14:49:10 +0000

Hi Oleg,

thanks for proposing this. I forwarded your message to [email-masked] -- I think it would be good have this activity.

Best regards,
Dirk

-----Original Message-----
From: hackathon [mailto:[email-masked]] On Behalf Of Oliver Hahm
Sent: Dienstag, 13. Oktober 2015 12:04
To: Charles Eckel (eckelcu)
Cc: [email-masked]
Subject: Re: [hackathon] RIOT@IETF 94 Hackathon

Hi,

I'd like to propose another follow-up to the good work on RIOT people started in Prague. Updating the CCN-Lite stack in RIOT, I plan to work on a flexible transport implementation. The goal is to make it configurable whether CCN runs over UDP or directly over any link-layer (Ethernet, IEEE 802.15.4...)

I would be happy to work with anyone interested in this or another ICN-related topic in RIOT.

Cheers,
Oleg