Subject: Re: [hackathon] IETF94 OpenWRT Homenet IPv6

From: "Rodriguez, Iben" <[email-masked]>
Date: Tue, 27 Oct 2015 02:10:35 +0000

FWIW – I have been tinkering with OpenWRT since this Homenet thread started and I am following IETF last few months – I built virtual machine images that run fine on VMware hypervisors from the KVM raw images the build system spits out - http://wiki.openwrt.org/doc/howto/vmware <— can we make this auto generate by the build system?  Who runs that?

I had asked the list for suggestions on hardware but didn’t get very far on that front so didn’t bring any fancy travel routers with 15cc build on it with me – just the VMs (they’re very small and light weight).

One idea for the hackathon is to get a bunch of physical and virtual chaos_calmer 15.05 routers talking to each other with ipv6 and home net and make a couple recipes and maybe a cookbook for how to configure for various roles.

Based on who shows up and when it might be really fun to see how easy or difficult to add and remove nodes from the setup.

This cookbook should start with an introduction including back ground and history and a highlight a few sample use cases.

Then we can dive into the steps to follow to build out each role to support the use cases.

If there is any existing content you wish to share or questions and suggestions of things to try please forward to me and I will compile them into a doc we can collaborate on to be shared during the hackathon.

Just show up when you can.

—
[email-masked]
+14087824726
Skype: ibenrodriguez
Twitter: @iben<http://twitter.com/iben>
Wechat: ibentc

On 10/27/15, 10:54 AM, "hackathon on behalf of Charles Eckel (eckelcu)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi David,

We have plenty of space this time, so feel free to register and attend as your schedule permits.
The kickoff and team forming is Saturday morning, so its best to be there for that, but its not required.

Cheers,
Charles

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of David Bird <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 27, 2015 at 10:45 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] IETF newbie...

Greetings,

I'm interested in participating in the hackathon, but I'm conflicted... I arrive in Yokohama Saturday (probably late morning) and I also have newbie meetings on Sunday. Yet, I'm interested in participating in the hackathon -- particularly since I enjoy hacking in OpenWRT (and am interested in DNS, DHCP, Homenet, and more). I am by no means an OpenWRT expert, but I did support a firmware based on OpenWRT (called CoovaAP) for several years, and have been active in networking centric open-source for even longer.

My only hesitation in registering is that my spotty attendance might make it pointless (?)

Better to leave the space for someone else?

Cheers,
David

Spirent Communications e-mail confidentiality.
------------------------------------------------------------------------
This e-mail contains confidential and / or privileged information belonging to Spirent Communications plc, its affiliates and / or subsidiaries. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution and / or the taking of any action based upon reliance on the contents of this transmission is strictly forbidden. If you have received this message in error please notify the sender by return e-mail and delete it from your system.

Spirent Communications plc
Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN, United Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN, United Kingdom.

Or if within the US,

Spirent Communications,
27349 Agoura Road, Calabasas, CA, 91301, USA.
Tel No. 1-818-676- 2300

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 26 Oct 2015 19:26:35 -0700

I'll try to have 2 * Mikrotik RB951G-2HND with me. I use similar
ones @home, just not yet with CC. Also a Ubiquiti ER-X. That one
i have no idea if OpenWrt will run on.

VMs sound quite interesting to me too.

On Tue, Oct 27, 2015 at 02:10:35AM +0000, Rodriguez, Iben wrote:
> FWIW ??? I have been tinkering with OpenWRT since this Homenet thread started and I am following IETF last few months ??? I built virtual machine images that run fine on VMware hypervisors from the KVM raw images the build system spits out - http://wiki.openwrt.org/doc/howto/vmware <??? can we make this auto generate by the build system?  Who runs that?
> 
> I had asked the list for suggestions on hardware but didn???t get very far on that front so didn???t bring any fancy travel routers with 15cc build on it with me ??? just the VMs (they???re very small and light weight).
> 
> ???

> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon

-- 
---
Toerless Eckert, [email-masked]

---

From: David Bird <[email-masked]>
Date: Mon, 26 Oct 2015 20:47:34 -0700

I just installed OpenWRT trunk on an Ubiquiti AirRouter as my multi-purpose
travel router... It is easy to flash via tftp and has 4 LAN ports (+ WAN).
I also work with UniFi APs a lot, but those do require PoE and TTL cable. I
have never installed OpenWRT on edge routers, but they do run debian ...
you can install gcc on it and build locally (though, very slow! :)

On Mon, Oct 26, 2015 at 7:26 PM, Toerless Eckert <[email-masked]> wrote:

> > FWIW ??? I have been tinkering with OpenWRT since this Homenet thread
> started and I am following IETF last few months ??? I built virtual machine
> images that run fine on VMware hypervisors from the KVM raw images the
> build system spits out - http://wiki.openwrt.org/doc/howto/vmware <???
> can we make this auto generate by the build system?  Who runs that?
> >
> > I had asked the list for suggestions on hardware but didn???t get very
> far on that front so didn???t bring any fancy travel routers with 15cc
> build on it with me ??? just the VMs (they???re very small and light
> weight).
> >
> > One idea for the hackathon is to get a bunch of physical and virtual
> chaos_calmer 15.05 routers talking to each other with ipv6 and home net and
> make a couple recipes and maybe a cookbook for how to configure for various
> roles.
> >
> > Based on who shows up and when it might be really fun to see how easy or
> difficult to add and remove nodes from the setup.
> >
> > This cookbook should start with an introduction including back ground
> and history and a highlight a few sample use cases.
> >
> > If there is any existing content you wish to share or questions and
> suggestions of things to try please forward to me and I will compile them
> into a doc we can collaborate on to be shared during the hackathon.
> >
> > On 10/27/15, 10:54 AM, "hackathon on behalf of Charles Eckel (eckelcu)" <
> [email-masked]<mailto:[email-masked]> on behalf
> of [email-masked]<mailto:[email-masked]>> wrote:
> >
> > Hi David,
> >
> > From: hackathon <[email-masked]<mailto:
> [email-masked]>> on behalf of David Bird <[email-masked]
> <mailto:[email-masked]>>
> > I'm interested in participating in the hackathon, but I'm conflicted...
> I arrive in Yokohama Saturday (probably late morning) and I also have
> newbie meetings on Sunday. Yet, I'm interested in participating in the
> hackathon -- particularly since I enjoy hacking in OpenWRT (and am
> interested in DNS, DHCP, Homenet, and more). I am by no means an OpenWRT
> expert, but I did support a firmware based on OpenWRT (called CoovaAP) for
> several years, and have been active in networking centric open-source for
> even longer.
> >
> > This e-mail contains confidential and / or privileged information
> belonging to Spirent Communications plc, its affiliates and / or
> subsidiaries. If you are not the intended recipient, you are hereby
> notified that any disclosure, copying, distribution and / or the taking of
> any action based upon reliance on the contents of this transmission is
> strictly forbidden. If you have received this message in error please
> notify the sender by return e-mail and delete it from your system.
> >