Subject: [hackathon] Internet of Things @ Hackathon: ACE & Co

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 10 Jul 2015 12:33:46 +0100

Hi all,

Michael Koster, Manuel Pégourié-Gonnard and myself will be at the Hackathon in Prague and we are interested to work on an Internet of Things (IoT) scenario. As a starting point we had been thinking about a user case from the IETF ACE working group about physical access control. I have worked with Eve Maler (Forgerock) and Erik Wahlström (Nexus Technology) on the user story for this use case. Erik is a domain expert in the physical access control space and has provided us with the necessary insight. Eve works for a company offering user identity management solutions and provides us with their vision on how to integrate IoT device management with user centric identity management solutions.

In any case, here is the description of the demo: https://docs.google.com/drawings/d/18Y0XwrhnAjJH51yWrNJY4aK8GYdf_EdbOxkEigqIHWQ/edit?usp=sharing
It combines several IETF technologies, including CoAP, Resource Directory, DTLS/TLS, and OAuth into a real-world IoT scenario.

The door lock would in some sense be fake since we are not trying to develop a real product but it nevertheless represents a challenging part. To make it realistic we wanted to use a Cortex M-based prototyping board offering Ethernet (or WiFi) together with Bluetooth Smart. The "front-end" connection to the user's device has to take place via Bluetooth Smart since it is widely available with smart phones and tablets today. With many deployed enterprise physical access control solutions there is also connectivity to a wired network infrastructure to interact with the backend infrastructure.

In terms of hardware we are planning to use a combination of the K64F and the Nordic NRF51-DK for the IoT devices. The two devices would be connected using I2C. The K64F prototyping board has an Ethernet connection and the Nordic board offers Bluetooth Smart. Here are some details about these prototyping boards:
https://developer.mbed.org/platforms/FRDM-K64F/
https://developer.mbed.org/platforms/Nordic-nRF51-DK/

I have ordered the Nordic NRF51-DK board but it has not yet arrived yet. If it does not arrive in time for the Hackathon then we are going to use the Nordic nRF51822 instead, which is also a Bluetooth Smart board but with less RAM and less flash memory. Here is the info about that board: https://developer.mbed.org/platforms/Nordic-nRF51822/

We are intentionally re-using existing IETF protocols to make our life easier: I am planning to use the Forgerock OpenAM server as an OAuth 2.0 authorization server and existing CoAP servers. They will have to get extended for this specific scenario setup. The interaction with the door lock requires us to define a new Bluetooth Smart profile/service, which we will have to design and implement. I hope that Erik Wahlström can make it to the event since he would help me with that task.

If someone else wants to join please let us know so that we take more boards/sensors/etc. with us (or other boards, depending on what you would like do). We are happy to help you become familiar with the ARM mbed. You can use the online IDE, third party IDEs that run on your desktop (like Keil, CooCox, IAR), or GCC.

Overall, the scenario aims to provide a contribution to the IETF ACE/OAuth working groups showing how already standardized technologies can be used to solve real-world use cases.

I believe we are going to have a lot of fun at the Hackathon even though our setup is quite ambitious.

Ciao
Hannes

PS: I will add our description to the Wiki. I noticed that there are plans for working on other exciting IoT technologies.

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2548782

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 10 Jul 2015 19:37:03 +0000

Sounds great Hannes. And yes, please do update the wiki.

Cheers,
Charles

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 10, 2015 at 4:33 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [hackathon] Internet of Things @ Hackathon: ACE & Co

Hi all,

Ciao
Hannes