Subject: [hackathon] IETF Hackathon GBP+SFC demo box image now available

From: alagalah <[email-masked]>
Date: Fri, 17 Jul 2015 06:48:14 +0200

Hi there,

For folks going to the IETF Hackathon, and for GBP/SFC folks in general,
there is a quicker alternative to building the Vagrant based demo from
scratch. 

This is helpful on slower internet connections. For instance, after
downloading a single box image, you can stand up 6 VMs for the demo in under
5min.

* Start by pulling the demo environment from
https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Consumability/De
mo (note the requirements listed on that page).
* Download .box image and replacement Vagrantfile from
https://www.dropbox.com/sh/x7yexgtnfg74efo/AAAWofg1bfqDx3J4vib9OmDAa?dl=0
* Replace the Vagrantfile from the demo with the one you downloaded from
Dropbox
* Edit the new Vagrantfile and change the reference to
"/Users/alagalah/Desktop/gbpsfc.box² to the location of the downloaded box
image (note Windows users will need to double escape their path i.e.
c:\\foo\\bar)
* Source ./env.sh
* Vagrant up
If folks at a minimum could ensure they have the pre-reqs installed listed
on the GBP wiki demo page linked above, and depending on your Internet
access here in Prague, pre-download the box and Vagrantfiles, we can help
with the rest on Saturday.

Looking forward to seeing you all there.

---

From: alagalah <[email-masked]>
Date: Fri, 17 Jul 2015 08:16:33 +0200

Folks,

Got some feedback from the Dropbox link may time out, so I am creating a new
github repo for the new Vagrantfile and gbpsfc.box file. This will take some
time to push, so hang tight if you are amongst those having issues
downloading from DropBox.

From:  alagalah <[email-masked]>
Date:  Friday, July 17, 2015 at 6:48 AM
To:  <[email-masked]>
Cc:  "[email-masked]"
<[email-masked]>, opendaylight sfc
<[email-masked]>
Subject:  IETF Hackathon GBP+SFC demo box image now available

> Hi there,
> 
> For folks going to the IETF Hackathon, and for GBP/SFC folks in general, there
> is a quicker alternative to building the Vagrant based demo from scratch.
> 
> https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Consumability/Demo
> (note the requirements listed on that page).
> If folks at a minimum could ensure they have the pre-reqs installed listed on
> the GBP wiki demo page linked above, and depending on your Internet access
> here in Prague, pre-download the box and Vagrantfiles, we can help with the
> rest on Saturday.
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 17 Jul 2015 08:28:06 +0000

You can use https://github.com/eckelcu/ietf-hackathon if you like.

From: hackathon <[email-masked]<mailto:[email-masked]>> on behalf of alagalah <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 17, 2015 at 8:16 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: opendaylight sfc <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [hackathon] IETF Hackathon GBP+SFC demo box image now available

Folks,

Got some feedback from the Dropbox link may time out, so I am creating a new github repo for the new Vagrantfile and gbpsfc.box file. This will take some time to push, so hang tight if you are amongst those having issues downloading from DropBox.

From: alagalah <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 17, 2015 at 6:48 AM
To: <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, opendaylight sfc <[email-masked]<mailto:[email-masked]>>
Subject: IETF Hackathon GBP+SFC demo box image now available

Hi there,

For folks going to the IETF Hackathon, and for GBP/SFC folks in general, there is a quicker alternative to building the Vagrant based demo from scratch.

This is helpful on slower internet connections. For instance, after downloading a single box image, you can stand up 6 VMs for the demo in under 5min.

  *   Start by pulling the demo environment from https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Consumability/Demo (note the requirements listed on that page).
  *   Download .box image and replacement Vagrantfile from https://www.dropbox.com/sh/x7yexgtnfg74efo/AAAWofg1bfqDx3J4vib9OmDAa?dl=0
  *   Replace the Vagrantfile from the demo with the one you downloaded from Dropbox
  *   Edit the new Vagrantfile and change the reference to "/Users/alagalah/Desktop/gbpsfc.box” to the location of the downloaded box image (note Windows users will need to double escape their path i.e. c:\\foo\\bar)
  *   Source ./env.sh
  *   Vagrant up

If folks at a minimum could ensure they have the pre-reqs installed listed on the GBP wiki demo page linked above, and depending on your Internet access here in Prague, pre-download the box and Vagrantfiles, we can help with the rest on Saturday.

---

From: "Keith Burns (krb)" <[email-masked]>
Date: Fri, 17 Jul 2015 13:21:40 +0000

Hackathon attendees, the GBPSFC.box file will be available for download via a local server onsite.

Tested internet access and we have 120/120 via WiFi

See you all tomorrow

---------- Forwarded message ----------
From: Keith Burns <[email-masked]>
Date: Jul 17, 2015 3:19 PM
Subject: Fwd: IETF Hackathon GBP+SFC demo box image now available
To: "Keith Burns (krb)" <[email-masked]>
Cc:

---------- Forwarded message ----------
From: "alagalah" <[email-masked]<mailto:[email-masked]>>
Date: Jul 17, 2015 6:48 AM
Subject: IETF Hackathon GBP+SFC demo box image now available
To: <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "opendaylight sfc" <[email-masked]<mailto:[email-masked]>>

Hi there,

  *   Start by pulling the demo environment from https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Consumability/Demo<https://wiki.opendaylight.org/view/Group_Based_Policy_%28GBP%29/Consumability/Demo> (note the requirements listed on that page).
  *   Download .box image and replacement Vagrantfile from https://www.dropbox.com/sh/x7yexgtnfg74efo/AAAWofg1bfqDx3J4vib9OmDAa?dl=0
  *   Replace the Vagrantfile from the demo with the one you downloaded from Dropbox
  *   Edit the new Vagrantfile and change the reference to "/Users/alagalah/Desktop/gbpsfc.box” to the location of the downloaded box image (note Windows users will need to double escape their path i.e. c:\\foo\\bar)
  *   Source ./env.sh
  *   Vagrant up