Subject: Re: [hackathon] homenet in Hackathon

From: Pierre Pfister <[email-masked]>
Date: Thu, 2 Jul 2015 15:58:41 +0200

Hello,

I have been quite implied in homenet for the past almost two years and would
be happy to ‘champion’ these subjects.

We also have 3 guys here who are quite motivated to work
on those subjects (they subscribed to the Hackathon already).

Two little problems on my side:
- I did not register to the Hackathon (yet).
- My plane will arrive late on friday’s evening. Is this a problem ?

Can we still make it happen somehow ?

Thanks,

- Pierre

> Le 19 juin 2015 à 21:34, Charles Eckel (eckelcu) <[email-masked]> a écrit :
> 
> Hi Markus,
> 
> It would be great to have HOMENET included, and your sample projects look
> good. I can add to the wiki, but we really need to identify one or more
> people to champion who can be available to kick things off and help get
> people going. I¹ve cc¹d the homenet list in hopes of finding volunteers.
> 
> Cheers,
> Charles
> 
> On 6/18/15, 12:39 AM, "hackathon on behalf of Markus Stenberg"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>> Heya,
>> 
>> due to personal reasons I will not able to be officially champion it as
>> such (Fri arrival not an option, probably not around early on Sat either
>> but will at least show up on Sat at some point and be there Sun) but I
>> would like the homenet stuff in general to be added to wiki as a hacking
>> option; I can help later if someone shows up. I know there are some
>> people signing up (or already signed up) that have some interest in that
>> direction too.
>> 
>> http://tools.ietf.org/wg/homenet/
>> 
>> What I would love to see:
>> 
>> - implementation of DNCP[1] in some quick-n-dirty scripting language (I
>> have two partial implementations done Python, for example, and it is
>> probably easily doable in 2 days if you are motivated; unfortunately I do
>> these in my copious spare time so haven¹t been able to finish either so
>> far)
>> 
>> - _any_ improvement of hnetd, an open-source impelementation of
>> DNCP+HNCP[2], issues list might provide starting point[3]
>> 
>> - perhaps implementation of one of the other WG drafts
>> 
>> - expanded version of the IETF92 BIER+homenet multicast stuff, or any
>> other Œquick and dirty¹ solution to homenet+X, e.g. X being multicast,
>> Coap, ..
>> 
>> Cheers,
>> 
>> -Markus
>> 
>> [1] https://datatracker.ietf.org/doc/draft-ietf-homenet-dncp/
>> [2] https://github.com/sbyx/hnetd/
>> [3] https://github.com/sbyx/hnetd/issues
>> 
>> _______________________________________________
>> hackathon mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/hackathon
> 
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 2 Jul 2015 14:31:21 +0000

Hi Pierre,

Yes, we can make it happen. Friday is an optional setup day for those with
special equipment to setup or configure. Just be sure to be wide awake and
fully caffeinated on Monday morning when we kick things off Saturday
morning. We will provide plenty coffee to help with that.
As for registration, the capacity is being increased as we speak. Some
participants will be working in another room on projects associated with
the ETSI plugtest event, so we can accommodate more people.
I will post another message to the [email-masked] list once the
registration limit has been increased.

Cheers,
Charles

---

From: Markus Stenberg <[email-masked]>
Date: Thu, 2 Jul 2015 20:28:10 +0300

I inserted preliminary topic to the wiki page ( 
https://www.ietf.org/registration/MeetingWiki/wiki/93hackathon ). Anyone 
can feel free to improve the entry or volunteer to champion (nudge 
Pierre :->) by editing the page.

I will provide moral support on Saturday and possibly show up then, but 
at least I will be around on Sunday.

Cheers,

-Markus