Subject: [hackathon] update on Hackathon

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 7 May 2015 15:01:53 +0000

Hi Everyone,

We are close to launching the event page and registration site for the hackathon at IETF 93 in Prague. We are working out a few remaining issues. In the meantime, here is a preview of the info for your considering and planning purposes. Comments, suggestions, and additional technologies/champions are all welcome.

IETF 93 Hackathon

The Internet Engineering Task Force (IETF) is holding a Hackathon to encourage developers to discuss, collaborate and develop utilities, ideas, sample code and solutions that show practical implementations of IETF standards.

When: Saturday July 18 and Sunday July 19
Where: Hilton Prague, Room TBD

Keep up to date by subscribing to https://www.ietf.org/mailman/listinfo/hackathon

The Hackathon is free to attend but limited to 100 attendees.

________________________________
Technologies and Champions*

* Champions are individuals familiar with a given technology who have volunteered to help get others get up and running with that technology

Champions should:

     *   Plan to arrive Friday, for any setup, and attend Saturday and Sunday
     *   Prepare a brief overview presentation to introduce the technology and suggest potential projects
     *   Make themselves available to answer questions and help others
     *   Hack on things themselves in their copious free time
     *   Additional champions for new or existing technologies are welcome at any time, send to [email-masked]<mailto:[email-masked]>

Current Technologies Include:

  *   BIER (Bit Index Explicit Replication)

     *   An alternative method of multicast forwarding
     *   Status: confirmed
     *   Champions:
Greg Shepherd (shep) <[email-masked]>
IJsbrand Wijnands (iwijnand) <[email-masked]>
     *   IETF working group charter: https://datatracker.ietf.org/wg/bier/charter/

  *   HTTP/2.0
     *   IETF Charter Hypertext Transfer Protocol (httpbis)<https://datatracker.ietf.org/wg/httpbis/charter/>
     *   Champions:
Mark Nottingham <[email-masked]>

  *   NETCONF/YANG, I2RS, OpenDaylight
     *   Working with NETCONF/YANG devices and models in I2RS and OpenDaylight
     *   Champions:
Benoit Claise <[email-masked]>
Jan Medved (jmedved) <[email-masked]>
Ignas Bagdonas <[email-masked]>

  *   NETVC and Daala
     *   Open source, royalty free video codec, video compression
     *   Daala Project: https://xiph.org/daala/
     *   Proposed IETF working group: Internet Video Codec (netvc)<https://datatracker.ietf.org/wg/netvc/charter/>
     *   Champions:
Timothy B. Terriberry <[email-masked]>
Jack Moffitt <[email-masked]>

  *   RIOT (OS for internet of things)
     *   http://www.riot-os.org/
     *   Information centric networking for IoT: Experiments with NDN in the Wild: http://conferences2.sigcomm.org/acm-icn/2014/papers/p77.pdf
     *   Champions:
Matthias Waehlisch <[email-masked]>
Emmanuel Baccelli <[email-masked]>
Oliver Hahm <[email-masked]>, a.k.a. Oleg

  *   SFC in OpenDaylight
     *   Service function chaining with OpenDaylight
     *   Champions:
Reinaldo Penno <[email-masked]>

  *   SPUD (Substrate Protocol Underneath Datagrams)
     *   Provide mechanism for applications at the end and boxes along the path to explicitly declare their assumptions and intentions
     *   Drafts: https://tools.ietf.org/id/spud
     *   Open source library: iptube/SPUDlib · GitHub<https://github.com/iptube/SPUDlib>
     *   Champions:
Joe Hildebrand <[email-masked]>
Pal Martinsen <[email-masked]>

Cheers,
Charles

---

From: Matthias Waehlisch <[email-masked]>
Date: Thu, 7 May 2015 17:12:35 +0200

Hi Charles,

  for RIOT, can you please replace the list of topics and champions as 
follow:

  Topics:

   * Update of AODVv2 (see draft-ietf-manet-aodvv2)
   * CoAP for service discovery in the IoT (see draft-jimenez-p2psip-coap-reload)
   * General IoT network stack and boarder gateway between the IoT and 
current Internet
  * Information centric networking for IoT: Experiments with NDN in the 
Wild: http://conferences2.sigcomm.org/acm-icn/2014/papers/p77.pdf

  Champions:

    Lotte Steenbrink (AODVv2) [email-masked]
    Hauke Petersen (CoAP) [email-masked]
    Martine Lenders (IP/IoT) [email-masked] 
    Kaspar Schleiser (ICN) [email-masked] 

Thanks
  matthias

On Thu, 7 May 2015, Charles Eckel (eckelcu) wrote:

> Hi Everyone,
> 
> We are close to launching the event page and registration site for the hackathon at IETF 93 in
> Prague. We are working out a few remaining issues. In the meantime, here is a preview of the info
> for your considering and planning purposes. Comments, suggestions, and additional
> technologies/champions are all welcome.
> 
> IETF 93 Hackathon 
> 
> The Internet Engineering Task Force (IETF) is holding a Hackathon to encourage developers to
> discuss, collaborate and develop utilities, ideas, sample code and solutions that show practical
> implementations of IETF standards.
> 
> __________________________________________________________________________________________________
> 
> * Champions are individuals familiar with a given technology who have volunteered to help get
> others get up and running with that technology
> 
>           Champions should:
> 
>      +  Plan to arrive Friday, for any setup, and attend Saturday and Sunday
>      +  Prepare a brief overview presentation to introduce the technology and suggest potential
>         projects
>      +  Make themselves available to answer questions and help others
>      +  Hack on things themselves in their copious free time
>      +  Additional champions for new or existing technologies are welcome at any time, send
>         to [email-masked]
> 
>      +  IETF Charter Hypertext Transfer Protocol (httpbis)
>      +  Champions:
>      +  Working with NETCONF/YANG devices and models in I2RS and OpenDaylight
>      +  Champions:
>      +  Open source, royalty free video codec, video compression
>      +  Daala Project: https://xiph.org/daala/
>      +  Proposed IETF working group: Internet Video Codec (netvc)
>      +  Champions:
>      +  http://www.riot-os.org/
>      +  Information centric networking for IoT: Experiments with NDN in the
>         Wild: http://conferences2.sigcomm.org/acm-icn/2014/papers/p77.pdf
>      +  Champions:
>      +  Service function chaining with OpenDaylight
>      +  Champions:
>      +  Provide mechanism for applications at the end and boxes along the path to explicitly
>         declare their assumptions and intentions
>      +  Drafts: https://tools.ietf.org/id/spud
>      +  Open source library: iptube/SPUDlib · GitHub
>      +  Champions:

-- 
Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net