Subject: [Fecframe] fecframe WGLCs

From: David Harrington <[email-masked]>
Date: Mon, 05 Mar 2012 13:59:50 -0500

Hi,

There are multiple fecframe WGLCs running for FEC schemes.

The charter is fairly clear:
"The FECFrame WG may develop new FEC schemes if necessary to provide
substantial performance gains for the intended applications. However
the acceptance of any FEC scheme will require multiple, prior, detailed
reviews of the FEC code by independent experts from both the IETF and
the broader community, since it is likely that the IETF working group
will not include a large enough number of suitable experts in its
working set. If these reviews are positive, then Working Group
acceptance of an FEC scheme work item still needs the approval of the
responsible Area Director. "

For the WGLC, I would like more than just a "sure I support this" email.

I would like a "I have reviewed the text in this document, I have reviewed
the code in this document, and this scheme significantly improves
performance for a use case that is important to me, which is <Š>. Therefore,
I support publication of this document."

If you have implemented or deployed this specification, and found no
problems with the specification, or plan to implement or deploy this scheme,
stating that would also be helpful.

Please convince me that these documents are ready for IESG Review and
deserve to be published as RFCs that are IETF standards because they address
real-world problems.

Thanks,
--
David Harrington
Director, Transport Area
Internet Engineering Task Force (IETF)
[email-masked]
+1-603-828-1401

---

From: Vincent Roca <[email-masked]>
Date: Thu, 8 Mar 2012 16:37:08 +0100

Hello David,

You're perfectly right. We did the exercise last year, before accepting
both I-D as WG Items.

1- Concerning LDPC-Staircase codes, you'll find opinions at:

http://www.ietf.org/mail-archive/web/fecframe/current/msg00816.html
http://www.ietf.org/mail-archive/web/fecframe/current/msg00811.html
http://www.ietf.org/mail-archive/web/fecframe/current/msg00810.html

In the meantime LDPC-Staircase codes have been adopted as the
primary AL-FEC scheme for the Japanese ISDB-Tmm standard.
Both open-source and commercial codecs are available. And if you do
want the check by yourself their performance, you can:
	http://openfec.org

2- Concerning Reed-Solomon codes, they are so commonly used
that I don't think we need any official support.

Cheers,

   Vincent

On March 5, 2012, 19:59, David Harrington wrote:
> I would like a "I have reviewed the text in this document, I have reviewed the code in this document, and this scheme significantly improves performance for a use case that is important to me, which is <…>. Therefore, I support publication of this document."
> 
> If you have implemented or deployed this specification, and found no problems with the specification, or plan to implement or deploy this scheme, stating that would also be helpful.
> 
> Please convince me that these documents are ready for IESG Review and deserve to be published as RFCs that are IETF standards because they address real-world problems.
> 
> Thanks,
> --
> David Harrington
> Director, Transport Area
> _______________________________________________
> Fecframe mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fecframe

---

From: David Harrington <[email-masked]>
Date: Thu, 08 Mar 2012 10:52:47 -0500

Hi,

Thanks,

It would be greatly helpful if that information is included in the document
shepherd writeup when the doc is submitted to the IESG.

From:  Vincent Roca <[email-masked]>
Date:  Thu, 8 Mar 2012 16:37:08 +0100
To:  David Harrington <[email-masked]>
Cc:  <[email-masked]>
Subject:  Re: [Fecframe] fecframe WGLCs

Hello David,

Cheers,

   Vincent

On March 5, 2012, 19:59, David Harrington wrote:
> I would like a "I have reviewed the text in this document, I have reviewed the
> code in this document, and this scheme significantly improves performance for
> a use case that is important to me, which is <Š>. Therefore, I support
> publication of this document."
> 
> If you have implemented or deployed this specification, and found no problems
> with the specification, or plan to implement or deploy this scheme, stating
> that would also be helpful.
> 
> Please convince me that these documents are ready for IESG Review and deserve
> to be published as RFCs that are IETF standards because they address
> real-world problems.
> 
> Thanks,
> --
> David Harrington
> Director, Transport Area

---

From: Greg Shepherd <[email-masked]>
Date: Thu, 22 Mar 2012 11:07:46 -0700

So far only Vincent has responded. I can't progress this as
"consensus" without more input from the WG. Please respond ASAP.

Thanks,
Greg

On Thu, Mar 8, 2012 at 7:52 AM, David Harrington <[email-masked]> wrote:
> performance for a use case that is important to me, which is <…>. Therefore,