Subject: AW: AW: [Iptel] FW: [Enum] Summary on NoPSTN dicussion

From: "Stastny Richard" <[email-masked]>
Date: Thu, 1 Apr 2004 09:35:44 +0200

Mike wrote:

	>>First, no number is owner by anybody, it is assigned by ITU-T to the NRA,
	>>and assigned in turn to the SP, and the SP assignes it to the end-user (for
	>>geographic numbers. Service numbers are already assigned one-by-one
	>>to the end-user by the NRA, no blocks, no anchor SP.
	
	>How does this work for numbers that were assigned to an SP, that used to be
	>TDM-only, but then (over time) converts to an IP-only network?  The SPs are
	>very guarded about the E.164 numbers assigned to them.  That is what I
	>meant by "owned."  You are suggesting that when a person with a phone
	>number assigned by an SP moves to an IP-based "phone" that the SP will
	>relinquish that phone number back to the NRA?  Or are you saying that
	>number portability doesn't work between TDM and IP worlds?
	 
	We are talking here about four different things here:
	Case 1:  a VoIP provider is also an ILEC (eg a cable operator) and gets a 
	number (geographic) range (block) assigned and assignes them to his users.
	Since number assignement is technology independent, there is no problem here,
	as long as the SP is providing a telephony service as usual (we call this PATS -
	Publicly Available Telephony Service in Europe).
	Note: some VoIP SP hide between small ILECs and get such number ranges
	via them (e.g Vonage, sipgate.de, ...)
	 
	Case 2: Since all normal rules apply, also LNP applies, so users may port
	their numbers back and forth between PSTN and VoIP SP
	 
	Case 3: The regulator reserves a special number range for VoIP (050 in
	Japan, 05x in UK, 032 in Germany). If these services are declared non-PATS
	NP does not apply (this is under discussion). In Japan there is also a lighter 
	regime regarding QoS. Regulations differ here in all countries. 
	In this case the VoIP SP also get blocks of numbers and route them to their GW. 
	I know, in the US there is no such number range. The problem I have with
	such an approach is that there are differnt rules in every country and end-users
	get restricted services. (e.g no NP, no access to emergence services, etc.
	IMHO this will cause problems in the future
	 
	Case 4. the regulator reserves a special number range for ENUM-only routed 
	numbers. This should be done directly to the end-user. The advantage is
	that you have NP built-in, without having to deal with normal LNP issues and
	technology, saving the SP much effort.
	 
	The difference between case 3 and 4 is that in case 3 no rules exist for NP and
	interconnect on IP, so you create VoIP Island that are interconnected only via
	the PSTN per default. If you interconnect on IP, you can do this only currently
	with bilateral agreements. In case 4 you have automatically NP and also interconnect
	because you can use ENUM also on IP to interconnect. This is BTW also drafted
	in the SIP Forum Service Provider WG Interconnect Consensus.

	>>With ENUM-only numbers there is no need to assign blocks of numbers.
	>>An ENUM-only number is the equivalent of a domain name. It is assigned
	>>to the end-user directly, who chooses the SP, like with a service number.
	>>You also do not assign domain names in blocks.
	
	>I think there is an issue here.  If the SPs hold most of the current NPA
	>blocks, and there is a migration of many users from TDM to IP, then do you
	>lengthen the number to 11 digits to get more, or do the SPs have to
	>relinquish numbers?

	This a typical NANP problem. In the NANP there is only geographic area
	codes (with the exception of 800 numbers). In most other country there are
	more number types: you have geographic and non-geographic numbers.

	Non-geo numbers are eg mobile numbers, personal numbers, etc. The advantage
	here is that you relieve the pressure on the number exhaust here. Since geo
	numbers are given away in blocks, you have a lot of unused numbers.
	Eg in Austria the geo numbers are using up a great chunk of the numbers:
	we have 1100 4-digit area codes used be appox 4 Mio subscribers,
	on the other hand, we have 5 (five) 3-digit mobile number ranges
	used by 4,5 Mio subscribers (80% of them are behind 2 mobile "area" codes).

	The reason is simple: the mobile number ranges are flat. So if we give eg
	one 3-digit number range to ENUM, we can instantly use them with
	additional 7-digits for 9.999.999 subscribers. 
	
	regards

	Richard

z{�����x%��^��z��m��?�0�'�~���f��f��X��)ߣ���

---

From: "Pfautz, Penn L, ALABS" <[email-masked]>
Date: Thu, 1 Apr 2004 12:11:10 -0500

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_______________________________________________enum mailing [email-masked]://www1.ietf.org/mailman/listinfo/enum

---

From: "James McEachern" <[email-masked]>
Date: Thu, 1 Apr 2004 17:26:31 -0500

If the E.164 number has been assigned to a SP providing a PATS, then the
PSTN will (must - because of opt-in) always know how to route to the
appropriate SP, and the SP in turn knows how to route to the device. If the
number is an ENUM only number, then the PSTN will need to know this (both
the fact that it is a valid number so it does not reject it, and the fact
that it is an ENUM-only number so that it can route it to an ENUM enabled
GW). The PSTN will be able to determine this using existing routing &
translation techniques - nothing more is required.

So the entire problem comes down to how the VoIP network can recognize that
a number is an "ENUM-only" number, and not route this to the PSTN if there
is no ENUM entry. For all other cases routing to the PSTN works fine. This
means that whatever solution we come up with, it is only necessary to apply
it to ENUM-only numbers. (We *may* decide it is valuable to also apply it to
other numbers, but if it complicates things this is not necessary.)

Am I missing something?

Jim

-----Original Message-----
From: Michael Hammer [mailto:[email-masked]] 
Sent: Thursday, April 01, 2004 3:58 PM
To: Pfautz, Penn L, ALABS
Cc: Stastny Richard; McEachern, James [CAR:5N00:EXCH]; [email-masked]
Subject: RE: AW: [Iptel] FW: [Enum] Summary on NoPSTN dicussion

This sounds reasonable to me, but I would rather hear from the DNS experts.

My assumption, as you note below, was that if the number was not in ENUM, 
then the only element that knows whether the number is assigned and 
reachable is the operator PSTN-IP GW that has a configured translation or 
knows that the number is unassigned.

Mike

At 12:11 PM 4/1/2004 -0500, Pfautz, Penn L, ALABS wrote:
>If I understand it the root issue is this:
>All E.164 numbers will have a PSTN point-of-interface, but for some 
>numbers that POI is a gateway to IP. Further some subset of these numbers 
>are ones that won't be assigned if they're not reachable through IP. So, 
>in order to avoid routing to the default gateway after an ENUM query that 
>returns no result because the number is unassigned, people are seeking 
>some mechanism to provide a response to the initial ENUM query to indicate 
>that attempts to route through the PSTN will be fuitless. And the need is 
>to do this without treading on the opt-in principle.
>
>Here's a thought which the more DNS/DDDS literate may be able to confirm 
>or shoot down:
>At Tier 1, instead of populating an NS record with the tier 2 delegation 
>for each number instead populate a pair of non-terminal NAPTR records with 
>different service fields (e.g.,  E2U  and E2C) which would point to the 
>domains for the end user Tier 2 and carrier Tier 2 respectively. In this 
>way, a single query would provide pointers into both trees and a client 
>could decide whether to pursue one or the other, or potentially both. For 
>non-assigned "ENUM-only" numbers, the carrier could populate the E2C 
>record only without treading on the perogatives of the end user or having 
>to instantiate a separate Tier 1.
>Such E2C records could not only address the NoPSTN issue but also be the 
>basis for a carrier or infrastructure ENUM capability that may become more 
>important as VoIP moves beyond arbitrage to where IP interconnection 
>becomes norm.
>
>Penn Pfautz
>
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>Stastny Richard
>Sent: Thursday, April 01, 2004 2:36 AM
>To: Michael Hammer
>Cc: James McEachern; [email-masked]
>Subject: AW: AW: [Iptel] FW: [Enum] Summary on NoPSTN dicussion
>
>
>Mike wrote:
>
>z{x%^zm?0'~ffX)ß£

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 2 Apr 2004 04:01:19 +0200

I tried to work on you matrix:
Geo:          Y        N/A     N/A
PSTN:       Y        N/A     N/A
VoIP:         Y         Y         Y
ENUM:     opt-in  opt-in    only
 Case       1-2        3          4
 
but it does not help very much.
We are talking about requirements in Public User ENUM:
Must: if a number is in ENUM only, the client needs to know that is 
does not make sense to forward the call to the PSTN
 
We need to find a solution for this. IF this solutions allows also
to do additional things (depending on the solution found),
it would be nice to have:
-Indication that the number is not existing an the PSTN either (e.g unused number block)
-If the number is on VoIP (or PSTN), but not in ENUM, but can be reached via a "GW" on IP,
the domain name of the gateway where the number can be delivered via sip:[email-masked]
-If the number is on the PSTN, but ported, and the LNP is also accessible via IP (carrier 
ENUM) what is the root of the carrier ENUM (if publicly available). This may be tricky, if not.
 
But remember, these are nice to haves and need not to be solved, as long as the PSTN is there.
On the other hand, if we finally want VoIP to be selfcontaining and not rely on the PSTN, we have 
to find solutions for this 
 
Richard

	-----Ursprüngliche Nachricht----- 
	Von: Michael Hammer [mailto:[email-masked]] 
	Gesendet: Do 01.04.2004 17:58 
	An: Stastny Richard 
	Cc: James McEachern; [email-masked] 
	Betreff: Re: AW: AW: [Iptel] FW: [Enum] Summary on NoPSTN dicussion

	Richard,
	
	So, if I might summarize what you have said, there are four attributes that
	result in different combinations:
	
	Geographic or not?    Y         N       N
	Public (NP) or not?   Y        Y/N      ?  (row: NP/regulatory requirements)
	VoIP or not?         Y/N        Y       Y
	ENUM or not?       opt-in?   opt-in?    Y
	                    Case 1-2  Case 3   Case 4
	                                       (NP inherent)
	
	There are probably 16 combinations, of which many don't make sense or
	aren't used.  I was unclear about whether being an ENUM number allowed you
	to opt in or out, i.e. what does an unlisted ENUM number mean.  It would
	greatly simplify things, if there were few combinations.
	
	But, this all comes down to routing based on configuration, database, or
	both.  And for calls to reach someone, one or the other must exist, even if
	only on the calling party's  terminal.
	
	Mike
	
	>         additional 7-digits for 9.999.999 subscribers.

��i��X��X����'�~����i����
bz���j)fj��b��?z{�

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 2 Apr 2004 04:24:45 +0200

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_______________________________________________enum mailing [email-masked]://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 2 Apr 2004 04:32:27 +0200

Jim wrote:

	If the E.164 number has been assigned to a SP providing a PATS, then the PSTN will (must - because of opt-in) always know how to route to the appropriate SP, and the SP in turn knows how to route to the device. If the number is an ENUM only number, then the PSTN will need to know this (both the fact that it is a valid number so it does not reject it, and the fact that it is an ENUM-only number so that it can route it to an ENUM enabled GW). The PSTN will be able to determine this using existing routing & translation techniques - nothing more is required.

	So the entire problem comes down to how the VoIP network can recognize that a number is an "ENUM-only" number, and not route this to the PSTN if there is no ENUM entry. For all other cases routing to the PSTN works fine. This means that whatever solution we come up with, it is only necessary to apply it to ENUM-only numbers. (We *may* decide it is valuable to also apply it to other numbers, but if it complicates things this is not necessary.)

	Am I missing something? 

	>Richard:
	No, this is the prime requirement, all other things are nice to have. On the
	other hand, if we find a solution which is also automatically solving the
	other niceties, we caould use it for this also. I will try to sum up the proposed
	solutions next week, so we can decide on the best way forward.
	
	I talked to Rich Shockey today and the plan is to have a principal idea
	within the next weeks to have this written down for San Diego in time.

	Richard

	Jim 

	-----Original Message----- 
	From: Michael Hammer [mailto:[email-masked]] 
	Sent: Thursday, April 01, 2004 3:58 PM 
	To: Pfautz, Penn L, ALABS 
	Cc: Stastny Richard; McEachern, James [CAR:5N00:EXCH]; [email-masked] 
	Subject: RE: AW: [Iptel] FW: [Enum] Summary on NoPSTN dicussion 

	Mike

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 2 Apr 2004 04:37:23 +0200

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_______________________________________________enum mailing [email-masked]://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Hammer <[email-masked]>
Date: Fri, 02 Apr 2004 14:15:02 -0500

I think we are aligned, except for the bit about how a TDM switch "knows" 
that a number presented to it is ENUM-only.  Is this a special country or 
area/city code?

If so, then yes the call could be routed to the ENUM-enabled GW, which then 
could presumable fetch the user ENUM or carrier ENUM record, and route 
accordingly.

Then, I guess the only question is how every ENUM-only telephone number can 
match some ENUM record.  For that, I am not sure why two trees versus one 
is better or worse to traverse to find that record.  Perhaps the ENUM 
veterans could explain that.

Mike

At 01:55 PM 4/2/2004 -0500, James McEachern wrote:

>Comments inline
>From: Michael Hammer [<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Friday, April 02, 2004 10:15 AM
>
>Don't expect the PSTN to be reprogrammed to know it is an ENUM only
>number.  The switches will simply be configured to route to a particular GW
>because that is the "home switch" for that number.
>[Jim McE] This was essentially what I meant when I said the PSTN would 
>need to know it was an ENUM-only number.
>
>If a number originally
>belonged to a TDM switch and gets ported to the GW, then the NP database
>will indicate that.  Beyond that don't expect much.
>[Jim McE] Agreed - but unless I'm missing something, this would not apply 
>to ENUM-only numbers, as an ENUM-only number would never have originally 
>belonged to a TDM switch.
>
>Once the call is directed to that GW, it has two possibilities:
>1) it has configured information about that number,
>2) it can do an ENUM look up.
>Lacking both, that call gets released.
>
>If you have an ENUM-only number, then the GW needs to know which GW that
>number is homed to, and preferably route within the IP domain to that
>GW.
>[Jim McE] If you have an ENUM-only number, wouldn't the PSTN just route to 
>the nearest ENUM enabled GW where an ENUM dip would be done so the call 
>could be routed to the end device in the IP domain?
>
>This is where the carrier ENUM entry would help.
>
>If this ENUM-only belongs to a user (and not associated with a carrier?), I
>hope they have an entry in ENUM.  What does it mean to have an ENUM-only
>number and to not opt-in?
>[Jim McE] I've wondered about this one myself. Is it a valid scenario? 
>Should we worry about it?
>
>Either there is a GW with configuration
>information to do the further routing, or the call dies, i.e., is
>unreachable except for folks that know your IP address.  But then why have
>a E.164 number at all?  So, if you have an E.164 number assigned, you must
>have an ENUM entry, either pointing directly to your IP addresses, or to a
>carrier GW that can act on your behalf.
>
>Mike

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "James McEachern" <[email-masked]>
Date: Fri, 2 Apr 2004 13:55:53 -0500

Comments inline

-----Original Message-----
From: Michael Hammer [mailto:[email-masked]] 
Sent: Friday, April 02, 2004 10:15 AM

Don't expect the PSTN to be reprogrammed to know it is an ENUM only 
number.  The switches will simply be configured to route to a particular GW 
because that is the "home switch" for that number.  
[Jim McE] This was essentially what I meant when I said the PSTN would need
to know it was an ENUM-only number.

If a number originally 
belonged to a TDM switch and gets ported to the GW, then the NP database 
will indicate that.  Beyond that don't expect much.
[Jim McE] Agreed - but unless I'm missing something, this would not apply to
ENUM-only numbers, as an ENUM-only number would never have originally
belonged to a TDM switch.

Mike

---

From: Michael Hammer <[email-masked]>
Date: Thu, 01 Apr 2004 10:58:47 -0500

Richard,

Geographic or not?    Y         N       N

Mike

---

From: Michael Hammer <[email-masked]>
Date: Thu, 01 Apr 2004 15:57:53 -0500

Mike

---

From: Michael Hammer <[email-masked]>
Date: Fri, 02 Apr 2004 10:14:31 -0500

because that is the "home switch" for that number.  If a number originally 

If you have an ENUM-only number, then the GW needs to know which GW that 
number is homed to, and preferably route within the IP domain to that 
GW.  This is where the carrier ENUM entry would help.

number and to not opt-in?  Either there is a GW with configuration 

Mike

At 04:32 AM 4/2/2004 +0200, Stastny Richard wrote:
>Jim wrote:
>
>         If the E.164 number has been assigned to a SP providing a PATS, 
> then the PSTN will (must - because of opt-in) always know how to route to 
> the appropriate SP, and the SP in turn knows how to route to the device. 
> If the number is an ENUM only number, then the PSTN will need to know 
> this (both the fact that it is a valid number so it does not reject it, 
> and the fact that it is an ENUM-only number so that it can route it to an 
> ENUM enabled GW). The PSTN will be able to determine this using existing 
> routing & translation techniques - nothing more is required.
>
>         So the entire problem comes down to how the VoIP network can 
> recognize that a number is an "ENUM-only" number, and not route this to 
> the PSTN if there is no ENUM entry. For all other cases routing to the 
> PSTN works fine. This means that whatever solution we come up with, it is 
> only necessary to apply it to ENUM-only numbers. (We *may* decide it is 
> valuable to also apply it to other numbers, but if it complicates things 
> this is not necessary.)
>
>         Am I missing something?
>
>         >Richard:
>         >         >>First, no number is owner by anybody, it is assigned 
> by ITU-T
>         > to the NRA,
>         >         >>and assigned in turn to the SP, and the SP assignes 
> it to the
>         > end-user (for
>         >         >How does this work for numbers that were assigned to 
> an SP, that
>         > used to be
>         >         >very guarded about the E.164 numbers assigned to 
> them.  That is
>         > what I
>         >         >meant by "owned."  You are suggesting that when a 
> person with a
>         > phone
>         >         >number assigned by an SP moves to an IP-based "phone" 
> that the
>         > SP will
>         >         >relinquish that phone number back to the NRA?  Or are 
> you saying
>         > that
>         >         Case 1:  a VoIP provider is also an ILEC (eg a cable 
> operator)
>         > and gets a
>         >         number (geographic) range (block) assigned and assignes 
> them to
>         > his users.
>         >         Since number assignement is technology independent, 
> there is no
>         > problem here,
>         >         as long as the SP is providing a telephony service as 
> usual (we
>         > call this PATS -
>         >         Note: some VoIP SP hide between small ILECs and get 
> such number
>         > ranges
>         >         Case 2: Since all normal rules apply, also LNP applies, 
> so users
>         > may port
>         >         Case 3: The regulator reserves a special number range 
> for VoIP
>         > (050 in
>         >         Japan, 05x in UK, 032 in Germany). If these services 
> are declared
>         > non-PATS
>         >         NP does not apply (this is under discussion). In Japan 
> there is
>         > also a lighter
>         >         In this case the VoIP SP also get blocks of numbers and 
> route
>         > them to their GW.
>         >         I know, in the US there is no such number range. The 
> problem I
>         > have with
>         >         get restricted services. (e.g no NP, no access to 
> emergence
>         > services, etc.
>         >         that you have NP built-in, without having to deal with 
> normal LNP
>         > issues and
>         >         The difference between case 3 and 4 is that in case 3 
> no rules
>         > exist for NP and
>         >         the PSTN per default. If you interconnect on IP, you 
> can do this
>         > only currently
>         >         with bilateral agreements. In case 4 you have 
> automatically NP
>         > and also interconnect
>         >         because you can use ENUM also on IP to interconnect. 
> This is BTW
>         > also drafted
>         >         >>With ENUM-only numbers there is no need to assign 
> blocks of
>         > numbers.
>         >         >>An ENUM-only number is the equivalent of a domain 
> name. It is
>         > assigned
>         >         >>to the end-user directly, who chooses the SP, like 
> with a
>         > service number.
>         >         >I think there is an issue here.  If the SPs hold most 
> of the
>         > current NPA
>         >         >blocks, and there is a migration of many users from 
> TDM to IP,
>         > then do you
>         >         This a typical NANP problem. In the NANP there is only 
> geographic
>         > area
>         >         codes (with the exception of 800 numbers). In most 
> other country
>         > there are
>         >         Non-geo numbers are eg mobile numbers, personal 
> numbers, etc. The
>         > advantage
>         >         here is that you relieve the pressure on the number 
> exhaust here.
>         > Since geo
>         >         Eg in Austria the geo numbers are using up a great 
> chunk of the
>         > numbers:
>         >         used by 4,5 Mio subscribers (80% of them are behind 2 
> mobile
>         > "area" codes).
>         >
>         >         The reason is simple: the mobile number ranges are 
> flat. So if we
>         > give eg

---

From: "Stastny Richard" <[email-masked]>
Date: Sat, 3 Apr 2004 12:02:45 +0200

IA0KDQoJSWYgeW91IGhhdmUgYW4gRU5VTS1vbmx5IG51bWJlciwgdGhlbiB0aGUgR1cgbmVlZHMgdG8ga25vdyB3aGljaCBHVyB0aGF0IA0KCW51bWJlciBpcyBob21lZCB0bywgYW5kIHByZWZlcmFibHkgcm91dGUgd2l0aGluIHRoZSBJUCBkb21haW4gdG8gdGhhdCANCglHVy4gIA0KCVtKaW0gTWNFXSBJZiB5b3UgaGF2ZSBhbiBFTlVNLW9ubHkgbnVtYmVyLCB3b3VsZG4ndCB0aGUgUFNUTiBqdXN0IHJvdXRlIHRvIHRoZSBuZWFyZXN0IEVOVU0gZW5hYmxlZCBHVyB3aGVyZSBhbiBFTlVNIGRpcCB3b3VsZCBiZSBkb25lIHNvIHRoZSBjYWxsIGNvdWxkIGJlIHJvdXRlZCB0byB0aGUgZW5kIGRldmljZSBpbiB0aGUgSVAgZG9tYWluPyANCg0KCVtSaWNoYXJkXSBZZXMsIHRoZXJlIGlzIG5vIHN1Y2ggdGhpbmcgYXMgYSBob25lIEdXLg0KDQoJVGhpcyBpcyB3aGVyZSB0aGUgY2FycmllciBFTlVNIGVudHJ5IHdvdWxkIGhlbHAuIA0KDQoJSWYgdGhpcyBFTlVNLW9ubHkgYmVsb25ncyB0byBhIHVzZXIgKGFuZCBub3QgYXNzb2NpYXRlZCB3aXRoIGEgY2Fycmllcj8pLCBJIA0KCWhvcGUgdGhleSBoYXZlIGFuIGVudHJ5IGluIEVOVU0uICBXaGF0IGRvZXMgaXQgbWVhbiB0byBoYXZlIGFuIEVOVU0tb25seSANCgludW1iZXIgYW5kIHRvIG5vdCBvcHQtaW4/ICANCglbSmltIE1jRV0gSSd2ZSB3b25kZXJlZCBhYm91dCB0aGlzIG9uZSBteXNlbGYuIElzIGl0IGEgdmFsaWQgc2NlbmFyaW8/IFNob3VsZCB3ZSB3b3JyeSBhYm91dCBpdD8gDQoNCglbUmljaGFyZF0gVGhzaSBpcyBkZXBlbmRpbmcgb24gbmF0aW9uYWwgcmVndWxhdGlvbnMuIEkgcHJpbmNpcGxlIHlvdSBkbyBub3QgbmVlZCBhDQoJQ2FycmllciwganVzdCBhIFRpZXIgMiBuYW1lcyBzZXJ2ZXIgYW5kIGEgcmVnaXN0cmFyLg0KDQoJUmljaGFyZA0KCQ0KDQo=_______________________________________________enum mailing [email-masked]://www1.ietf.org/mailman/listinfo/enum

---

From: Michael Hammer <[email-masked]>
Date: Mon, 05 Apr 2004 11:47:49 -0400

Richard,

The effect of your statement below (no home GW) is that an ENUM-only number 
MUST be registered.  There is no opt-in.

Mike

At 12:02 PM 4/3/2004 +0200, Stastny Richard wrote:
>         [Jim McE] If you have an ENUM-only number, wouldn't the PSTN just 
> route to the nearest ENUM enabled GW where an ENUM dip would be done so 
> the call could be routed to the end device in the IP domain?
>
>         [Richard] Yes, there is no such thing as a hone GW.
>
>         [Jim McE] I've wondered about this one myself. Is it a valid 
> scenario? Should we worry about it?
>
>         [Richard] Thsi is depending on national regulations. I principle 
> you do not need a
>         Carrier, just a Tier 2 names server and a registrar.
>
>         Richard
>

---

From: "Stastny Richard" <[email-masked]>
Date: Tue, 6 Apr 2004 21:31:51 +0200

Jeff wrote
>This is not a good thing.  It is not because the security and privacy
>issues with "Registered Only" ENUM numbers is significant.

Please do not make such cryptic statements.
Could you please elaborate more in detail what the significant security/privacy
issue(s) is /are with ENUM-only numbers in your opinion?

Richard

§ºišŠX§‚X¬µéîš'~Šà†Ûi³ÿðÃ
bz×è®æj)fjåŠËb�ú?z{¦