Subject: Re: [Enum] 5 years since last message

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 2 Jul 2019 00:41:09 +0000

So what needs to happen here? Seems indisputable that there's not much happening on the ENUM front...

On 6/27/19, 9:48 AM, "enum on behalf of Olivier Guillard / AFNIC" <[email-masked] on behalf of [email-masked]> wrote:

    pong :-)
    
    le Tuesday 15 January à 13 H 17 , Jaap Akkerhuis a écrit :
    >  Bernie Hoeneisen writes:
    > 
    >  > Hi Jaap
    >  >
    >  > Well, there is a dependency on this list in RFC 6117...
    >  >
    >  > On the other hand, registering new ENUM services has not been that popular 
    >  > either for several years...
    >  >
    >  > cheers
    >  >   Bernie (Designated Expert of the IESG and other list maintainer)
    > 
    > In that case, it would make sense that you take over the maintaining
    > of this list as well. Would you? If so, let's arrange that off-list.
    > 
    > 	jaap
    > 
    > _______________________________________________
    > enum mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/enum
    
    -- 
    Olivier
    
    _______________________________________________
    enum mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/enum

---

From: "Patrik Fältström" <[email-masked]>
Date: Tue, 02 Jul 2019 07:43:52 +0200

Well, the standard is in use -- sort of -- with various modifications locally (like use of a different prefix than what is assigned here in IETF). I heard last time last week people "just saying" this is what is and should be used for routing of communication with E.164 numbers as destination in time of emergency/stress where centralized IN systems can not be reached (but locally cached DNS can).

So the list is silent, but there is some kind of usage. Does this "some kind of usage" imply something should be done?

I do not know.

I personally did conclude after the first couple of years of discussions that NAPTR is incredibly stupid. Designing things to have so large RRSets is not very optimal, so other DNS types would be better. I suggested the simple URI. But it itself got stuck in the IETF process of creation of new RRTypes, and when it finally was approved, the interest in deployment was sort of gone :-(

And people seems to have implemented NAPTR...

   Patrik

---

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 2 Jul 2019 10:17:58 +0200 (CEST)

I can confirm Patrik: ENUM standard is in use, somewhat, with variatians.
(We occasionally even get consultancy work assigned on ENUM deployments.)

What I normally see in the wild, I would certainly not call "Public User 
ENUM" (what we designed ENUM / RFC 6116 for). Most of the deployments are 
"Private Infrastructure ENUM", some are "Private User ENUM". I have not 
encountered any "Public User ENUM" nor "Public Intrastructure ENUM" for 
some time.

["Public" meaning the root is owned and/or governed by a public / official 
/ "higly-recognized" body, e.g. governmental, ICANN, ... ; "User" meaning 
Enduser has control over the content of the zone belonging to his own 
number (as oposed to "Infrastructure" where zone is controlled by a 
provider).]

I wonder whether my observations match with what others see in the wild.

The mailing list needs to remain open. There is a mention in RFC 6117 
of this list as the central place to discuss new Enumservices.

Have a nice summer and c.u. (or at least some of u) in Montreal!

cheers,
  Bernie (another former ENUM co-chair)

--

http://ucom.ch/
Modern Telephony Solutions and Tech Consulting for Internet Technology

On Tue, 2 Jul 2019, Patrik Fältström wrote:

> Well, the standard is in use -- sort of -- with various modifications 
> locally (like use of a different prefix than what is assigned here in 
> IETF). I heard last time last week people "just saying" this is what is 
> and should be used for routing of communication with E.164 numbers as 
> destination in time of emergency/stress where centralized IN systems can 
> not be reached (but locally cached DNS can).
>
> So the list is silent, but there is some kind of usage. Does this "some 
> kind of usage" imply something should be done?
>
> I do not know.
>

---

From: Carsten Schiefner <[email-masked]>
Date: Tue, 2 Jul 2019 16:26:12 +0200

Bernie, all -

On 02.07.2019 10:17, Bernie Hoeneisen wrote:
> [...] I have
> not encountered any "Public User ENUM" nor "Public Intrastructure ENUM"
> for some time.

certainly no new ones, indeed.

But how about:

	https://nrenum.net/

?

It does not fully match your definition:

> ["Public" meaning the root is owned and/or governed by a public /
> official / "higly-recognized" body, e.g. governmental, ICANN, ... ;
> "User" meaning Enduser has control over the content of the zone
> belonging to his own number (as oposed to "Infrastructure" where zone is
> controlled by a provider).]

of "public", though...

> Have a nice summer and c.u. (or at least some of u) in Montreal!

Thanks - same for you and all others here on the list!

Best,

	-C.

---

From: Arash Farshid <[email-masked]>
Date: Tue, 2 Jul 2019 11:20:32 -0400

Please remove my email address, your emails don’t relate to me!

Sent from my iPhone

> On Jul 2, 2019, at 10:26 AM, Carsten Schiefner <[email-masked]> wrote:
> 
> Bernie, all -
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 2 Jul 2019 15:24:28 +0000

Arash - All you need to do is visit https://www.ietf.org/mailman/listinfo/enum and unsubscribe (form field near the bottom). 

On 7/2/19, 11:21 AM, "enum on behalf of Arash Farshid" <[email-masked] on behalf of [email-masked]> wrote:

    Sent from my iPhone

---

From: Richard Shockey <[email-masked]>
Date: Tue, 02 Jul 2019 13:12:45 -0400

Well its still a big deal to the US Government. Its central to the FCC's system for providing telecommunications services for the hearing impaired.  The iTRS database still run by NeuStar BTW.  It's also used in modern SIP/IMS  internal IP Interconnection schemes at multiple carriers in place of old TDM SCP's  .  The FCC North American Numbering Council ( on which I sit)  is thinking about revisiting the issue to enhance and deploy Video Calling <sigh>. 

https://www.fcc.gov/document/itrs-numbering-report-and-order

https://www.fcc.gov/fcc-acts-improve-video-relay-service-and-direct-video-calling

We took a stab at revisiting Public ENUM in the US about 5 years ago to no consensus. 

https://www.sipforum.org/2015/07/atis-and-sip-forum-complete-new-ip-based-network-to-network-interface-nni-technical-specification/

It still pops up from time to time. Recently in relation to all IP Interconnection driven by STIR/SHAKEN mandates in the US to combat robocalls and caller ID spoofing.   I had a nightmare one night a couple of months ago that someone wanted me to restart the ENUM WG to enable 6116 over HTTPS.   Now if you think that would be a nightmare ..well the British are actively considering Distributed Ledger Technology aka Hyperledger to accomplish the ENUM like functions.

https://www.ofcom.org.uk/about-ofcom/latest/features-and-news/blockchain-technology-uk-telephone-numbers

— 
Richard Shockey

Shockey Consulting LLC

Chairman of the Board SIP Forum

www.shockey.us

www.sipforum.org

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

On 7/2/19, 1:43 AM, "enum on behalf of Patrik Fältström" <[email-masked] on behalf of paf=[email-masked]> wrote:

    
    I do not know.

    
       Patrik

---

From: Claudio Allocchio <[email-masked]>
Date: Tue, 2 Jul 2019 21:26:30 +0200 (CEST)

well...

at GARR we just had a misconfiguration problem during a hardware 
migration for enum related services... and we got the help desk email 
and phone immediately receiving complaints from users unable to "dial" in 
services... (even if some of us was just thinking that there was nobody 
using it anymore).

so... yes, still a useful service !

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

      PGP Key: https://www.cert.garr.it/servizi/informazioni-su-pgp-keys