Subject: Re: [Enum] Working Group Last Call on enumservices guide 12

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 3 Oct 2008 13:48:42 -0400

Bernie & Rich -

I can take another turn of the document to handle this.

Jason 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Tuesday, September 30, 2008 2:54 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [Enum] Working Group Last Call on enumservices guide 12
> 
> Hi Rich
> 
> We'll certainly consider Peter's feedback and issue a revision -13.
> 
> As I expressed in Dublin, Swisscom is not supporting me for 
> this work any longer, so I'll have to do it all in my 
> freetime. (And freetime is precious at the moment as there is 
> also all my NomCom work to be done in my freetime.) Therefore 
> it might take a while.
> 
> I hope we can issue -13 soon, but unfortunately these are my 
> boundary conditions...
> 
> cheers,
>  Bernie
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Richard Shockey
> Sent: Tuesday, September 30, 2008 7:14 PM
> To: 'Peter Koch'; 'IETF ENUM WG'
> Subject: Re: [Enum] Working Group Last Call on enumservices guide 12
> 
> [...]
> 
> In any event WGLC is now over. I'm wondering if the authors 
> want to incorporate any of Peter's suggestions into a 13 
> version before the chairs request publication.
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/enum
> 
_______________________________________________
enum mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/enum

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 3 Oct 2008 15:52:10 -0400

Works for the chairs... we'll request publication as soon as a 13 crosses
the wire.

We're trying to clear the queue.

>  From: Livingood, Jason [mailto:[email-masked]]
>  Sent: Friday, October 03, 2008 1:49 PM
>  To: [email-masked]; [email-masked]; [email-masked]
>  Cc: Alexander Mayrhofer
>  Subject: RE: [Enum] Working Group Last Call on enumservices guide 12
>  
>  Bernie & Rich -
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 3 Oct 2008 18:28:28 -0400

I just sent my revision to Alex and Bernie and I sent one open question to you, Rich, that we may need help with.

Also, I have one open question with my co-authors on whether to drop the XML Template Appendix or not.

Depending upon the outcome of each of these questions, a quick revision can be made next week and we'll submit the -13 then.

Regards
Jason

> From: Richard Shockey [mailto:[email-masked]] 
> Sent: Friday, October 03, 2008 3:52 PM
> To: Livingood, Jason; [email-masked]; [email-masked]
> Cc: 'Alexander Mayrhofer'; 'Patrik Fältström'
> Works for the chairs... we'll request publication as soon as 
> a 13 crosses the wire.
> 
> >  > From: [email-masked] [mailto:[email-masked]] On  > 
> > Behalf Of [email-masked]  > Sent: Tuesday, 
> September 
> > 30, 2008 2:54 PM  > To: [email-masked]; [email-masked]  
> > Subject: 
> > Re: [Enum] Working Group Last Call on enumservices guide 12 
>  >  > Hi 
> > Rich  >  > We'll certainly consider Peter's feedback and issue a 
> > revision -13.
> >  >
> >  > As I expressed in Dublin, Swisscom is not supporting me 
> for  > this 
> > work any longer, so I'll have to do it all in my  > freetime. (And 
> > freetime is precious at the moment as there is  > also all 
> my NomCom 
> > work to be done in my freetime.) Therefore  > it might take a while.
> >  >
> >  > I hope we can issue -13 soon, but unfortunately these are my  > 
> > boundary conditions...
> >  >
> >  > cheers,
> >  >  Bernie
> >  >
> >  >
> >  > From: [email-masked] [mailto:[email-masked]] On  > 
> > Behalf Of Richard Shockey  > Sent: Tuesday, September 30, 
> 2008 7:14 PM  
> >  > Subject: Re: [Enum] Working Group Last Call on 
> enumservices guide 
> > 12  >  > [...]  >  > In any event WGLC is now over. I'm 
> wondering if 
> > the authors  > want to incorporate any of Peter's 
> suggestions into a 
> > 13  > version before the chairs request publication.

---

From: Peter Koch <[email-masked]>
Date: Mon, 6 Oct 2008 19:59:38 +0200

On Fri, Oct 03, 2008 at 06:23:35PM -0400, Livingood, Jason wrote:

{this is a reply to a private response to my WGLC comments, quoted with
permission}

> > Regarding Terminology, the draft mixes "Registration", 
> > "Registration Template"
> > and "Registration Document", where I'd suggest the following 
> > distinctions to be consistently applied:
> > 
> >   "Registration" is what is entered into the Registry after 
> > an application has
> >           been approved.
> >   "Registration Template" is the multiline template given in 
> > section 11.
> >   "Enumservice Specification" is what the applicant uses to 
> > specify the
> >           actual data. In fact, the Registration Template 
> > should be copied into
> >           the specification document, as it is today.
> >           I'd suggest to completely drop the term 
> > "Registration Document".
> 
> I am not sure I agree.  We carefully considered all of these terms and
> some cannot be dropped due to cross-references with other documents.  If
> you can point on specific places in the I-D where the term is applied
> inconsistently or incorrectly, we appreciate the feedback asap.

The introduction says:

   For the purpose of this document, 'Registration Document' and
   'Registration' refer to a specification that defines an Enumservice
   and proposes its registration following the procedures outlined
   herein.

and thus makes "Registration" and "Registration Document" synonyms,
while actually stating that both denominate the Enumservice specification.
I'm not sure what cross-reference you have in mind, but neither RFC 5226
or RFC3761 nor the -bis draft use this term and it doesn't really sound
familiar in an IETF context to me.  With the terminology above I've tried
to follow the development and registration procedure in a, what I think, closer
fashion:

  You come up with an idea for an Enumservice and write the specification.
  This document is then used as a reference in the application form
  (aka "Registration Template") and the registration is actually the
  assignment of the codepoint or part of the namespace (as per RFC 5226,
  section 1), i.e., "what goes into the registry".

Apologies if I've managed to exhaust the WG on these process and terminology
issues, but I believe that the current wording is ambiguous and could
confuse or mislead potential "users".

Looking at specific examples, without any claim to completeness, have a
look at section 3:

>    All Enumservice Registration proposals are expected to conform also
>    to various requirements laid out in the following sections.
> 
> 3.1.  Functionality Requirements
> 
>    A registered Enumservice must be able to function as a selection
>    mechanism when choosing one NAPTR resource record from another.  That
>    means that the Registration MUST specify what is expected when using

"Enumservice Registration proposals" doesn't match the predefined
terminology and "the Registration MUST specify ..." suggests that the
content of the registry will have to compy, where its clearly the
specification that will be evaluated against this list of criteria.

-Peter