Subject: Re:[Enum] Response codes and multiple paths to a destination

From: "JoonHyung Lim" <[email-masked]>
Date: Thu, 15 Mar 2007 01:18:01 +0900

Hi,

I also agree that this work has a lot of exceptional conditions when it implements on real world practically. But I believe that this consideration is very worthy for early implementor who wants to add ENUM on existing system.

> The problem is that when a dialog routed using ENUM fails,
> what the proxy does next needs to depend on how the dialog
> failed.  If it failed with a Busy, Declined, or Ring No
> Answer status (that is, the call reached the UA and then
> failed), no attempt should be made using the PSTN.  But if
> the dialog failed before reaching the UA, the dialog should
> attempt to connect using the PSTN.

In this situation, If I understand it correctly, proxy already has a SIP URI from ENUM(it means Rcode=0), but it can't terminate the call by several reason.

So, here is my question.
 
If a call failed before reaching UA,  does the proxy have to send a call to PSTN? What happen if such a call must fail? IMHO, If proxy can't reach to UA using SIP URI through IP network, it is also hardly  to terminate a call through PSTN. If I'm wrong let me know...

Actually we didn't much care about this issue on our ENUM softswitch trial in 2006,  because PSTN could be used only when "Rcode=3(NXDOMAIN)"

JoonHyung Lim, NIDA

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: [email-masked]
Date: Wed, 14 Mar 2007 22:00:36 -0500

From: "JoonHyung Lim" <[email-masked]>

   If a call failed before reaching UA,  does the proxy have to send a
   call to PSTN?

It is not a requirement of ENUM that if an attempt using SIP fails,
then the call must be routed through the PSTN.  But many of our
customers would like that behavior.

Dale