Subject: RE: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt

From: "Yu, James" <[email-masked]>
Date: Thu, 22 Feb 2007 13:04:52 -0500

Steve,

Yes but this I-D is not just for voice (e.g., could be for messaging
services such as SMS, MMS and IM).

A mobile operator may include this specific NAPTR RR to contain the IMSI
or MCC+MNC information in Carrier/Operator/Infrastructure ENUM
environment.  It can also be used in private ENUM offering before
Carrier/Operator/ Infrastructure ENUM is deployed.

James

-----Original Message-----
From: LIND, STEVEN D, ATTLABS [mailto:[email-masked]] 
Sent: Thursday, February 22, 2007 12:48 PM
To: Yu, James; Stastny Richard
Cc: IETF ENUM WG
Subject: RE: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt

It is my understanding that MCC and MNC are used _between_ mobile
service providers when subscribers are roaming to ensure that
operational agreements exist that allow service to be extended to that
subscriber in the visited network. Calls are completed based on the
E.164 number dialed.

There is a lot of sensitivity over more public use of these data items.

Steve

--------------------------------------------------------
Steven D. Lind, AT&T            Tel: 973-236-6787
180 Park Avenue, Rm. A201       Fax: 360-343-2875
Florham Park, NJ 07932          e-mail: [email-masked]
--------------------------------------------------------

> -----Original Message-----
> From: Yu, James [mailto:[email-masked]] 
> Sent: Thursday, February 22, 2007 12:08 PM
> To: Stastny Richard; LIND, STEVEN D, ATTLABS
> Cc: IETF ENUM WG
> Subject: RE: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt
> 
> Richard, Steve,
> 
> This is to allow the IMSI or MCC+MNC information to be returned in a
> specific NAPTR RR in the ENUM response.  This NAPTR RR can be the only
> one returned in the ENUM response or can be returned with other NAPTR
> RRs.   Mobile operators use MCC+MNC for settlement so the MCC+MNC
> returned in "mcc" and "mnc" parameters or derived from "imsi" can be
> used to identify the "terminating" mobile operator and included in the
> CDR when needed.   Certainly the domain names in the URIs can also be
> used to identify the operators but "MCC+MNC" is widely used. 
> 
> James
> 
> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]] 
> Sent: Wednesday, February 21, 2007 5:14 AM
> To: LIND, STEVEN D, ATTLABS; IETF ENUM WG
> Subject: RE: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt
> 
> Same for me
> 
> I may understand adding the IMSI parameters to the tel: URI in
> draft-lewis-enum-teluri-e212, especially using mcc and mnc as kind
> of SPID
> 
> What I do not understand is purpose of the enumservice "e212"
> Can one explain, please?
> 
> Richard
> 
> > -----Original Message-----
> > From: LIND, STEVEN D, ATTLABS [mailto:[email-masked]]
> > Sent: Tuesday, February 20, 2007 10:44 PM
> > To: [email-masked]; IETF ENUM WG
> > Subject: RE: [Enum] FW: I-D 
> ACTION:draft-lewis-enum-teluri-e212-00.txt
> > 
> > I find it curious that this and the companion enumservice 
> I-D did not
> > originate from a wireless service provider. It's not clear 
> to me that
> > the I-Ds adequately explain the reason for including this 
> information
> > for terminating calls. I'd like to understand more on how such
> > information would be used.
> > 
> > Steve
> > 
> > --------------------------------------------------------
> > Steven D. Lind, AT&T            Tel: 973-236-6787
> > 180 Park Avenue, Rm. A201       Fax: 360-343-2875
> > Florham Park, NJ 07932          e-mail: [email-masked]
> > --------------------------------------------------------
> > 
> > 
> > > -----Original Message-----
> > > From: Richard Shockey [mailto:[email-masked]]
> > > Sent: Tuesday, February 20, 2007 4:09 PM
> > > To: 'IETF ENUM WG'
> > > Subject: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]
> > > > Sent: Tuesday, February 20, 2007 3:50 PM
> > > > To: [email-masked]
> > > > Subject: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt
> > > >
> > > > A New Internet-Draft is available from the on-line 
> Internet-Drafts
> > > > directories.
> > > >
> > > >
> > > > 	Title		: E.212 Parameters for the "tel" URI
> > > > 	Author(s)	: E. Lewis
> > > > 	Filename	: draft-lewis-enum-teluri-e212-00.txt
> > > > 	Pages		:
> > > > 	Date		: 2007-2-20
> > > >
> > > > Parameters are defined in the "tel" Uniform Resource
> > > Identifier (URI)
> > > > to carry ITU E.212-related information.
> > > >
> > > >
> > > > A URL for this Internet-Draft is:
> > > >
> > > http://www.ietf.org/internet-drafts/draft-lewis-enum-teluri-e2
> > > 12-00.txt
> > > >
> > > > To remove yourself from the I-D Announcement list, send 
> a message
> to
> > > > [email-masked] with the word unsubscribe in
> > > the body of
> > > > the message.
> > > > You can also visit
> > > https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > > to change your subscription settings.
> > > >
> > > > Internet-Drafts are also available by anonymous FTP. Login with
> the
> > > > username "anonymous" and a password of your e-mail 
> address. After
> > > > logging in, type "cd internet-drafts" and then
> > > > "get draft-lewis-enum-teluri-e212-00.txt".
> > > >
> > > > A list of Internet-Drafts directories can be found in
> > > > http://www.ietf.org/shadow.html
> > > > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > > >
> > > > Internet-Drafts can also be obtained by e-mail.
> > > >
> > > > Send a message to:
> > > > 	[email-masked].
> > > > In the body type:
> > > > 	"FILE 
> /internet-drafts/draft-lewis-enum-teluri-e212-00.txt".
> > > >
> > > > NOTE:	The mail server at ietf.org can return the document in
> > > > 	MIME-encoded form by using the "mpack" utility. 
>  To use this
> > > > 	feature, insert the command "ENCODING mime" 
> before the "FILE"
> > > > 	command.  To decode the response(s), you will 
> need "munpack" or
> > > > 	a MIME-compliant mail reader.  Different MIME-compliant
> > > mail readers
> > > > 	exhibit different behavior, especially when dealing with
> > > > 	"multipart" MIME messages (i.e. documents which 
> have been split
> > > > 	up into multiple messages), so check your local 
> documentation on
> > > > 	how to manipulate these messages.
> > > >
> > > > Below is the data which will enable a MIME compliant mail reader
> > > > implementation to automatically retrieve the ASCII 
> version of the
> > > > Internet-Draft.
> > >
> > 
> > _______________________________________________
> > enum mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/enum
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 23 Feb 2007 09:38:51 +0100

Hi James,

I still do not see the need (in current mobile practice)
for the usage of the IMSI of the B-subscriber derived from
the E.164 number in call-set-up

The IMSI (and the Private User Identity in IMS) is only
used during registration from the A-subscriber and the
A subscriber knows his IMSI (or Private UID) anyway.

And there are rules in 3GPP to derive a realm from MCC+MNC

Richard

> Sent: Thursday, February 22, 2007 7:05 PM
> To: LIND, STEVEN D, ATTLABS
> Cc: IETF ENUM WG
> > > > Subject: [Enum] FW: I-D

---

From: lconroy <[email-masked]>
Date: Fri, 23 Feb 2007 10:19:05 +0000

Hi Richard, folks,
  It must be me. Just because one can look up the A party number to
help route a call doesn't mean that's the only thing one can query.
It seems reasonable for entities to be able to query ENUM-like
systems for data tied to *any* 'phone number for any reason - not
just to route a call.

Why can't one look up the A party number in an ENUM-like system -
what am I missing?

all the best,
   Lawrence

---

From: Otmar Lendl <[email-masked]>
Date: Fri, 23 Feb 2007 11:44:48 +0100

> the E.164 number in call-set-up

I agree in the sense that the full IMSI is seldom needed, whereas the
MCC+MNC information can be very valuable.  As the draft just adds the
option to specify any subset of MCC/MNC/IMSI, there is no downside to
including the IMSI parameter in the spec.

There are a number of possible applications for I-ENUM with
MCC+MNC information in numbers:

* Mobile number portability in the PSTN

  SS7 routing information (e.g. routing-numbers) can be derived
  from B-Number + MCC + MNC.

* Charging

  If different mobile carriers charge different termination fees (and
  thus end-users are charged different prices), then any fixed line
  carrier which does not partake in MNP can use that information as
  input to its mediation system.

* Enterprise mobile gateways

  If public I-ENUM is used, then enterprise PBXs with direct gateways
  to mobile operators can select the right mobile network even
  if the number was ported.

> And there are rules in 3GPP to derive a realm from MCC+MNC

Yes, but that's only relevant if you want to do NGN stuff in
the GRX. See above for uses in a non-IMS and non-VoIP environment.

/ol
-- 
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 23 Feb 2007 12:01:06 +0100

Thanks for this helpful information

Richard

> From: Otmar Lendl [mailto:[email-masked]]
> Sent: Friday, February 23, 2007 11:45 AM
> To: [email-masked]
> Subject: Re: [Enum] FW: I-D ACTION:draft-lewis-enum-teluri-e212-00.txt
>

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 23 Feb 2007 12:03:44 +0100

You mean the B-Party is looking up the A-Party
to ROUTE the call?

Now I must be missing something ;-)

Richard

> From: lconroy [mailto:[email-masked]]
> Sent: Friday, February 23, 2007 11:19 AM
> To: Stastny Richard
> Cc: Yu, James; LIND, STEVEN D, ATTLABS; IETF ENUM WG

---

From: lconroy <[email-masked]>
Date: Fri, 23 Feb 2007 12:40:44 +0000

Hi Richard, folks,
  With IMS, who can tell?
Maybe they do, plus the phone number of your second aunt. I lost
track after the 25th message flow of the roaming scenarios.
Repeat after me - routing is not everything 9-)p
all the best,
   Lawrence