Subject: Re: [Enum] draft-ietf-enum-unused-00.txt

From: "Lupton, Ronan" <[email-masked]>
Date: Wed, 17 Jan 2007 10:02:54 -0000

Richard,

DDI being suffix to national numbering schema expected rather than the old
telco PABX DDI as many know it!

There is no escape from this in Austria, Germany and perhaps one other
country.

Ronan

-----Original Message-----
From: Stastny Richard <[email-masked]>
To: Clive D.W. Feather <[email-masked]>; [email-masked]
<[email-masked]>
CC: [email-masked] <[email-masked]>
Sent: Wed Jan 17 09:41:56 2007
Subject: RE: [Enum] draft-ietf-enum-unused-00.txt

Thank you Clive, you answered all the questions already

One more clarification to your last reply:

> > There is also the question of how this infrastructure interacts with
> > number portability, which leads to situations where any given range
of
> > numbers is likely to be a mosaic of assignments to different
carriers.
> 
> Do you mean open plans, or in general? I can't speak to open plans,
but at
> least in the UK portability is unrelated to number length.

In open numbering plans everything may be variable:

If one looks at the Figure B.1/E.164 - Addressing by an ISDN Number
in Rec. E.164 Annex B.3.2, the N(S)N part of an E.164 number is
divided in the NDC (Network Destination Code) and the SN (Subscriber
Number)

The SN is further divided in a Partial Number and what?

The reminder of the SN is not named, we in Austria call it
Pilot Number.

The Partial Numbers are used for DDI (Direct Dialling In)

>From this figure one can derive the following:

A full E.164 number is the Pilot Number + the Partial Number

In closed numbering plans the SN is fixed, so the fixed length
includes the Pilot Number + the Partial Number.

In open numbering plans such as in Austria (and Germany) both
the Pilot Number and the Partial Number can be variable length

The numbering ordinance from the regulator defines the length
of the Pilot Number and is very complicated:

The NDC is between 1 and 4 digits

A Pilot Number is 5 digits
EXCEPT:
In NDCs 316, 463, 512, 662, 732, 2236, 2252, 5572 and 7242 
6 digits
in NDC 1 it is 7 digits

On request you may get more digits, up to 13 digits
in NDC 1, in all other NDC up to 14 digits (including CC)

Companies may also get shorter numbers, depending
on size of company (UNI) -1 or -2 digits

All this rules are only for Pilot numbers and
for Carriers
Any subscriber may add Partial Numbers behind the
Pilot Number (this was something we had to take over
from the old analog system)
The Operator (Carrier) does not know about the length
and structure of the Partial Numbers (= private number plan)

It is recommended the whole E.164 does not exceed
14 digits to make the number reachable internationally

Now to Number Portability (NP):

Only Pilot Numbers are portable. One cannot
port his company number with DDI to another
after retirement or leaving the company.

Additional Information:

Assume the Vienna E.164 Number +43 1 2345678-222

*43 is the CC
1 is the NDC
2345678-222 is the SN
+43 1 2345678 is the Pilot Number (portable)
222 is the Partial Number (DDI)
(Note: there may exist also an E.164
+43 1 2345678-3333

To reach the switchboard, you may dial
+43 1 2345678-0
BUT, you may also dial
+43 1 2345678

The call is terminated at the PBX and after
a time-out you fall back to the switch-board

You also fall back to the switchboard if
you under-dial or dial a non-existent partial number

All this makes a lot of fun with ENUM

Regards
Richard

> -----Original Message-----
> From: Clive D.W. Feather [mailto:[email-masked]]
> Sent: Wednesday, January 17, 2007 9:37 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Enum] draft-ietf-enum-unused-00.txt
> 
> [email-masked] said:
> >    7.2.1.  Closed Numbering Plans
> >
> >    In many countries closed numbering plans are in use.  In such a
> >    scheme, all valid telephone numbers have a defined length - the
> >    number of digits used for the subscriber number is fixed.  Thus,
for
> >    a given initial digit string, the length of the subsequent digit
> >    string together constituting a valid telephone number is known.
All
> >    other digit strings are invalid.
> >
> > As I read this, it means that all E.164 nubmers for a particular
> > country have the same length.
> 
> No. It says that the first N digits (for some value of N which may
depend
> on the number) tells you how long the number is.
> 
> For example, in the UK, +442 or +447 tells you there is another 9
digits
> to come, but +441 or +448 doesn't - the length depends on more digits.
> 
> > E.g., in North America, a subscriber
> > number is 10 digits (or 11 if you count the country code).
> 
> Apparently not. I am told that numbers beginning +109 are a digit
longer.
> 
> >    For example, for the initial digit string "+44160649", the
subsequent
> >    number string is three digits in length.  However, for the
initial
> >    digit string "+44160650", the subsequent string is four digits in
> >    length.
> >
> > At this point, I have a problem.  If one adds three digits to
> > "44160649" to make a number, then numbers have 11 digits.  But if
one
> > adds four digits to "44160650", then numbers have 8 digits.
> 
> 12 digits, you mean.
> 
> > As far as I can tell, the solution to this contradiction is that
> > "subscriber number" refers to the digits that are after the block
> > prefix, and "initial digit string" refers to the digits that compose
> > the block prefix.
> 
> Right. The meaning of "block" varies - in the UK, the longest such is
(I
> think) +44845464N, where there are no subsequent digits if N is 7 but
2
> otherwise.
> 
> > In section 7.2.2, the draft says "The only restriction is that all
> > these initial digit patterns representing telephone numbers are
> > unique."  I think this means "The only restriction is that no
assigned
> > telephone number may be a prefix of another."
> 
> Right.
> 
> > As far as I can tell from 7.2.2.1, under an open number plan, some
> > customers can be assigned prefixes, and the customer can select how
> > many digits are allowed after the prefix, and which of those sets of
> > digits are valid numbers.
> 
> Not just that: the customer can select which suffices are valid *and
these
> can be different lengths*. In other words, if I am allocated +99923456
> (I use +999 because I don't know of a valid example) I can decide that
> the valid numbers are:
> 
>   +999 23456 0
>   +999 23456 1x
>   +999 23456 2xxx
>   +999 23456 4xx
> 
> > There is also the question of how this infrastructure interacts with
> > number portability, which leads to situations where any given range
of
> > numbers is likely to be a mosaic of assignments to different
carriers.
> 
> Do you mean open plans, or in general? I can't speak to open plans,
but at
> least in the UK portability is unrelated to number length.
> 
> --
> Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495
> 6138
> Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051
> 9937
> Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973
377646
> THUS plc            |                            |
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 17 Jan 2007 11:08:16 +0100

Ronan,

>DDI being suffix to national numbering schema expected rather than the
old >telco PABX DDI as many know it! 

I do not really understand what you want to say

>There is no escape from this in Austria, Germany and perhaps one other

Do you mean Austria has to change this?

No plans yet

Richard