Subject: RE: [Enum] void-02 new version

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 8 Nov 2006 00:02:21 -0500

> >unallocated (not existent)
> 
> >unassigned (not existent)
> 
> >inactive (inactive -= out-of-service- barred - etc)

I still don't understand how the inactive use case differs...

J

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: lconroy <[email-masked]>
Date: Wed, 8 Nov 2006 08:27:58 +0000

Hi Jason, folks,
  This is exactly one of my issues. As Jason says below, these first
two cases seem to differ in who is controlling the zone.

"Unallocated" means the NRA still controls the zone (as then have not
put a TN in service).

In the "Unassigned" case, the SP controls the zone (as the SP has not
put a TN into service).

This last "Inactive" case seems to imply this as well, but only makes
sense if it takes a long time to make a TN active. Otherwise why bother
provisioning this status?

Who/What controls the zone may be important information.

all the best,
   Lawrence

On 8 Nov 2006, at 05:02, Livingood, Jason wrote:
>> PLEASE PLEASE... I think we had consensus here. The initial
>> use case for this ID surrounds 3 conditions as Richard noted.
>>
> Well, hold on just a second.  I thought we had consensus on the first
> two use cases.  Where did the 3rd one above come from?  Can someone
> please describe the specific use case and how that is noticeably
> different from the first two?  In the first the NRA has not put a  
> TN in
> service, and in the second the SP has not done so.  So in the third,
> what party are we talking about?

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 8 Nov 2006 15:57:37 +0100

>Who/What controls the zone may be important information.

maybe, but not for the originator during the call
 
Richard

________________________________

Von: lconroy [mailto:[email-masked]]
Gesendet: Mi 08.11.2006 09:27
An: Livingood, Jason
Cc: [email-masked]; Otmar Lendl; [email-masked]; Stastny Richard
Betreff: Re: [Enum] void-02 new version

Hi Jason, folks,

all the best,
   Lawrence

---

From: lconroy <[email-masked]>
Date: Wed, 8 Nov 2006 15:12:50 +0000

Hi Richard, folks,
  Absolutely agree that it doesn't matter to the originator.
But if the real difference between these two cases is whether the NRA  
or the SP
controls the zone and provisions the Vacant/Void/Status/... NAPTR,  
then why do
we need both Unallocated and Unassigned?
How does this make a difference to the originating ENUM client?

all the best,
   Lawrence

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 8 Nov 2006 16:22:55 +0100

that why I proposed to use vacant/void/status as ENUMservice
and put the rest in the text/data

The originator does not need to look in the URI during call setup
(as it was with void), he simple stops the call

Richard

Von: lconroy [mailto:[email-masked]]
Gesendet: Mi 08.11.2006 16:12
An: Stastny Richard
Cc: Livingood, Jason; [email-masked]; Otmar Lendl; [email-masked]
Betreff: Re: [Enum] void-02 new version

Hi Richard, folks,

all the best,
   Lawrence

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 8 Nov 2006 19:59:05 +0100

>What happens when a number is changed?  On the PSTN, 
>the Caller would be given an intercept message like
>"The number have have dialled <X> has been changed.  
>The new number is <y>".  
>personally, I'd like to have this scenario result in an origination
>feature that updates my address book.
>Should this be in scope for the status indication?

we should not overload void/status/etc
with this issues - they may be handled with normal enumservices
(such as announcement)
 
I am starting to get problems with the new name status, because
it seems to open up another can-of-worms of interpretations
 
what about "unused" for both unallocated and unassigned
that narrows the used better than status
 
Richard

Von: Ed Guy [mailto:[email-masked]]
Gesendet: Mi 08.11.2006 19:43
An: Stastny Richard
Cc: lconroy; [email-masked]; Otmar Lendl; Livingood, Jason; [email-masked]
Betreff: Re: [Enum] void-02 new version

On the void/status indications, the originator needs to stop
the call in all of these cases, but the issue is 
"what indication to they give to the calling party?"

On unassigned vs unallocated:
If a well-formed number has not yet been allocated by the NRA or 
assigned by one of its delegates,  the handling might be the same.   
Why is the national regulator special?  any domain may be delegated.
(so, two designations are not needed) 

on Out of service:
If the services associated with a number is out of order, there is an 
opportunity to push this status to the originating side, foregoing 
SIP timeouts. the  TTL would need to be very short. 

We should consider what happens in open dialing plans 
where a dialled number may be too short. 
(it's possible I missed this discussion in this email chain).

and also, 

What happens when a number is changed?  On the PSTN, 
the Caller would be given an intercept message like
"The number have have dialled <X> has been changed.  
The new number is <y>".  
personally, I'd like to have this scenario result in an origination
feature that updates my address book.
Should this be in scope for the status indication?

/ed

On Wed, 2006-11-08 at 16:22 +0100, Stastny Richard wrote: 

	
	Richard

	
	Hi Richard, folks,
	
	all the best,
	   Lawrence

---

From: "Nieminen Klaus" <[email-masked]>
Date: Wed, 8 Nov 2006 21:04:18 +0200

I like the idea of narrowing the scope and name of the enumservice. Name unused is much better than status (don't want this to be a presence service :).
 
- klaus

Lähettäjä: Stastny Richard [mailto:[email-masked]]
Lähetetty: ke 8.11.2006 20:59
Vastaanottaja: Ed Guy
Kopio: [email-masked]; Livingood, Jason; lconroy; Otmar Lendl; [email-masked]
Aihe: Re: [Enum] void-02 new version - new name: unused

Richard

---

From: Ed Guy <[email-masked]>
Date: Wed, 08 Nov 2006 13:43:32 -0500

on Out of service:

and also, 

/ed

---

From: Niall O'Reilly <[email-masked]>
Date: Thu, 09 Nov 2006 14:18:41 +0000

> SIP timeouts. the  TTL would need to be very short.

AFAICS, this would be a per-service (rather than per-number) situation.
Wouldn't that be beyond the scope of void/status/unused?

/Niall

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 9 Nov 2006 15:53:29 +0100

Exactly
 
Richard

Von: Niall O'Reilly [mailto:[email-masked]]
Gesendet: Do 09.11.2006 15:18
An: Ed Guy
Cc: Niall O'Reilly; Stastny Richard; [email-masked]; Livingood, Jason; lconroy; Otmar Lendl; [email-masked]
Betreff: Re: [Enum] void-02 new version

/Niall