Subject: [Enum] Regular Expression Pattern

From: [email-masked]
Date: Fri, 1 Sep 2006 21:18:08 +0530

Hi,
 I have a question regarding the Regular Expression field in the NAPTR 
Record received as a response to the DNS query.
 
The Regular Expression is always applied to the AUS. 
The AUS for an Enum query is converted into a  domain name according to 
the Algorithm specified for converting the e164 number  into a domain name 
(As per RFC 3761).
Now ,say we queried for NAPTR records after converting a global e164 
number into a domain name (using the top level domain name - e164.arpa). 
What then is the need for the Regular Expression pattern ?  Can the 
pattern part  of the Regular expression be fixed as "^.*$" which would 
mean it applies to the entire string i.e. the entire Domain Name that was 
queried for.
 Specially in case when Non - terminal records are not handled , would any 
different pattern be at all required.

Also can a terminal NAPTR record have a Regular Expression pattern other 
than as mentioned i.e. "^.*$"

  Regards,
   Vikram
"DISCLAIMER: This message is proprietary to Flextronics Software Systems (FSS) and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Otmar Lendl <[email-masked]>
Date: Sat, 2 Sep 2006 09:48:54 +0200

> than as mentioned i.e. "^.*$"

You're free to use "^.*$" to simply replace the number with a given URI.

The regexp handling is extremely handy if you use DNS wildcards in your
ENUM zone. Then one DNS record will match many different DNS queries and
thus apply to many E.164 numbers. In order to have the resulting URI
reflect the initial E.164 number, you have to use a more complex regexp.

Consider e.g. +43 1 5056416. That's our office phone number here
in Vienna. We're free to define extensions to that number, e.g.
+43 1 5056416 33 is my desk phone. Austria uses an open numbering
plan where the length of a number isn't fixed. We could thus
use two single ENUM entries to cover all our needs:

; main number
6.6.1.4.6.5.0.5.1.3.4.e164.arpa. NAPTR 10 10 "u" 
            "E2U+sip" "!^.*$!sip:[email-masked]!" .
; all extensions:
*.6.6.1.4.6.5.0.5.1.3.4.e164.arpa. NAPTR 10 10 "u" 
            "E2U+sip" "!^\\+4315056416(.*)$!sip:extension-\\[email-masked]!" .

This maps +43 1 5056416 XY to sip:[email-masked]

[The use of wildcards in the DNS is quite controversal, our experience
with open numbering plans tells us that you can't avoid them, though.]

> "DISCLAIMER: This message is proprietary to Flextronics Software      
> Systems (FSS) and is intended solely for the use of the individual to 
> whom it is addressed.
[...]

That's a creative way of writing "Our legal department is clueless."

/ol
-- 
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >