Subject: [Enum] Last Call: 'ENUM Validation Architecture' to Informational RFC (draft-ietf-enum-validation-arch)

From: The IESG <[email-masked]>
Date: Wed, 16 Aug 2006 17:59:45 -0400

The IESG has received a request from the Telephone Number Mapping WG to 
consider the following document:

- 'ENUM Validation Architecture '
   <draft-ietf-enum-validation-arch-03.txt> as an Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by 2006-08-30.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-enum-validation-arch-03.txt

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "chenhui" <[email-masked]>
Date: Tue, 22 Aug 2006 18:27:35 +0800

Dear Alex, Bernie and all,

Quite important draft to promote ENUM application!

We studied this draft and had a discussion. Here are some questions and suggestions for you:

1. The data flow of validation process says "A Validation Entity may choose to perform all communication with the Assignee via the requesting Registrar rather than contacting the Assignee by itself." in last paragraph of Sec 4.3, but actually Figure 4 of Sec 5.2 shows VE directly communicates with Assignee.
   We are not clear that how does VE directly communcates with Assignee, or that VE draws the effective validation inforamtion out of the Assignee/Registrant's registration information from Registrar.

2. It says VE possess the validation function, but the description of VE in the implementation  seems VE is only an agent to preform validation, such as Figure 4 of Sec 5.2 that VE fetches information from NAE and Assignee.
----suggestion: VE possess validation database as the third validation center, and need not to inquire of other entities about the assignee's information during validation process.

3. Sec 2 requirement mentions "recurring validation" or "revalidation", and Sec 4.1 describes revalidation workflow. We think it is rather complex when expiration of E.164 number and expiration of ENUM domain name both need to be considered.
----suggestion: Period of E.164 number validity need to be refered only when E.164 number is assigned. And after registration of ENUM domain name and ENUM services, E.164 number validity equals to ENUM domain name/services validity.

4. The different entities have different demands of benefit, so it is difficult to level the relation of each entities in ENUM provision model, especially Registry, Validation Entity and Number Assignment Entity.
----suggestion: Registry has the right to delegate NAE, and NAE is also the VE.

The following figure explains our point of view:
        +----------+
        | Registry | \
        +----------+  \ 
             ^         \ 
             |          \
             |           \
             |            \ 
             |             \
             |              \
             |               \ 
             |                \ 
             |(8)              \(9)
             |                  \ 
             |                   \
             |          (6)       v
        +-----------+ ---------->+---------+
        | Registrar |<---------- | NAM(VE) |
        +-----------+   (7)    > +---------+
             ^                     ^  |
             |                     |  |
             |                     |  |
             |(5)                  |  |
             |                  (2)|  |
             |                     |  |
             |                     |  |
             |                     |  |
             |                     |  |(3)
             |                     |  |
             |                     |  V
       +------------+    (4)     +---------+ 
       | Assignee = |<---------- |  NAAE   |
       | Registrant |----------> |         |
       +------------+    (1)     +---------+

         NAM: Number Assignment Management
         NAAE:  Number Assignment Agent Entity
         VE:   Validation Entity

   (1) The Assignee applys for an E.164 number from NAAE and submits personal particular information .
   (2) NAAE sends Assignee's information and the applied E.164 number to NAM.
   (3) NAM checks whether the E.164 number has been assigned in its Validation database, if not-assigned adds record in database(Assignee's information and the applied E.164 number are used as validation information, and period of ENUM validity is created) and returns successful result, otherwise returns failed result.
   (4) NAAE tells Assignee the result got from NAM.
   (5) The Assignee applies the corresponding ENUM domain name at a ENUM Registrar.
   (6) The Registrar requests validation at NAM(VE).
   (7) The VE verify that the Assignee of the E.164 number corresponds to the Registrant of the ENUM domain name and return result.
   (8) The Registrar sends an ENUM registration request to the Registry. Additional information about the validation process might be sent along with the registration request.
   (9) Finally, Registry sends to NAM the information that the certain E.164 number has been used.(this information is used to renew period of ENUM validity)

The benefits of our opinion are as following:
1.Registry gets delegation from government and answer for the whole process of ENUM number assignment and ENUM domain name registration, which can avoid benefit and responsibility of different entities.
2.Unification of ENUM number expiration and ENUM domain name expiration can reduce operation and combine the ENUM number and ENUM domain name/ENUM services.
3.Independence of VE provides rather absolute validation database, and is useful for management and validation of ENUM application.

We just bring out some thinking, and if any different opinion, let's discuss further.

Yours sincerely 

Chenhui, Wangfeng, Chenliang