Subject: [Enum] Erratum in RFC 4114: <replacement> vs. <repl>

From: Otmar Lendl <[email-masked]>
Date: Wed, 28 Jun 2006 16:08:58 +0200

FYI,

The XML element name for the NAPTR "Replacement" field is not
consistent throughout the document. The text describes
the element name (in 3.1.2., 3.2.1., and 3.2.5.) always as 

   -  An OPTIONAL <e164:replacement> element that contains a NAPTR
      replacement value.

The XML schema contains the following definition:

     <complexType name="naptrType">
       <sequence>
         <element name="order" type="unsignedShort"/>
         <element name="pref" type="unsignedShort"/>
         <element name="flags" type="e164:flagsType"
          minOccurs="0"/>
         <element name="svc" type="e164:svcType"/>
         <element name="regex" type="e164:regexType"
          minOccurs="0"/>
         <element name="repl" type="e164:replType"
          minOccurs="0"/>
       </sequence>
     </complexType>

There is thus a conflict whether <e164:replacement> or <e164:repl>
is the correct element name.

The examples in the RFC do not use this optional element.

---

Before I send this to the RFC errata page: What is more
normative? The text or the schema? 

The Austrian Infrastructure ENUM Registry has used the
schema as basis for the implementation.

/ol
-- 
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 28 Jun 2006 10:52:23 -0400

Otmar,

The schema is what counts.  The text will need to be corrected at an
opportune time.

-Scott-

> -----Original Message-----
> From: Otmar Lendl [mailto:[email-masked]] 
> Sent: Wednesday, June 28, 2006 10:09 AM
> To: [email-masked]; Hollenbeck, Scott
> Subject: Erratum in RFC 4114: <replacement> vs. <repl>
> 
> 
> FYI,
>