Subject: RE: [Enum] How to correctly set up the request URI?

From: "Creighton, Tom" <[email-masked]>
Date: Fri, 2 Jun 2006 15:59:34 -0400

Comments below.

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Friday, June 02, 2006 15:41
> To: Creighton, Tom; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Enum] How to correctly set up the request URI?
> 
> Tom,
> 
> being in favor of the usage of an AoR in Infrastructure ENUM, I have
no
> problems with your proposed words. There are only two issues:
> 
> 1. There will be some people objecting, I assume.

[Tom Creighton wrote:] 

I welcome any comments or recommendations that anyone has to help move
beyond this discussion.  

> 2. Where should this words go?
> -in the ENUM requirements or in the SPEERMINT requirements?

[Tom Creighton wrote:] 

My initial reaction would be to keep it in SPEERMINT as this is a
peering architecture issue and not a specific ENUM protocol issue, but
as you said, advice from the 4 chairs would be appreciated.

> 
> could the esteemed chairs of the two WGs please give their advice?
> 
> -sta
> 
> ________________________________
> 
> Von: Creighton, Tom [mailto:[email-masked]]
> Gesendet: Fr 02.06.2006 21:19
> An: Stastny Richard; [email-masked]
> Cc: [email-masked]
> Betreff: RE: [Enum] How to correctly set up the request URI?
> 
> 
> 
> Richard:
> 
> All examples aside, I attempted to craft some words that would not set
> any limitations on what can or cannot be used in the host portion of a
> SIP URI while maintaining a consistent method for resolving whatever
is
> used in the host portion of a SIP URI.
> 
> When a SIP URI is used in Infrastructure ENUM, the procedures outlined
> in RFC3263 MUST be followed for locating a UAS that will accept a
> request for the given URI.  For providers assuming the role of a UAS,
> this means that they MUST provision RFC3263 compliant NAPTR records
and
> SRV records that correspond to the host portion of the SIP URI
> provisioned in Infrastructure ENUM.  For providers assuming the role
of
> a UAC, when a query to Infrastructure ENUM returns a SIP URI, they
MUST
> follow the procedures outlined in Section 4 of RFC3263 to determine
the
> IP address, port, and transport protocol of a UAS that will accept a
> request for the given URI.
> 
> Please let me know what you think.
> 
> Regards,
> 
> Tom
> 
> > -----Original Message-----
> > From: Stastny Richard [mailto:[email-masked]]
> > Sent: Thursday, June 01, 2006 09:06
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [Enum] How to correctly set up the request URI?
> >
> > Folks,
> >
> > Question for clarification:
> >
> > In the discussions here on how to populate sip URI in Infrastructure
> > ENUM to derive the Call Routing data for SPEERMINT  two
> > lines of thought exist:
> >
> > The Enumservice SIP in Infrastructure ENUM should contain
> > 1. the address-of-record of the user: e.g. sip:[email-masked]
> > 2. the ingress point into the provider network:
> > e.g. sip:[email-masked]
> >
> > The originating UAC has in this case set the To: field to
> > tel:+4319793321 and the Request-URI to e.g.
> > sip:+4319793321provA.net;user=phone. This caused the
> > ENUM query at the proxy of provider A
> >
> > The question is how the proxy of provider A is now
> > setting up the request URI in cases mentioned above?
> >
> > Does the UAS from provider B accept calls to sbc7411.provB.net,
> > or must the request URI set to the proper AoR as described in
> > 8.2.2.1 of RFC 3261? If yes, only option 1 is possible in ENUM.
> >
> > I would also like to draw the attention to section 3 of
> > RFC3761 (SIP Enumservice) explaining the usage of AoR in
> > ENUM.
> >
> > Regards
> >
> > -sta
> >
> >
> > _______________________________________________
> > enum mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 2 Jun 2006 16:59:09 -0400

This discussion is best kept in SPEERMINT. IMHO.

s/

your bewildered ENUM WG co-chair