Subject: SV: [Enum] ENUM Working Group Last call on Infrastructure ENUMRequirements

From: <[email-masked]>
Date: Tue, 11 Apr 2006 13:05:30 +0200

HELLO
We have some small comments on the I-D that now is on last call.
Our comments follow the present structure of the ID.

Clause 1.1
The second paragraph of 1.1 could be updated so E.164-number for mobile service are included - see example below:
The "carrier of record" will typically be a service provider authorized to issue E.164 numbers for the provisioning of fixed (PSTN/ISDN) and mobile (PLMN) communication services under the authority of a National Regulatory Authority (NRA), but generally exhibits one or more of the following properties:

We are not so familiar with term "carrier of record" and the last paragraph in 1.1 states that NRA shall ultimately determine this. We think this I-D needs to define "carrier of records" and exactly explain its meaning. The paragraph above gives the impression that the term is a term of an SP (service provider).

Clause 1.2
Is it correct understanding that the "infrastructure ENUM namespace" could be in the .e164.apra used for User ENUM or in another public tree, but should it only be in ONE or in many public trees?

Later in this paragraph we think it is appropriate to delete the term "closed" before NGN and also add mobile networks, i.e. PLMN.

Clause 2
In 6) - we think "PLMN applications" could be added.
In 7) the meaning of "discovery of unlisted numbers" is unclear and might further description.
In 8) B) only "open numbering plan" are mentioned but we hope the I-D also cover "closed numbering plan".
In 8 F) and G) the terms "end-user ENUM" and "private ENUM" are used - this terms, together with User ENUM and infrastructure ENUM could be defined in this I-D/RFC.

Clause 3
The statements in the second paragraph about register all allocated number to avoid identification of unlisted numbers is a little bit unclear - please explain this better in the I-D/RFC

Clause 5
The I-D author could correct the version number of [3] of ITU-T Recommendation E.164 as he also is the editor of E.164.

Sincerely
Joakim Strålmark
Swedish Administration/NRA
Tel. +46 70 811 40 64 

-----Ursprungligt meddelande-----
Från: Richard Shockey [mailto:[email-masked]] 
Skickat: den 25 mars 2006 21:52
Till: [email-masked]
Kopia: Cullen Jennings; =?ISO-8859-1?Q?Patrik_F=E4ltstr?=; öm; Peterson,Jon
Ämne: [Enum] ENUM Working Group Last call on Infrastructure ENUMRequirements

	Title		: Infrastructure ENUM Requirements
	Author(s)	: S. Lind, P. Pfautz
	Filename	: draft-ietf-enum-infrastructure-enum-reqs-01.txt
	Pages		: 8
	Date		: 2006-3-23
	
This document provides requirements for "infrastructure" or "carrier"
ENUM (E.164 Number Mapping), defined as the use of RFC 3761
technology to facilitate interconnection of networks for E.164 number
addressed services, in particular but not restricted to VoIP (Voice
over IP.)

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-enum-infrastructure-enum-reqs-01.txt

The intent of the last call is to solicit comments before submitting the
ID to the IESG as a Proposed Standard.

This document has been under extensive discussion since early 2005.

The purpose of a working group Last Call is in the style of "speak now
or forever hold your peace" in case there are fundamental objections
which have not gotten previous or adequate discussion, or minor errors
which need correction.

Work group last call will extend for 3 weeks or so from Monday Mar 27
until at least April 17 though we can modify that if new issues come up.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Thu, 13 Apr 2006 17:02:14 -0400

Joakim:
Thanks for your comments. Let me see if I can  begin to address them in-line below.

Penn 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, April 11, 2006 7:06 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; =?ISO-8859-1?Q?Patrik_F=E4ltstr?=; [email-masked]; [email-masked]; [email-masked]
Subject: SV: [Enum] ENUM Working Group Last call on InfrastructureENUMRequirements

HELLO

Clause 1.1
The second paragraph of 1.1 could be updated so E.164-number for mobile service are included - see example below:
The "carrier of record" will typically be a service provider authorized to issue E.164 numbers for the provisioning of fixed (PSTN/ISDN) and mobile (PLMN) communication services under the authority of a National Regulatory Authority (NRA), but generally exhibits one or more of the following properties:
>> We had intended "PSTN" to cover both fixed and mobile E.164 numbers. I don't mind 
>> calling out PLMN as well if you feel that would be clearer.

>> My preference would  have been to say that the Carrier of Record is the entity that 
>> provides the PSTN/PLMN point of interface for other carriers to deliver calls to. 
>> This can become complicated in situations where there is number portability without a
>> central number portability database or where resale is involved. What entity should
>> be the CoR in these cases might be argued, which is why we said the NRA may have to 
>> decide. There may also cases where there may be no PSTN PoI. In the US
>> we can easily operationalize the definition of CoR based on the industry routing
>> databases (LERG and NPAC), but, in trying to be general we wound up with the more 
>> provisional definition you currently see in the I-D. 

Clause 1.2

>>It should only be in one place. While the doing something in e164.arpa (e.g., 
>>c.e164.arpa or even non-terminal NAPTR records has not been ruled out), I think it most
>> likely that infrastructure apex would be something else under .arpa e.g., ie164.arpa.

>>our point here was to indicate that the destination might not be part of the Internet

Clause 2
>>Our concern here was prompted by that of US regulators who worry that, if only
>> active numbers are listed in infrastructure ENUM, unscrupulous parties could compare
>> infrastructure ENUM registrations against directory listings and thus identify
>> numbers in ENUM w/o corresponding directory listings to be unlisted numbers
>> and launch telemarketing calls. 
>>We intend to cover closed as well. Open plans are specifically cited because they raise
>> issues for certain potential solutions (i.e., non-terminal NAPTRs). We'll change this
>> to read "open as well as closed"

Clause 3

Clause 5

Sincerely
Joakim Strålmark

-----Ursprungligt meddelande-----
Från: Richard Shockey [mailto:[email-masked]] 
Skickat: den 25 mars 2006 21:52
Till: [email-masked]
Kopia: Cullen Jennings; =?ISO-8859-1?Q?Patrik_F=E4ltstr?=; öm; Peterson,Jon
Ämne: [Enum] ENUM Working Group Last call on Infrastructure ENUMRequirements

--

---

From: Richard Shockey <[email-masked]>
Date: Mon, 17 Apr 2006 13:34:18 -0400

> Thanks for your comments. Let me see if I can  begin to address them in-line below.

Penn ..I'm assuming you want to incorporate these remarks into a new version?

That would not be a problem and we would not have to extend last call to 
accommodate that.

--