Subject: [Enum] [Fwd: I-D ACTION:draft-haberler-carrier-enum-02.txt]

From: Richard Shockey <[email-masked]>
Date: Wed, 08 Mar 2006 21:43:02 -0500

-------- Original Message --------
Subject: I-D ACTION:draft-haberler-carrier-enum-02.txt
Date: Wed, 08 Mar 2006 18:50:01 -0500
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: Combined User and Carrier ENUM in the e164.arpa tree
	Author(s)	: M. Haberler, R. Stastny
	Filename	: draft-haberler-carrier-enum-02.txt
	Pages		: 18
	Date		: 2006-3-8
	
ENUM as defined in RFC3761 [1] is not well suited for the purpose of
    interconnection by carriers, as can be seen by the use of various
    private tree arrangements based on ENUM mechanisms.  A combined end-
    user and carrier ENUM tree solution would leverage the ENUM
    infrastructure in e164.arpa, increase resolution rates, and decrease
    the cost per registered telephone number.  This document describes a
    minimally invasive scheme to provide both end-user and carrier data
    in ENUM.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-haberler-carrier-enum-02.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of 
the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-haberler-carrier-enum-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-haberler-carrier-enum-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: lconroy <[email-masked]>
Date: Fri, 10 Mar 2006 14:32:03 +0000

Hi Richards, Michael, folks,
  I like this document. I do, however, think that there's a typo in
section 7 (specifically in example 2). At present, example 2 shows:
-------------
    $ORIGIN 7.e164.arpa.
    @         IN   NS      ns1.enum.ru.
    @         IN   NS      ns2.enum.ru.
    ; Branch location record at CC level
    @         IN   BLR  0 "carrier" "e164.arpa"

    carrier   IN   NS      ns1-ce.enum.ru.
    carrier   IN   NS      ns2-ce.enum.ru.
-------------

I think that these last two lines are wrong.
Shouldn't these be replaced by...:
-------------
    $ORIGIN carrier.e164.arpa.
    7         IN   NS      ns1-ce.enum.ru.
    7         IN   NS      ns2-ce.enum.ru.
-------------

This highlights the main complication you mention in section 4
(in the discussion of your option 1) - it requires IAB, RIPE, and
no doubt ITU to be involved. Perhaps tag on a note to this example?:
-------------

    Note that the NS records for the delegated name servers ns1- 
ce.enum.ru.
    and ns2-ce.enum.ru. are within the "parent" carrier zone  
maintained by
    RIPE, and so will require approval from IAB and ITU for these  
records
    to be inserted.
-------------

Does this make sense, and/or am I misunderstanding the scheme?

all the best,
   Lawrence

On 9 Mar 2006, at 02:43, Richard Shockey wrote:
> [email-masked] with the word unsubscribe in the body  
> of the message.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
>