Subject: Re: [Enum] a suggestion re: using flags to distinguish post-ENUMsignaling f lows

From: "Stastny Richard" <[email-masked]>
Date: Tue, 7 Feb 2006 19:54:29 +0100

>Something like E2U+sip:pstngw
 
I thought E2U+sip:pstn
is pointing to a gw service already
 
>URI extentions or Enumservice definitions are the way to go

E2U+mms:mailto:mx ?
or mailto:[email-masked];mx=yes/no ?

E2U+sip:srv 
or sip:[email-masked];srv=yes/no
 
Richard

________________________________

Von: [email-masked] im Auftrag von Richard Shockey
Gesendet: Di 07.02.2006 19:36
An: Stafford, Matthew
Cc: [email-masked]; [email-masked]; lconroy
Betreff: Re: [Enum] a suggestion re: using flags to distinguish post-ENUMsignaling f lows

> ==> I take your point regarding the headaches w/changes to clients.
> ==> However, I'm not sure I agree that this is limited to carrier/infra-
> ==> ENUM, at least if we think of that in terms of traditional telcos/
> ==> cellcos. For example, does this discussion really bear no relevance
> ==> to enterprise applications (e.g., I want to call into my company's
> ==> IP PBX while I'm on the road?)
>
> It appears that the proposed 'g' flag is appropriate only for SIP use
> within Carrier ENUM, so one could WELL argue that this is an issue for the
> SIP URI - I don't see how it can be used for other Enumservices (like
> email:mailto, for example). Perhaps adding a SIP parameter (akin to ;user=phone)
> would be more appropriate, or adding a new Enumservice to run alongside the
> existing SIP one (i.e. to develop a new Enumservice definition RFC to specify
> a SIP Gateway service)?

That would be my strong recommendation.

Something like E2U+sip:pstngw

>
> ==> That would have a similar effect to the flag proposal, in the sense
> ==> that the contents of the ENUM NAPTR offer guidance on what to do next
> ==> (which is really what I'm after)
>
> ==> For the sake of discussion, here's a similar example using the
> recently-==> standardized Enumservice mms:mailto... an 'm' flag
> indicating that the ==> NAPTR recipient should now look for an MX
> Resource Record.

Lets not even start a discussion over using the flag field ..I do't
think that will go very far. IMHO a non starter.

URI extentions or Enumservice definitions are the way to go

> all the best,
>    Lawrence
--

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Tue, 07 Feb 2006 14:07:06 -0500

> is pointing to a gw service already

Good point! I forgot about that definition.

--