Subject: RE: [Enum] Re: URI Portability

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 8 Feb 2006 14:06:00 -0500

Otmar,

What do you think are the chances of my getting the [email-masked],
hammer.net, hammer.org, ... domain name?

The problem is only shifted.

Mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Otmar Lendl
> Sent: Wednesday, February 08, 2006 12:48 PM
> To: [email-masked]
> Subject: Re: [Enum] Re: URI Portability
> 
> On 2006/02/08 18:02, [email-masked] wrote:
> > Richard,
> > 
> > I must be missing something.  As far as I know, 
> individually-owned or 
> > company-owned domain names ARE portable.  I can have any service 
> > provider run a web server for my domain.  I can have a separate 
> > provider handle my email.  I can have lots of providers 
> handle lots of 
> > different services for me, and I can switch any particular service 
> > from any provider to any other at any time.
> > 
> > What kind of portability isn't already implemented?  What 
> portability 
> > functions are you looking for that aren't available today?
> 
> Have you ever asked one of the new SIP based VoIP outfits 
> (Vonage, SIPhone, Gizmo, VoIPbuster, SIPgate, ...) whether 
> their system copes with customers wanting to use their own 
> domain for the SIP URIs these services use?
> 
> I haven't seen that yet. 
> 
> The protocol support ist there, no question. But in term of 
> implementation we're at the level of email anno 1992 where 
> most people had to use user@provider as their email address.
> 
> To make things even more interesting: have a look at the the 
> IMS and all the other NGN efforts. From what I have heard, 
> these people don't want to rely on the public DNS for any of 
> their call routing decisions. They can easily build their own 
> private DNS on their GRX (or whatever) network and store the 
> domains of the carriers in there.
> 
> I can't see how such a private DNS infrastructure can ever 
> cope with people wanting to user their own domains in an IMS 
> or NGN setting. Either you duplicate the public DNS in your 
> walled garden or you abandon your "never depend on the public 
> Internet principle".
> 
> So: There is a real chance that for the near future people 
> will have no choice but use sip:user@provider as their SIP address.
> 
> I thus consider it not _that_ unlikely that regulators will 
> step in and force portability for such addresses.
> 
> Summary: Right now, E.164 numbers are still the primary 
> addressing mechanism for most SIP/VoIP services. Once that 
> starts to change and people start to put SIP addresses on 
> their business cards, then all providers MUST offer the 
> option of using a customer-owned domain.
> 
> Failing to support that early can spell trouble down the road.
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Wed, 08 Feb 2006 14:32:07 -0500

> The problem is only shifted.

well actually mikehammer.us is available  :-)

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 8 Feb 2006 20:42:27 +0100

> well actually mikehammer.us is available  :-)

I could offer mikehammer.at.  We kind of, eh, sell those domains.  :-)

But seriously: you have the same problem even if you use identifiers 
like sip:[email-masked]:

Which of the Mike Hammer's out there will get sip:[email-masked]?

(see also http://www.sendmail.org/faq/section3.html#3.5)

-------

The question wasn't how to get a nice address, the question is how to
get an address that you can take with you if you switch VoIP provider.

Because one way (using a customer's domain) or the other (a regulator steps in)
this will be possible.

/ol