Subject: [Enum] RE: Section 3.2 of draft-ietf-enum-enumservices-guide-00

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 28 Feb 2006 13:27:00 -0500

I would like to point out section 3.2 and ask for some specific WG
feedback.  Here is the text:

   This section MUST be included in an Enumservice registration.  In
   addition, where a given registration type has multiple subtypes,
   there MUST be a separate registration section for each subtype.  The
   following lists the sections and order of an Enumservice Registration
   section.  All types and subtypes SHOULD be listed in lower-case.

This took into account WG feedback to have a separate Enumservice
registration section for each sub-type (a given I-D could therefore have
several registrations).  

The question we now have is...  What about when there are multiple URI
schemes for a given sub-types?  

This is, for example, what was done in RFC 4002, where the URIs http and
https each had separate registrations, as each URI was tied to a
specific sub-type that matched the URI scheme.  (URI=http,
sub-type=http, and URI=https, sub-type=https)

In contrast, RFC 3764, has multiple URIs given type (no sub-type is
registered).

Our tendency is to assert that these may be guiding principles:
1.  A sub-type should always be specified.
2.  There should be a separate registration for each sub-type.
3.  There should be a separate sub-type for each URI scheme.

Thanks for your feedback,
Jason

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Monday, February 27, 2006 3:50 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Enum] I-D ACTION:draft-ietf-enum-enumservices-guide-00.txt 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Telephone Number Mapping 
> Working Group of the IETF.
> 
> 	Title		: Guide and Template for IANA 
> Registrations of Enumervices
> 	Author(s)	: J. Livingood, B. Hoeneisen
> 	Filename	: draft-ietf-enum-enumservices-guide-00.txt
> 	Pages		: 12
> 	Date		: 2006-2-27
> 	
>    This document provides a guide to and template for the creation of
>    new IANA registration of ENUM services.  It is also to be used for
>    updates of existing IANA registrations.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-enum-enumservic
> es-guide-00.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to [email-masked] with the word 
> unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> 	"get draft-ietf-enum-enumservices-guide-00.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-ietf-enum-enumservices-guide-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Tue, 28 Feb 2006 13:41:09 -0500

Jason:
Actually, one the things that I like about the current draft was the
indication (in the XML template) that sub-type was not always required
("use N/A if none") as this accommodates non-terminal NAPTRs. Thus, the
guideline,

Needs to be reworded to make clear when subtypes are or aren't required.

Penn