Subject: [Enum] ENUM Working Group Last call on ENUM Validation Architecture

From: Richard Shockey <[email-masked]>
Date: Wed, 08 Feb 2006 13:04:41 -0500

Title		        : ENUM Validation Architecture
	Author(s)	: A. Mayrhofer, B. Hoeneisen
	Filename	: draft-ietf-enum-validation-arch-01.txt
	Pages		: 17
	Date		: 2006-2-7
	
An ENUM domain name is tightly coupled with the underlying E.164
    number.  The process of verifying whether or not the Registrant of an
    ENUM domain name is identical to the Assignee of the corresponding
    E.164 number is commonly called "validation".  This document
    describes validation requirements and a high level architecture for
    an ENUM validation infrastructure.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-enum-validation-arch-01.txt

The intent of the last call is to solicit comments before submitting the
ID to the IESG as a Proposed Standard.

This document has been under discussion since early 2005.

The purpose of a working group Last Call is in the style of "speak now
or forever hold your peace" in case there are fundamental objections
which have not gotten previous or adequate discussion, or minor errors
which need correction.

Work group last call will extend for 2 weeks or so from today Feb 8
until at least Feb 24 though we can modify that if new issues come up.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Thu, 9 Feb 2006 09:12:57 -0500

Nice summary of the validation issue. A couple of questions for Alexander and Bernie:

1. The disjoint roles example in Section 5.2 shows the Validation Entity in communication with the Number Assignment Entity. Is your intent that such communication be considered a requirement of validation or merely one way in which it may be accomplished?

2. You may want to consider the effects of number portability on the process when the CSP is the NAE. When a number is ported, the CSP that assigned the number may no longer be in a position to verify number assignment. And yet the new CSP for the number is not the entity that originally assigned the number and was delegated the range from the NNPA. Where proper NP architectures (i.e. all-call query) have been implemented there is a database that can, if accessible to the VE, identify the current CSP. In other architectures different procedures will be required.

Penn

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Shockey
Sent: Wednesday, February 08, 2006 1:05 PM
To: [email-masked]
Cc: Patrik Fältström; Peterson,Jon; Allison Mankin
Subject: [Enum] ENUM Working Group Last call on ENUM Validation Architecture

--

---

From: "Mowafy, Hala" <[email-masked]>
Date: Sun, 12 Feb 2006 16:51:34 -0500

Alex and Bernie,

The ENUM Validation draft looks good.  This is an important topic for ENUM.

Just one clarification about the last sentence of section 3.1, where you mention it is unlikely that all CSPs will participate in the ENUM validation.  I agree, not ALL CSPs would or could.  
However, to be consistent with the expectations and roles outlined later in Sec 5.2, it would be helpful to add at the end of 3.1 that: "In some cases, the CSP may own and operate subscriber database(s) containing service information on each working number (wireline, wireless, VoIP).  Typically, other CSPs and authorized entities are allowed to access these databases, in real-time, under contract for the limited purposes of billing and validation (no marketing, data mining or otherwise).  It is conceivable that the VE would negotiate such access to those databases for fulfilling its role in validating the number assignee."

I know this standard is generic for all countries involved, but I just wanted to draw your attention to the fact that such databases exist and have been widely used in the US and Canada for other validation purposes long before the ENUM validation needs came up.

thanks
Hala

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Shockey
Sent: Wednesday, February 08, 2006 1:05 PM
To: [email-masked]
Cc: Patrik Fältström; Peterson, Jon; Allison Mankin
Subject: [Enum] ENUM Working Group Last call on ENUM Validation Architecture

--