Subject: Re: [Enum] Why not re-use interim procedures for infrastructure ENUM?

From: "Stastny Richard" <[email-masked]>
Date: Mon, 6 Feb 2006 14:27:43 +0100

Pail wrote:

>I like your way forward.  I continue to have severe reservations of the Plan B approach, ie i.c.c.e164.arpa, leaving things to >national matters. 

It is always national matters

>I think that approach is fine where the ENUM delegation hasn't been made, or where it's been made for limited trial >purposes.  In these scenarios, the choice of Tier One for commercial service could then be made according to the needs of >both user and infrastructure ENUM.

The entity responsible for the delegation may at ANY time switch the delegation. So if they requested delegation for trial and now go to commercial service and are not happy with the registry running the trial, they can request a re-delegation to somebody else

>However, where delegation has already made for commercial service, this delegation was very much made under the criteria >of the Tier One being selected for *USER* ENUM.  These criteria may or may not be applicable for infrastructure ENUM.  >For example, it is a reasonable expectation that the telcos in the country concerned may  require some degree of joint >control over the infrastructure ENUM Tier One, given its actions/performance would be critical in the routeing of calls to >their customers.  The choice of Tier One for User ENUM certainly wouldn't have factored this in, or at least if it has it would >be by co-incidence of similar stakeholder communities.
 
I sometimes get the impression that some consider User ENUM as a toy and Infrastructure ENUM as serious. In Austia and also now in Germany there are businesses depending on User ENUM and they expect both Tier 0 and Tier 1 to work appropriate. As I said above, it is up to the domain name holder (the NRA) to select a company running the Tier 1 properly in both cases, and not to have different requirements for the two. In the above mentioned option delegating below the CC still another registry running the Tier 1 may be selected, although delegated to by the User ENUM Tier 1.

On the other hand it should be noted that currently the common consensus seems to be to go for option 1 splitting
Infrastructure ENUM off at or directly below e164.arpa. So the option2 is only transitory to be used by countries who do not wnat to wait until the IAB, RIPE and ITU-T thing is sorted out, mainly because nobody now is able to say how long this might take, but the issue is urgent.

>Having the discussion at ITU may be painful....but it will be far less painful than half of the world's numbers not being in >infrastructure ENUM because the telco assignees aren't willing to participate in something that they have no influence >over....
 
We should not always blame ITU-T. First the issue hads to be sorted out with the IAB, then with RIPE and only if this is done we should bother ITU. I should be done until mid of April, but I have slight doubts ;-)

>Paul Rosbotham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Stastny Richard
Sent: Saturday, February 04, 2006 12:09 AM
To: Lind, Steven D, ALABS; Bernie Hoeneisen; [email-masked]
Subject: Re: [Enum] Why not re-use interim procedures for infrastructure
ENUM?

Bernie, Steven,

In principle Bernie is correct, but only in principle, because also Steven
has a point in stating that this is an oversimplification. and it
would IMHO unwise politically not to involve the ITU at all.

The currently envisaged way forward is

- discuss the proposal at the IETF meeting in Dallas
The IETF (and the IAB) should come to a conclusion
before RIPE and especially the ITU is involved.
(note: if this is agreed, a simple addition of one or two lines
to RFC3761 is sufficient)

- the next ITU SG2 meeting takes place first half of May 2005
so enough time to prepare a D contribution to explain
the issue. (requires IAB and RIPE to principally agree)

- if ITU SG2 accepts that the interim procedures are
also sufficient for valid requests of member states, it
may instruct the ITU TSB by stating this in the meeting
report to approve also requests to RIPE for infrastructure
ENUM delegations in the same way as it is done now for
User ENUM requests. This would be the optimum

- if ITU SG2 is not stating this in the meeting report
(this could be for various reasons, eg no decision is
made, the interim procedures need change, etc.)
the next ITU SG2 meeting is in January 2006, (because
of the ITU Plenipot Meeting in Fall in Turkey)

- in this case we could still proceed with option 2.

best regards
Richard Stastny

This e-mail has been scanned for viruses by the Cable & Wireless e-mail security system - powered by MessageLabs. For more information on a proactive managed e-mail security service,  visit http://www.cw.com/uk/emailprotection/

The information contained in this e-mail is confidential and may also be subject to legal privilege. It is intended only for the recipient(s) named above. If you are not named above as a recipient, you must not read, copy, disclose, forward or otherwise use the information contained in this email. If you have received this e-mail in error, please notify the sender (whose contact details are above) immediately by reply e-mail and delete the message and any attachments without retaining any copies.

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Tony Rutkowski <[email-masked]>
Date: Mon, 06 Feb 2006 08:52:57 -0500

Hi Richard,

>The entity responsible for the delegation may at ANY time switch the 
>delegation. So if they requested delegation for trial and now go to 
>commercial service and are not happy with the registry running the 
>trial, they can request a re-delegation to somebody else

Sage advice.

In the U.S., as in many countries, anyone can
get an authorization to do ENUM trials.  They are
intended only to demonstrate and test technology
- usually with performance measurements for use
in subsequent proceedings.

National public ENUM infrastructure platforms
will be determined through regulatory agency
proceedings and be expected to meet existing
infrastructure requirements.  Infrastructure
trials don't get morphed into national
operational systems.

--tony

---

From: Richard Shockey <[email-masked]>
Date: Mon, 06 Feb 2006 08:57:25 -0500

Stastny Richard wrote:
> Pail wrote:
> 
>> I like your way forward.  I continue to have severe reservations of the Plan B approach, 
ie i.c.c.e164.arpa, leaving things to >national matters.
> It is always national matters

Exactly

>
> We should not always blame ITU-T. First the issue hads to be sorted out with the IAB, 
then with RIPE and only if this is done we should bother ITU. I should 
be done until mid of
April, but I have slight doubts ;-)

Richard is again right ..we should not blame the ITU-T for being what 
they are. In fact they seem to be running aspects their operation better 
than the IETF.

The simple fact is the procedures we have in place right now are working 
remarkably well. Far beyond the expectations of those of us that wrote 
the rules in the first place.

However the "issue" as you call it Richard IMHO would not lie with the 
IAB. You should re read the charter of the IAB.

It would lie with the IESG upon creation of the appropriate RFC that 
designated an Infrastructure apex. If the RFC is approved there is 
little or nothing the IAB can do to impede its deployment.

Certainly there would have to be renegotiations of various agreements 
but the working model is in place and could be reasonably modified.

So long as the fundamental principal of respect for the national 
sovereign rights of Nation States to regulate the use of their portions 
of the E.164 plan is maintained and preserved I do not see a lot of 
problems at the ITU, only be the usual problems of gratuitous bashing of 
United States policy over control of the root.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<