Subject: RE: [Enum] General question on Enumservices

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 24 Feb 2006 18:57:48 -0500

In the end, which number/name is the index (business card) to the others
is arbitrary.

The choice of E.164 number is an artifact of the fact that phones have
keypads (0-9, #, *) and most of the world uses phones, while access to
computers is not as universal.

Beyond that, the main concern is to have an address associated with a
protocol (need that clue) that can be used to further the
communications.

Mike

> -----Original Message-----
> From: Tony Rutkowski [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 5:47 PM
> To: Stastny Richard; [email-masked]
> Subject: Re: [Enum] General question on Enumservices
> 
> Hi Richard,
> 
> >2. USER ENUM is for the End User = Customer The service is providing 
> >him a domain in ENUM He is willing to pay for this only if 
> it gives him 
> >some value the more value (more potential use) he gets out 
> of it, the 
> >more he is willing to use it AND in addition the user is pointing in 
> >ENUM again to services. So the more services he may point to, the 
> >better for service providers
> 
> All of this is nice in theory.  However, it's apparent that 
> the nature of the services being provided as well as the 
> interactions among multiple kinds of providers of services 
> associated with a single number is significantly more complex 
> for both the user and providers involved, as well as subject 
> to all kinds of authentications as part of the associated
> administrative processes.   Someone will bear those costs
> and it's not clear who will want to get left "holding the 
> bag" for some flat rate, and be unable to charge for 
> supplementary services.  So the cost model remains unclear.
> 
> Additionally, all the nations of the world add substantial 
> regulatory, justice, and security burdens on top of this 
> identifier system that get more complex and extensive by the 
> day.  (Check out today's FCC delegation of number
> pooling to the State Commissions.)   At last check, these
> burdens include:  number portability, priority access, 
> roaming, directory assistance, callerid, disability 
> assistance, language preference, personal emergency 
> (E112/911), law enforcement assistance (including data 
> retention in many countries), public emergency alerts, 
> donotcall, intercarrier compensation, service provider specification.
> 
> ENUM is cool.  However, the administrative challenges and 
> sorting out of the associated burdens and costs is non-trivial.
> 
> --tony 
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Fri, 24 Feb 2006 21:40:01 -0500

> computers is not as universal.

and E.164 numbers are linguistically neutral. We cannot forget there are 
two globally reckonized naming and addressing schemes for 
communications. E.164 and the ICANN domain root.

ENUM is the definitive mapping between the two.

All others are private silo, such as most IM or P2P systems and skype. 
These have their place in the world.
> protocol (need that clue) that can be used to further the

I have to admit that some of this discussion over Enumservice 
registrations is mildly amusing to me. I too have vacillated between 
what is caller vs called party control of communications and I tried to 
touch on this in my security and privacy draft that I'm continuing to 
review.

I see no reason to restrict what Enumservices should be registered 
..this is what markets are for.  We will not decide what prevails.

 >> sorting out of the associated burdens and costs is non-trivial.

Tony .. you admitting that ENUM is 'cool' after all these years is high 
praise indeed. :-) Many of us remember when you thought otherwise.

Best wishes as always,

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Tony Rutkowski <[email-masked]>
Date: Sat, 25 Feb 2006 08:02:37 -0500

Hi Richard,

>and E.164 numbers are linguistically neutral. We cannot forget there 
>are two globally reckonized naming and addressing schemes for 

Not quite.  There are many such schemes.
The original and still a very large one is the OID root
that emerged from Jim White's IFIPS 6.5 work.

If you want to look at definitive collections, check
the two contending "root of roots" in the form of TBL's
URN and Bob Kahn's Handles.

>Tony .. you admitting that ENUM is 'cool' after all these years is 
>high praise indeed. :-) Many of us remember when you thought otherwise.

Uh...maybe in some alternative universe you've
been visiting.

I significantly promoted the original implementation
and concept - which was Marshall T. Rose's and Carl
Malamud's TPC.INT implementation in 1994.  That was
followed by the NetNumber and WebNum variants circa
1999.  Gluing Michael's DDDS NAPTR RR concept was the
cool innovation circa 2000 - which is when my "ENUM
as Superglue" article was published in CommWeek.

My expressed concern thereafter had nothing to do
with ENUM, but rather a certain continuing obliviousness
to the real world of public network infrastructure,
and the needs of revenue earning providers, end users
(other than geeks), regulatory authorities, justice
officials, and NS/EP agencies.  That in turn requires
more than just resolver architectures and platforms;
and includes rather notably, good directory and OA&M
platforms.

So here we are in 2006.  All the concerns remain and
indeed have escalated.  You have much more involvement
by government authorities, the industry is largely
focussed on NGN, the EU has adopted a profoundly
far reaching data retention directive, the FCC is
about to a new USF scheme based on 90 cents/number
and a new statute effectively requiring CallerID for
VoIP.  The token scheme is a useful innovation to
begin dealing with some of these developments.  So
is EIDQ's E.115v2 and EREG - although IMHO E.115v2
has far more useful features.

It's time, however, to engage with the outside world
and produce capabilities that meet the needs of the
world that exists, not the one that we wish existed.

--tony