Subject: Re: [Enum] a suggestion re: using flags to distinguish post-ENUM signaling f lows

From: "Stastny Richard" <[email-masked]>
Date: Tue, 7 Feb 2006 19:50:12 +0100

>The second one is (essentially) number portability. My SIP URI can change from sip:[email-masked] to >sip:[email-masked]. As long as my phone number stays the same, it can be used to obtain my current SIP URI.

What I want to have is SIP URI portability too, or in other words: I want to have my sip URI sip:[email-masked]
hosted by one provider and the possibility to port this to another.

Especially if I am a company.
 
For more information see the ECMA christmas wish-list presented today at ETSI TISPAN:
Technical Report TR/91
Enterprise Communication in Next Generation Corporate Networks (NGCN) involving Public Next Generation Networks (NGN)
(December 2005)
http://www.ecma-international.org/publications/files/ECMA-TR/TR-091.pdf
 
and also
Technical Report TR/92
Corporate Telecommunication Networks - Mobility for Enterprise Communications
(December 2005)
http://www.ecma-international.org/publications/files/ECMA-TR/TR-092.pdf
 
The scenarios and requirements described in these two documents will not
be really easy to implement with NGNs ;-)
Of course they want to have best of both sides: peering with each other in all variants
AND in addition to be connected to an NGN, just to be on the safe side.
One could also say: the overflow traffic is for the telcos (say max 20%)
 
Richard

________________________________

Von: [email-masked] im Auftrag von Stafford, Matthew
Gesendet: Di 07.02.2006 19:20
An: Tony Rutkowski
Cc: [email-masked]; [email-masked]
Betreff: RE: [Enum] a suggestion re: using flags to distinguish post-ENUM signaling f lows

Tony- The E.164 space is a many-encumbered thing. No argument there. 

All the same, I see two benefits of E.164 numbers: although *some* mobile devices have QWERTY keyboards, many of them still don't. IMO a telephone number is far and away the easiest thing to punch into a cellphone keypad. That's the first one. The second one is (essentially) number portability. My SIP URI can change from sip:[email-masked] to sip:[email-masked]. As long as my phone number stays the same, it can be used to obtain my current SIP URI.

Best, 
Matt 

-----Original Message----- 
From: Tony Rutkowski [mailto:[email-masked]] 
Sent: Sunday, February 05, 2006 10:42 AM 
To: lconroy; Stafford, Matthew; Otmar Lendl 
Cc: [email-masked]; [email-masked] 
Subject: Re: [Enum] a suggestion re: using flags to distinguish post-ENUM signaling f lows 

Hi Lawrence, 

>The first is the process issue - what group (if any) coordinates 
>between the different DDDS applications and their uses; this topic 
... 
>3761bis. It seems that your proposal is purely for Carrier/ Infrastructure/ 
>Private ENUM; in this case, changing 3761 has unintended consequences 
>for Public/User ENUM applications. 

These are great understatements.  The use of 
E.164 identifiers, internationally and 
domestically, is subject to more statutory, 
regulatory, national security, and industry 
practice requirements than any identifier 
space in existence - not to mention well 
established institutional jurisdiction. 

The following list is a current tabulation 
of E.164 resolver-directory capability 
requirements, parsed into three categories, 
currently in play in various industry NGN 
forums.  The recently enacted EC Data 
Retention Directive, and the U.S. Prevent 
Cyberstalking law, add further complexity 
to the mix. ;-) 

best, 
--tony 

>basic resolver capability 
> 
>supplementary capability 
>         Number Portability 
>         Priority Access 
>         Roaming 
>         Quality of Service 
>         Directory Assistance 
>         CallerID 
>         Disability Assistance 
>         Language preference 
>         Personal emergency (E112/911) 
>         Public emergency alerts 
>         Law enforcement assistance 
>         DoNotCall 
>         Payment Methods 
>         Intercarrier Compensation 
>         Profile Management 
>         Presence 
>         Availability 
>         Location 
>         Push Management 
>         Digital Rights Management 
>         Device Management 
>         Authentication Credentials 
>         Information verification level 
> 
>protocol feature 
>         Authentication 
>         Auditing 
>         Multiple Syntax Support 
>         Mutiple Language Support 
>         Extensibility and Localisation Mechanisms 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Tue, 07 Feb 2006 14:05:31 -0500

> One could also say: the overflow traffic is for the telcos (say max 20%)

And ..just to make sure everyone is totally confused and bewildered by 
all of this, the SIP Forum is very close to publishing its Proposed 
Recommendation on IP-PBX to Service Provider interface.

Draft version four of the IP PBX / SP Interoperability specification is 
now available online for your review at the following URL:

The list for this document is taking final comments for the next 30 days.

http://data.memberclicks.com/bbattach/123566/sf-draft-twg-IP_PBX_SP_Interop-sibley-v4.pdf

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Dean Willis <[email-masked]>
Date: Thu, 9 Feb 2006 08:31:14 -0600

On Feb 7, 2006, at 12:50 PM, Stastny Richard wrote:

>> The second one is (essentially) number portability. My SIP URI can  
>> change from sip:[email-masked] to  
>> >sip:[email-masked]. As long as my phone number stays  
>> the same, it can be used to obtain my current SIP URI.
>
> What I want to have is SIP URI portability too, or in other words:  
> I want to have my sip URI sip:[email-masked]

It's quite easy to move stastny.com from one provider to another --  
you simply change the DNS NS, A, MX,  and SRV records appropriately,  
and you're moved. We don't even need ENUM for this, and it's not a  
peering problem ala speermint.

Having a phone number translate to a different URI requires either a  
DNS record change or an delegation, depending on which portability  
model you're using.

What is HARD to is to move sip:[email-masked] without also  
moving sip:[email-masked]. That's basically a 302 operation,  
requiring database dips at the original host, and you expect it to be  
painful.

--
dean