Subject: RE: [Enum] RE: [voipeer] I-D: Publishing SIP Peering Policy

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 11 Jan 2006 12:06:54 -0500

There MUST be some association of IP layer protocol elements to L5
traffic needs, such as low delay, packet loss etc.  If the L5 need is
real-time transmission, and that translates to a DSCP marking, then the
IP network needs to meet that need one way or another or very simply the
real-time service breaks.  The alternative is that the peering always
must include both L5 and L3 and you get a half-step instead of full-step
in evolution from PSTN to IP.

Put another way, is it really necessary to have L5 transit networks?  If
you insist that L3 always be paired with L5 for real-time, that is what
you get.

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Otmar Lendl
> Sent: Monday, January 09, 2006 6:06 PM
> To: Henry Sinnreich
> Cc: 'Michael Haberler'; 'Richard Shockey'; 'David Meyer'; 
> [email-masked]; [email-masked]; [email-masked]; 
> 'Stastny Richard'
> Subject: Re: [Enum] RE: [voipeer] I-D: Publishing SIP Peering Policy
> 
> On 2006/01/09 19:01, Henry Sinnreich <[email-masked]> wrote:
> > Otmar,
> > 
> > You say:
> > 
> > >All current protocols regarding proxy and transport 
> selection for SIP 
> > >are only based on the domain. I don't want to diverge from 
> that model.
> > 
> > What business has the broadband provider to mess with the 
> user preferences?
> > Users and enterprises pay for a certain bandwidth and 
> hopefully will 
> > have the choice to pay extra for Diff Serv and that's the end of it.
> 
> In an ideal world, yes.
> 
> > If one domain has DiffServ and the other does not, it's up to the 
> > users to continue the call or switch over to some other 
> networks, such 
> > as mobile or PSTN. And also to tell the other party to please 
> > subscribe to better broadband :-)
> > 
> > What do you think?
> > 
> 
> My problem with this idea is that "domain" in the sense of 
> SIP-servers is an application layer notion.
> 
> DiffServ is a layer 3 issue. My layer 3 network does not 
> neccessarily know which applications I run over them.
> 
> If my ISP also acts as my SIP provider, then yes: one can 
> link these two layers into one integrated QoS solution. AFAIK 
> this is one of the aims of the IMS. One of the local Austrian 
> ISPs uses this for his VoIP service: they use separate 
> VLANs/QoS planes for their VoIP offering.
> 
> My private playground is quite different: I use an Asterisk 
> installation on a box (the same one I write this mail on) 
> colocated at ISP A whereas my SIP-phone at home is connected 
> via ISP B. The gateway to the PSTN is operated by a 
> commercial provider who uses ISP C.
> If you add my ENUM nameservers, you get one more ISP into the picture.
> To top it off, I could add a SIP line to my office phone 
> which would bring our office connectivity into the game were 
> we basically run own multihomed network.
> 
> I really don't know how to get seamless QoS in such a setting.
> 
> (As you mentioned before: layer3 networks can't just trust 
> each other's DiffServ settings.)
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer > 
> ______________________________________________________________
> _______________
> List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
> User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Wed, 11 Jan 2006 12:34:11 -0500

> you insist that L3 always be paired with L5 for real-time, that is what

I dont disagree and this is exactly the point Dave Oran made in BC but I 
recall the general consensus in the room was that that specific problem 
was out of scope for speermint now but that the proposed solution should 
be able to accomodiate this requirement in the future. Which is why some 
form of general purpose XML based admission control mechanism seems 
interesting here. As part of that admission control protocol would be 
information on network state in order to permit the peering parties to 
judge whether interconnection ( under these terms at these points )is 
even possible.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 11 Jan 2006 13:01:47 -0500

The MSF is defining a scenario they hope to demonstrate, where media 
paths cross different domains from signalling. The signalling may be of 
the form visited originating network - home originating network - home 
terminating network - visited terminating network.  This typical 
scenario is an obvious example of L5 transit. Then the media path is 
optimized to run directly between the visited networks, possibly by way 
of a different transit network offering QoS based on diffserv markings 
at the egress points of the visited networks.

L5 and L3 are linked in the originating and terminating visited 
networks, but not in between.

Michael Hammer (mhammer) wrote:
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 
>