Subject: RE: [Enum] Re: [Sip] SIP AoR, tel and ENUM

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 6 Dec 2005 16:36:14 -0500

I am having trouble parsing these statements.

A provider is a provider.  I used the terms ingress and egress to
indicate some server that sits on the edge of a provider's network and
does peering to some other provider.  The usage below seems to mix
egress with originating being the network where the caller is attached.

I was noting that the called party terminal and the interconnect points
were different hosts and therefore may have different identities.  To
keep maximum flexibility, the format of those identities would need to
be fully under the control of the domain of each provider.  However,
conflating all that into a single URI in the Request-URI seemed
constraining to me.  Having three URIs in separate headers seemed the
most flexible.

Splitting.  I don't understand what got split or how.  ENUM -- Tel:URI
in, Point-of-interconnect URI out.  Put in Route header.  I only
suggested that there might be two route headers because the terminating
provider would indicate in ENUM, to get to this end-user, go to this
entrance first.  But, to get to that entrance, the originating provider
needs to determine what the corresponding exit point is from his
network, i.e. another Route header.  The format and content of that URI
is up to each provider.  The advertised entrance point is I think by
definition the (Inter-) Carrier ENUM.  The internal determination of the
exit point could be termed (Intra-) Carrier ENUM.  Maybe peering is
concerned only with the inter-carrier aspect.

The Request-URI could be a normalized public identity of the user
totally independent of interconnect naming schemes.  I was just teasing
out what are the assumptions and constraints in the original email.

Mike

> -----Original Message-----
> From: Thilo Salmon [mailto:[email-masked]] 
> Sent: Tuesday, December 06, 2005 2:06 PM
> To: Klaus Darilion
> Cc: Michael Hammer (mhammer); [email-masked]; 
> [email-masked]; [email-masked]; Stastny Richard
> Subject: Re: [Enum] Re: [Sip] SIP AoR, tel and ENUM
> 
> Richard, Klaus, et al.
> 
> Apparently, I have missed an important developlement lately. 
> 
> > What is the benefit of splitting the ENUM result (the SIP 
> URI) into a 
> > Route header and into a request URI?
> [...]
> > IMO there should be no semantic for the internal routing 
> (the routing 
> > from the main proxy to the egress proxy). This should be 
> out of scope 
> > of all WGs. Also the internal routing of the ingress 
> provider should 
> > be out of scope. The ingress provider should have SIP URI 
> which can be 
> > used to address its customers.
> 
> I absolutely second that statement. If for any reason (we all 
> have enough a vivid enough phantasy to imagine a good reason, 
> I suppose) an ingress provider wishes to feed a different set 
> of SIP URIs to each and every of his egress partners, he 
> should not be stripped of this option.
> The scenario I have in mind is one in which an ingress 
> provider chooses to encrypt the user part of all his SIP URIs 
> with a key uniquely assigns to his egress partner.
> 
> Just as Klaus I feel this complicates things and takes 
> authority over internal adressing away from the ingress 
> provider for no reason apparent (to me).
> 
> Thilo
> 

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: "Henry Sinnreich" <[email-masked]>
Date: Tue, 6 Dec 2005 16:29:34 -0600

Sorry for nitpicking:

>A provider is a provider.

A provider is a business model and att/SBC may differ from Google who uses a
different business model (which is more significant measured in $$$?).

Didn't we agree to use the term "Internet domain owner" (we could shorten to
IDOM or such)? 

Internet domains are well defined in the IETF. 
Business models for VoIP are better suited for other organizations,
consortia or innovators who work to disrupt them :-)

Thanks, Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Michael Hammer
(mhammer)
Sent: Tuesday, December 06, 2005 3:36 PM
To: Thilo Salmon; Klaus Darilion
Cc: [email-masked]; [email-masked]; [email-masked]; Stastny Richard
Subject: [voipeer] RE: [Enum] Re: [Sip] SIP AoR, tel and ENUM

Mike

> provider for no reason apparent (to me).

____________________________________________________________________________
_
List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html