Subject: RE: [Enum] please post issues from yesterdays session

From: "Creighton, Tom" <[email-masked]>
Date: Fri, 11 Nov 2005 12:28:56 -0500

What happens if the number you are performing a PSTN URI query on isn't ported?  Wouldn't you want to receive an NXDOMAIN and fall back to the PSTN anyway?
 
Also, having to add any type of response record for every number that isn't ported, would result in an enormous database on day 1.

________________________________

From: [email-masked] on behalf of McCandless, Kevin
Sent: Wed 11/9/2005 4:41 PM
To: Livingood, Jason; Alexander Mayrhofer; [email-masked]
Subject: RE: [Enum] please post issues from yesterdays session

I would also add to the list that if you perform a PSTN URI query and no
record exists that you consider a value to return.  One that comes to
mind is 'Void'.  There was a draft discussed in this working group for
the use of value.

Thoughts?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Livingood, Jason
Sent: Wednesday, November 09, 2005 1:08 PM
To: Alexander Mayrhofer; [email-masked]
Subject: RE: [Enum] please post issues from yesterdays session

I noted that during my presentation on "draft-ietf-enum-pstn-00" the
following issues were discussed and decided upon:

1.  Minor nits with the draft will be resolved and I will re-submit to
up-rev to -01.

2.  Must revisit the section on Distribution of Data to note that it may
or may not be done on a private basis.  This will be primarily
determined based on regulatory requirements in a particular country.  I
have not determined the exact wording of this yet.

3.  After fixing the nits and word-smithing #2 above (resulting in -01),
we will work on -02 with new suggested data types.  These include CNAM
and 800 number data, per feedback from Kevin McCandless.  (This would
not include Global Title Translation - which was a question raised by
the co-chair.)  The co-authors are open to any other suggestions.

Separately, the need was again confirmed for a guide to creating an
enumservice I-D.  This work will be undertaken by members of the WG in
the near future.

Regards
Jason Livingood

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Alexander Mayrhofer
> Sent: Wednesday, November 09, 2005 12:38 PM
> To: [email-masked]
> Subject: [Enum] please post issues from yesterdays session
>
> All,
>
> i'd like to ask you to post any issue which you brought up
> during yesterday's WG session on the list.
>
> that would make tracking those issues much more easier.
>
> thanks,
>
> alex
>
>
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
>

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
enum mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/enum

---

From: Jim Reid <[email-masked]>
Date: Fri, 11 Nov 2005 18:33:18 +0000

On Nov 11, 2005, at 17:28, Creighton, Tom wrote:

> What happens if the number you are performing a PSTN URI query on  
> isn't ported?  Wouldn't you want to receive an NXDOMAIN and fall  
> back to the PSTN anyway?

Nope. That only works if the number is reachable over the PSTN. If  
the number is VoIP only, it may be impossible to terminate calls to  
that number on the PSTN. This was one of the motivations behind the  
void NAPTR draft. That allows ENUM clients (such as SIP) gateways to  
make a distinction between numbers that are not entered into ENUM and  
numbers which don't have service or can't be reached from the PSTN.